Support » Plugin: Safe SVG » Plugin not working

  • Resolved amybca

    (@amybca)



    When I first installed the plugin, I was able to upload SVG files and view them in the media library, but the next day (and after), it no longer worked. SVG’s show up as broken in the media library (but they showed up before the design changed and they were no longer needed), and I can’t upload new SVGs. The designers on our project aren’t very responsive and I don’t have any graphic tools that can read SVG, so it’s better if I can get this working.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • I don’t see any SVGs linked on that page.

    Are you getting any browser console errors? (If you don’t know what that means, let me know which web browser you are using – Internet Exploder, Chrome, Firefox, etc – and I can add assistance.)

    amybca

    (@amybca)

    Right, like I said the svgs that were uploaded for that page have been removed because the design changed. I am trying to upload a new SVG for the giant banner image on that page, but when I try to upload it just fails. Chrome/Windows 10.

    Plugin Author Daryll Doyle

    (@enshrined)

    Hi @amybca,

    I’ve just tested again on the latest version of WordPress and the plugin is uploading SVGs correctly for me. That’d lead me to believe that something in your theme or another plugin is interfering with the upload process.

    Can you please try and deactivate all plugins other than Safe SVG and see if you can then upload an SVG correctly? If that works, try re-enabling them one by one until it doesn’t work again and that way we can narrow down which plugin is causing the issue.

    If that doesn’t work, can you try and revert back to a default WordPress theme such as Twenty Seventeen and see if it works then?

    If both of those don’t work then my only guess would be an incompatibility with the server although if it was working before, that’s highly unlikely.

    amybca

    (@amybca)

    I turned off all the ones I could (some are baked in, so those can’t be turned off). It made my site look like crap, but didn’t help.

    Here is the console error Uncaught (in promise) TypeError: Cannot read property ‘media’ of undefined
    at t.value (/calypso/post-editor.f42bf04304e99c32ad88.min.js:66)
    at t.__invokeOnDispatch (/calypso/post-editor.f42bf04304e99c32ad88.min.js:158)
    at Object.ID_21 (/calypso/post-editor.f42bf04304e99c32ad88.min.js:158)
    at e._invokeCallback (build.eb02ada43f180eb45ec1.min.js:53)
    at e.dispatch (build.eb02ada43f180eb45ec1.min.js:53)
    at e.handleServerAction (build.eb02ada43f180eb45ec1.min.js:1)
    at build.eb02ada43f180eb45ec1.min.js:13
    at <anonymous>

    amybca

    (@amybca)

    Note that this did work on initial install. It occurred to me VaultPress might think it is a security problem and disable it, but I didn’t see any alerts.

    Plugin Author Daryll Doyle

    (@enshrined)

    Thanks @amybca,

    That error is unrelated to Safe SVG but could be part of the problem. Are you editing your site through Calypso or the wp-admin dashboard?

    Also, without disabling all plugins and testing it’s hard to narrow down what the actual issue is. Can you try a default theme temporarily as suggested and see if that works?

    If possible, can we get a list of the plugins you can’t disable, then at least I can eye over them and see if anything stands out.

    amybca

    (@amybca)

    I don’t know what calypso actually is. When I go to wordpress.com, there’s a “my site” tab that I can use to edit pages. I can’t edit pages through wp-admin. It only seems to give access to settings on the site and its plugins.

    Plugins I can’t disable:
    Akismet Anti-Spam
    Jetpack
    Vaultpress

    I don’t know how these could be responsible, because they were all there when the plugin was working. I can see how VaultPress could do it, because it will deactivate plugins that can be a security threat, but there is nothing in history suggesting this happened.

    Plugin Author Daryll Doyle

    (@enshrined)

    Hi @amybca,

    If you’re accessing the admin area through WordPress.com then you’re actually using their custom dashboard “calypso” rather than the default WordPress dashboard which would usually be located at http://yoursite.com/wp-admin.

    Unfortunately when you use calypso, SVG images won’t load. This is because plugins have no control over the WordPress.com dashboard. In order for Safe SVG or indeed any other SVG plugin to work, you’d need to access your website dashboard directly where we can hook into the upload process.

    As an example, this is an SVG file from my own site, loaded through the WordPress.com dashboard:

    https://i0.wp.com/enshrined.co.uk/wp-content/uploads/2017/12/useTest.svg?ssl=1&w=450

    And this is the same file loaded directly as it would on my site

    https://enshrined.co.uk/wp-content/uploads/2017/12/useTest.svg

    Unfortunately there’s nothing either myself or anyone else can do to fix this issue as it resides with WordPress.com rather than being an issue with the plugin.

    If you can login to your website dashboard directly through /wp-admin then you will be able to use the plugin as intended and upload SVGs.

    Regards,
    Daryll

    amybca

    (@amybca)

    Weird. It worked for a day. Thanks anyway.

    amybca

    (@amybca)

    Ha! Guess what? Taking the information from your post above, I looked again in wp-admin, and there is actually a way in to the Media Library from there. Using that, it worked!

    THANK YOU!

    Plugin Author Daryll Doyle

    (@enshrined)

    Awesome @amybca!

    I’m glad you managed to get in and find a way to upload them directly 🙂

    I thought Calypso was supposed to save us time switching back & forth between sites. But now we spend time switching back & forth between Calypso and WP admin, and all the confusion that comes with keeping track of which interface we are using and what works where!

    I’m finding features of plugins that are not available in Calypso, but some post editing functions won’t take effect until I do them in Calypso. I’m not enjoying all this bouncing back & forth.

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.