Support » Plugin: Extended Post Status » Plugin Not Working

  • Resolved JimDeadlock

    (@jimdeadlock)


    I’ve previously been using PublishPress for extended statuses. I would like to switch to Extended Post Status (I prefer the simplicity) but when I install/activate EPS (with PublishPress deactivated) there is no Statuses option under the Posts option on the left bar of admin menu. Am I doing something wrong or is this a glitch?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Felix W.

    (@welly2103)

    Hi @jimdeadlock

    by default statuses are managed under the menu item “Settings”. A new menu item “Extended Post Status” should appear there.
    If you prefer to have the statuses menu item in the main menu, you can do that by selecting the option “Move status to main admin menu” in “Settings > Writing”.

    Greetings Felix

    Thread Starter JimDeadlock

    (@jimdeadlock)

    Thanks, I probably should have looked there… long night 🙂

    It’s working great, but one thing I’ve noticed is that when you move a post to a custom status it loses the permalink – move it back to drafts and the permalink reappears so it’s not a major issue, but perhaps worth tweaking?

    Plugin Author Felix W.

    (@welly2103)

    Hi @jimdeadlock

    I guess your custom status is not public. Permalinks are only created for publicly accessible posts. Go to the settings of your custom status and activate the checkbox “Public”, then the permalink should be generated.

    Greetings Felix

    Thread Starter JimDeadlock

    (@jimdeadlock)

    Works like a charm, thanks!

    • This reply was modified 5 months, 1 week ago by JimDeadlock.
    Plugin Author Felix W.

    (@welly2103)

    Hi @jimdeadlock

    the topic with the permalink came up again here (https://wordpress.org/support/topic/permalinks-further-issue/) I wanted to point out that now all users with the ability to edit posts should always see a permalink and also posts that are not public should still be able to be seen in the frontend by these users.

    Greetings Felix

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.