Support » Plugin: WP YouTube Lyte » Plugin not Work (Elementor created website)

  • Resolved christianzimpel

    (@christianzimpel)


    Hi There,
    I am looking for a possibility to embed Youtube videos in the law complince of the EU.
    So I found your Plugin that should do what I am looking for.

    After Install and put in the API key. nothing happens, nothing changed.
    and also if i look to the sources it contact youtube as usual.

    The Website is made with the Elementor page builder plugin. It is possible that you Plugin is not working with Pages there are made with this Page builder?

    Thank you for your time.
    BR,
    Christian

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    LYTE act on wordpress’ “the_content” Christian, so if Elementor stores the vids in a different entity, it will not work by default.

    if, like siteorigin, elementor stores videos’s in a widget, then this code snippet might help;

    
    add_action('lyte_actionsfilters','christian_lyte_force_widgets',10,0);
    function christian_lyte_force_widgets() {
    	add_filter('widget_text', 'lyte_parse', 4);
    }

    hope this helps,
    frank

    christianzimpel

    (@christianzimpel)

    Hi, Thank you for your quick responce.
    Your snipptet is CSS, PHP, Java script?

    I tryed to put it in with this plugin:
    https://www.christianzimpel.de/wp-admin/plugin-install.php?tab=plugin-information&plugin=code-snippets&TB_iframe=true&width=600&height=550

    but it shows me an error.

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    It’s PHP, you could use e.g. the code snippets plugin to add it.

    frank

    christianzimpel

    (@christianzimpel)

    it is not working 🙁
    I have to find another solution.
    Thank you.
    Christian

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    I _might_ have a look at how to force Elementor to honor LYTE, as I think I have Elementor hanging around here somewhere on my development setup 😉

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, found a workaround; add the video in an Elementor’s “Text Editor” (or shortcode) widget using the lyte shortcode;

    [lyte id="qJ_PMvjmC6M"]

    frank

    christianzimpel

    (@christianzimpel)

    It Worked! Thank you very much!
    if you are able to do it with a Short code, you are also able to make a Elementor widged right? like a addon for Elementor al lot programmer do so. that would be awesome!

    Best Regards
    Christian

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    It Worked! Thank you very much!

    you’re welcome, feel free to leave a review of the plugin and support here! 🙂

    if you are able to do it with a Short code, you are also able to make a Elementor widged right? like a addon for Elementor al lot programmer do so. that would be awesome!

    I might do that someday Christian 🙂

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin not Work (Elementor created website)’ is closed to new replies.