WordPress.org

Support

Support » Plugins and Hacks » Codestyling Localization » [Resolved] Plugin not translatning all

[Resolved] Plugin not translatning all

  • Hi,

    I have used Codestyling Localization plugin in several wordpress blogs, and first of all i have to say, that i really love this plugin – great work!

    But, on my new page with Enifinity theme and Woocommerce, it is not working properly. Some things can be translated, others can’t.
    When opening the plugin, it says:
    Loading Issue: Author is using load_textdomain instead of load_plugin_textdomain function. This may break behavior of WordPress, because some filters and actions won’t be executed anymore. Please contact the Author about that.
    This is put just beside the WooCommerce translation in the plugin. What can i do?

    http://wordpress.org/extend/plugins/codestyling-localization/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author codestyling

    @codestyling

    I need at least examples, what can’t be translated and where it is located (woocommerce or theme).
    Furthermore i can’t test the theme because it’s not a free theme and I can’t get access to it without payment.
    Please provide more detailed information, otherwise no qualified support is possible.

    Some examples are on a product page here: http://www.istilfest.dk/butik/25kg-isterninger/

    “You may also like…” and “Related Products” is translated in the plugin, but i does not show the translation. This also goes for the “Add to cart” button.

    Also, in the shop page (http://www.istilfest.dk/butik/), when hovering the product photos, “Add to cart” and “View details” shows up. I don’t know if they are in the theme or in WooCommerce.

    Do you wan’t a login to my site to test it?

    Plugin Author codestyling

    @codestyling

    Try to switch of total cache plugin or reset the cache.
    If you did newly translate it the pages won’t get the translation as long as the page get cached again from scratch.
    I don’t see any other reason, why the affected texts doesn’t appear.

    I have tried both resetting the cache and disbling the cache plugin. It didn’t do it for me.
    I’ve translated it about two weeks ago, så i should have been translated?

    Plugin Author codestyling

    @codestyling

    It could be, that the plugin does load the textdomain to late or never for your frontpage. If the load call of plugin is performed after the partial content has been generated or wasn’t loaded, than it appears at english.
    If you made translations of woocommerce and mostly they work correctly, than this may also a reason for untranslated texts.

    I’ve decided to translate them manually through the .po file instead. Thanks for your support.

    Plugin Author codestyling

    @codestyling

    I don’t understand it, because it’s contained at the scanned file and can be translated anyway. But as long as no new mo file has been generated, it won’t appear, *.po file won’t get used for translation on page, only the produced *.mo files out of.

    Yes of course, but i was editing the .po file, which makes the .mo file (as far as i understand). But that worked for me, and everything is translated know.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] Plugin not translatning all’ is closed to new replies.
Skip to toolbar