Support » Plugin: TablePress » Plugin not showing up in admin dashboard

  • Resolved webuser1

    (@webuser1)


    Greetings,

    I just installed TablePress plugin on our WordPress site.

    However, it is not showing up on our admin dashboard.

    I googled and found this link:

    https://tablepress.org/faq/tablepress-is-missing-in-the-admin-menu-on-the-dashboard/

    Followed the instruction to change plugin_options_db_version from 39 (mine is 40) to 0.

    When I scrolled down and clicked Save Changes, I got the following error message:

    The link you followed has expired.

    I googled this error and found several articles on potential fixes which include increasing Memory Limit, Upload Max Size, Max Execution time in php.ini but I kept getting the same The link you followed expired error message.

    Does anyone please have any ideas what else to try?

    Our WordPress version is current 5.4.

    PHP version 7.3. and mySQL db is 8.0

    I have disabled all plugins but kept getting same error.

    We are using Envision theme whose version is current at the moment.

    Any help is greatly appreciated.

    Unfortunately, our WordPress site is intranet and cannot be accessed from outside our firewall.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.

    That error message indicates that something in the HTTP request is not properly sent to WordPress, like the “nonce” value.

    You could try a different method of resetting the access capabilities: Please try installing the TablePress Debug Extension from https://tablepress.org/download/extension/tablepress-debug.zip
    TablePress will then be visible in the admin menu, and there will be a “Debug” tab. Please go there and enable the “Reset access capabilities” checkbox and save the changes. After that, please deactivate the Extension again, and TablePress should still be visible.

    Regards,
    Tobias

    Thread Starter webuser1

    (@webuser1)

    Hi Tobias,

    I really appreciate your prompt responses sir.

    I must apologize for my late response. I was expecting an email notification after your response but didn’t see any even though the “Notify me of follow-up replies via email” box was checked. I assumed there was no response till I just decided to check now.

    In any case, Installed and activated tablePress_debug extension plugin.

    I am able to see TP in admin dashboard but not tablePress.

    Also, I did not see any debug tab.

    Do I need to uninstall entire plugin and start all over?

    Thread Starter webuser1

    (@webuser1)

    UPDATE: I was able to see TablePress but what is weird is that it was under Pages (You know Posts and Pages).

    I have no idea why it is hiding under Pages instead of admin dashboard menu.

    Anyway, I clicked on the Debug tab, checked the box “Reset Access Capababilities”, deactivated the extension and TablePress disappeared again from Admin Dashboard Menu.

    WOW

    Thread Starter webuser1

    (@webuser1)

    LATEST UPDATE: It is now under Pages.

    This is with the debug extension deactivated.

    So, the good news is that now we can see it.

    Bad news is that it is under Pages instead of being under Admin Dashboard menu.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for checking that. If it’s under “Pages”, you can now still move it back to the main menu. That’s possible via the dropdown on the “Plugin Options” screen of TablePress 🙂

    Regards,
    Tobias

    Thread Starter webuser1

    (@webuser1)

    Awesome.

    Everything looks great now.

    Many thanks for your incredible response and help.

    Just one last question if I may, please?

    There is one of your extensions, Automatic URL Conversion.

    Our table has just ONE column that has hyperlinks.

    Can this extension be used to convert just one column into hyperlinks?

    I didn’t see any documentations about this but just I just ask.

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    good to hear that this helped!

    Sure, I don’t see why couldn’t use the Extension for that. It doesn’t care how many columns a table has and will simply convert all URLs that it finds.

    Best wishes,
    Tobias

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Plugin not showing up in admin dashboard’ is closed to new replies.