Support » Plugin: Top 10 - Popular posts plugin for WordPress » Plugin not showing the latest “top 10”

  • Resolved hbk747

    (@hbk747)


    Hello,

    Since the past week, I have noticed that the top 10 (or top 7 in my case) are staying the same. I have not made any changes to the settings and this is the first time this has happend. I am trying to test things out on my staging website.

    If you need to access it please let me know.
    The 1st in the top 7 is a post on china’s economic power and the last (7th) is on Turkey.

    Looking forward to your reply.

    Regards

    • This topic was modified 3 months ago by hbk747.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Thread Starter hbk747

    (@hbk747)

    The reason I know the top 7 are NOT accurate is becauseI have 2 posts boosted on facebook and whenever I do that, those posts slowly but surely come to the top 7. They should be 1 and 2. I checked google analytics to confirm my theory. For the last 7 days, these are the top posts/pages. Also on the plugin I always had “10” set in the “custom time period” (on the widget). Also when I change this “10” to “7” or another number, the posts change but the boosted posts still do not show up. So there is something wrong and it started a week or two ago. In the plugin settings, I always had the daily and overall trackers enabled. I have never changed these settings in the past 6-7 months.

    1) us-troop-withdrawal-from-afghanistan/ (boosted post)

    2)5th-generation-warfare-in-pakistan/ (boosted post)

    3)pakistans-foreign-policy/

    4) submit-articles/

    5)uas-challenge-2021/

    6) how-china-became-a…conomic-superpower/

    Plugin Author Ajay

    (@ajay)

    It could be possible the tracking is blocked for some reason. Are you able to turn the debug mode on in the settings page.

    Can you try switching trackers in the settings page?

    Thread Starter hbk747

    (@hbk747)

    @ajay

    I can turn the debug mode on but not sure if it works. I have turned on right now on the live site.

    As for the trackers, what do you mean by switching them? I have both daily and overall enabled. DO you want me to turn one off?

    The only plugin that could have affected it, might be austoptimize that I recently installed. Maybe that is blocking it. I have js optimization and html optimization active. CSS optimization is inactive. Do i need to add an exclusion in the js section for automptimzie?

    • This reply was modified 3 months ago by hbk747.
    Plugin Author Ajay

    (@ajay)

    In terms o trackers, you have a setting in the tracker tab which shows query variable based or Ajax based. And you can switch between these.

    This is another add on I run on my sites: https://github.com/WebberZone/top-10-fast-tracker

    This adds a faster tracker but isn’t compatible always.

    I have autooptimise on my sites, but it could the case that it does effect that the tracker isn’t always loaded. You could try to put that in the exclusion settings and test as well. My site visits are tiny

    Thread Starter hbk747

    (@hbk747)

    I switched to Ajax and still nothing changed.

    My JS exclusion list on autoptimize includes this:

    wp-includes/js/dist/, wp-includes/js/tinymce/, js/jquery/jquery.js, js/jquery/jquery.min.js, ai.min.js, themes/gutenverse

    the last one is my theme.

    What should I add (what do I type) for it to exclude top 10?

    Thread Starter hbk747

    (@hbk747)

    I am not sure what to add in the exclusions. What would i type?

    Warm regards

    Plugin Author Ajay

    (@ajay)

    You could try: top-10-tracker.min.js, top-10-tracker.js

    Thread Starter hbk747

    (@hbk747)

    @ajay Worked like a charm.

    For anyone having similar issues, yes go to autoptimize and add top-10-tracker.min.js, top-10-tracker.js to the exclusions list of the javascript section.

    Thanks Ajay.

    Take care

    Plugin Author Ajay

    (@ajay)

    Thanks for confirming @hbk747

    I think I need to do this for my sites as well 🙂

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.