• Resolved sanchitgoyal

    (@sanchitgoyal)


    Hello team

    For the couple of websites I am using this plugin “add to cart” data is not being sent correctly to facebook. The same can be checked via the Facebook pixel helper plugin in Chrome and it is also not showing during the test events check in facebook.

    If you want I can send a video of the same as well. Please check. Thanks.

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support B C. a11n

    (@battouly)

    Hi @sanchitgoyal,

    When you say “Plugin not sending “add to cart” data correctly via pixel” do you mean the events are not sent, or they are being sent, but the count is not correct?

    Additionally, please visit the Test Events tab from your Facebook Event Manager, open your website in a new window and test out the Add to Cart event?

    While in the Event Manager page, please check the Diagnostics tab to see if there are any issues displayed there. The tabs look like this: https://cloud.skyver.ge/L1uJWrGj

    It will be helpful if you attach screenshots of the tabs content in your reply in case the problem still persists.

    I recommend https://snipboard.io/ for easily sharing screenshots – please follow the instructions on the page, then paste the URL(s) in your reply.
    You can simply drag the image and drop it to generate a link to share.

    Thread Starter sanchitgoyal

    (@sanchitgoyal)

    Hello

    Please check this video-

    https://www.berrycast.com/conversations/b5aa74df-c071-59cd-8be7-0737b66ac267

    As can be seen the “add to cart” event does not show either in the pixel helper or in the test events tab even though the initiate checkout event is shown in both.

    However some “add to cart” events are shown in the overview tab so it means either only some events are being sent or these events are being sent very late.

    Do let Me know if further information is required. Regards.

    Plugin Support Fernando a11n

    (@fhaps)

    Automattic Happiness Engineer

    Hi @sanchitgoyal – thanks for sharing those additional details.

    Most issues we see with the AddToCart event are related to theme conflicts. A theme that utilizes custom actions or custom AJAX calls for the cart functionality can often result in this type of conflict.

    I’d recommend checking for conflicts by temporarily switching the theme of your site to the free Storefront theme. You can enable this theme directly from your site’s Dashboard at Appearance > Themes > Add new.

    Let us know if switching to the Storefront theme enables the AddToCart event to work more reliably.

    Thread Starter sanchitgoyal

    (@sanchitgoyal)

    Hello

    Thanks for the reply. Switching to Storefront resolves the problem. The theme I am using is Woodmart. So is there anything that can be done to register add to cart events using this plugin or would I need to contact theme author for the same? Regards

    Plugin Support Niall a11n

    (@wpniall)

    Hi @sanchitgoyal,

    I’m happy to hear you’ve managed to find the problem here.

    As the Facebook plugin works with a default theme like Storefront, but not the Woodmart theme, I recommend reaching out the Woodmart developers for further help, as we don’t support their theme. You should be able to reach them here:

    https://themeforest.net/item/woodmart-woocommerce-wordpress-theme/20264492/support

    Thank you!

    Thread Starter sanchitgoyal

    (@sanchitgoyal)

    Hello

    I dont think that the theme is entirely at fault here-

    1.) Add to cart events were working fine when I was using pixel via other implementations.

    2.) https://www.berrycast.com/conversations/a6511f39-e13f-5a59-96bc-959c532f9f34

    The “add to cart” seems to be working fine on staging website and not on the main website!

    Regards

    Plugin Support Niall a11n

    (@wpniall)

    Hi @sanchitgoyal,

    Hmm, is the staging site the same as the live site? By that, I mean, is it an exact copy of the live site?

    If it is the same, could you please contact us at WooCommerce.com > My Account > Support, as we’d like to take a closer at the sites and wouldn’t ask for log in details for the site here in the public forums. You may need to create an account before you can access that page.

    Please include a link to this forum thread, so that we can keep track of what’s already been done.

    We will be able to help you further there.

    Thank you!

    Thread Starter sanchitgoyal

    (@sanchitgoyal)

    Hello

    I am doing some further testing on this. Can you please confirm the following-

    1.) Is it possible to test server events on facebook to check if those are being fired correctly? For example if using pixelyoursite plugin We can check server events?

    2.) Does this plugin cause conflict when using cache plugin like same event id being sent multiple times? Thanks

    Plugin Support AW a11n

    (@slash1andy)

    Automattic Happiness Engineer

    Hey again!

    Please follow the above request, which is

    could you please contact us at WooCommerce.com > My Account > Support, as we’d like to take a closer at the sites and wouldn’t ask for log in details for the site here in the public forums. You may need to create an account before you can access that page.

    Please include a link to this forum thread, so that we can keep track of what’s already been done.

    We will be able to help you further there.

    Thread Starter sanchitgoyal

    (@sanchitgoyal)

    Hello

    I have submitted support request. Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Plugin not sending “add to cart” data correctly via pixel’ is closed to new replies.