Support » Plugin: Yoast SEO » Plugin not generating sitemaps since upgrade to latest version.

  • WordPress 3.5.2
    Wordpress SEO 1.4.12
    Headway 3.4.11 and 3.5.3

    Hi, I’m not getting site maps generated for a number of my sites (using latest WP and WPSEO, with various versions of the Headway theme).

    WPSEO was generating sitemaps prior to upgrade to 1.4.12 (I tested prior to updating the plugin), immediately after update, when I click through the “You can find your XML Sitemap here” button I get an error dialogue:

    This webpage is not available
    The webpage at might be temporarily down or it may have moved permanently to a new web address.
    Error 330 (net::ERR_CONTENT_DECODING_FAILED): Unknown error.

    Example sites: or

    example plugin generated sitemap url:

    I’ve tried adding the htaccess fix:

    # WordPress SEO – XML Sitemap Rewrite Fix
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    # END WordPress SEO – XML Sitemap Rewrite Fix

    – it doesn’t seem to work…

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have exactly the same problem.

    I had the same problem, disabling the sitemap functionality (save the setting) and reactivating it fixed the issue for me.

    Oh, after checking a bit it seems in your case it’s a different problem. You two guys are using Headway Themes -> try to disable “gzip Compression” in Headway – Options – Advanced and see if that helps.


    I checked disable/re-enable out of interest, it did not help.

    Disabling gzip fixed the problem and sitemaps now generate, Headway recommend leaving this on (though to be honest I’ve compared load times with GTMETRIX with and without and they didn’t vary significantly, payload was around 20% more though).

    HEADWAY (with GZIP enabled) and older versions of WordPress SEO worked happily together, generating XML sitemaps – any idea if this issue (if it is seen as an issue) would be fixable by one of the teams (HW/Yoast).

    Thanks for your help Rubinstein.


    [Resolved] thanks Rubinstein.

    1.4.13 seems to resolve this. gzip back on and site maps being produced.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin not generating sitemaps since upgrade to latest version.’ is closed to new replies.