Support » Plugin: Quotes for WooCommerce » Plugin not compatible with PHP 7.3

  • My server was just updated to 7.3, and when I updated to the latest version of this plugin it disabled access to my dashboard. I received the following error:

    12 PHP Fatal error: Uncaught Error: Call to undefined function cart_contains_quotable() in /nas/content/live/WEBSITEDIR/wp-content/plugins/quotes-for-woocommerce/quotes-woocommerce.php:692\nStack trace:\n#0 [internal function]: quotes_for_wc->woocommerce_title(”, 0)\n#1 /nas/content/live/WEBSITEDIR/wp-includes/class-wp-hook.php(286): call_user_func_array(Array, Array)\n#2 /nas/content/live/WEBSITEDIR/wp-includes/plugin.php(208): WP_Hook->apply_filters(”, Array)\n#3 /nas/content/live/WEBSITEDIR/wp-includes/post-template.php(165): apply_filters(‘the_title’, ”, 0)\n#4 /nas/content/live/WEBSITEDIR/wp-content/plugins/fusion-builder/shortcodes/fusion-sharingbox.php(75): get_the_title()\n#5 /nas/content/live/WEBSITEDIR/wp-content/plugins/fusion-builder/inc/helpers.php(1919): FusionSC_SharingBox::get_element_defaults(”)\n#6 /nas/content/live/WEBSITEDIR/wp-content/plugins/fusion-builder/shortcodes/fusion-sharingbox.php(976): fusion_builder_frontend_data(‘FusionSC_Sharin…’, Array)\n#7 [internal function]: fusion_e in /nas/content/live/WEBSITEDIR/wp-content/plugins/quotes-for-woocommerce/quotes-woocommerce.php on line 692

    Any idea what this could be? It was working great before. Otherwise a great plugin.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Pinal Shah

    (@pinalshah)

    Hi @djangelic,

    I apologize for the delay in response.

    The plugin is not yet tested with PHP version 7.3. It seems one of the functions defined & used by the plugin was not found. I’ll have to analyze this further to find the root cause of the issue.

    I’ll check and get back to you with an update soon.

    Pinal

    This totally crashed my site. I had to go to phpmyadmin and delete all my plugins and enable them one by one until I figured out this was the plugin. I fixed my issue by modifying the quotes-woocommerce.php file. First by changing any include_once( ‘directory/filename.php’ ); to include_once(dirname(__FILE__) . ‘/directory/filename.php’); — However, the error on cart_contains_quotable() was still present. I copied all the functions from qwc-functions.php into the the bottom of the quotes-woocommerce.php and then commenting out the include_once(dirname(__FILE__) . ‘/includes/qwc-functions.php’); — that I had done above. It works now. Waiting an update to correct my temporary hack. At least with this my website actually works now.

    Plugin Author Pinal Shah

    (@pinalshah)

    Hi,

    I apologize for the issues cause. An update will be released soon making the plugin compatible with PHP v7.3.

    Pinal

    Plugin Author Pinal Shah

    (@pinalshah)

    Hi @jerrilynnreeves,

    Thank you for sending across the code changes which you did to get the plugin working. I’ve been trying to replicate the errors by using PHP v7.3.12 on my local and so far have not been able to replicate any warnings/errors.

    The entire process of placing a quote request, sending a quote email & completing the payment went off without a hitch and did not raise any warnings.

    I’m checking if I can find something else that will help me replicate the issue. Shall keep you posted on the update.

    Pinal

    Thread Starter djangelic

    (@djangelic)

    Thank you, I have found a workaround for now by disabling the plugin and editing the woocomerce checkout text. Looking forward to your fix. Thanks!

    Plugin Author Pinal Shah

    (@pinalshah)

    Hi @djangelic & @jerrilynnreeves,

    I’ve been unable to replicate the issue so far at my end. It would help me if you could grant me access to a staging/dev site where I can replicate the issue.

    Please send the FTP access details and WP admin access details to pinalj1612 at gmail dot com. I’ll check the issue and create a fix accordingly.

    Thanks in advance,
    Pinal

    Did you update to the latest WordPress version 5.3 as well as Woocommerce 3.8.0 and perform the Woocommerce database update as requested?

    I’m not comfortable sending FTP information to my site. I might possibly be able to get a dev site up; however, that will not be anytime soon due to other demands at work.

    Also, of note I had to comment out the loading of files for Include files in the admin side. The WordPress backend would crash out and stop when it read line 187 of the quotes-woocommerce.php file echo “<p>directory: </p>”; My admin wordpress page would just display directory: as a page, which is the lat line of code.

    Sorry for the late reply I was on vacation for our US Thanksgiving holiday. I will let you know when and if I can get a dev site up for your to see what I am seeing.

    Plugin Author Pinal Shah

    (@pinalshah)

    Hi @jerrilynnreeves,

    Yes, my site was updated to all the latest version of WP & WC. I understand that you are unwilling to send the FTP access and I would also prefer to test this on a staging/dev site instead of a production site.

    I have released an upgrade to the plugin a little while ago and it contains some code changes for including the files based on the information you had provided earlier.

    However, since I have not been able to replicate the issue, I would suggest you test the update on a staging/dev site before you upgrade the plugin version on your production site.

    Thanks,
    Pinal

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Plugin not compatible with PHP 7.3’ is closed to new replies.