Support » Plugin: W3 Total Cache » Plugin not compatible with new wordpress update (5.3)?

  • Resolved andreasra

    (@andreasra)


    Dear W3 Total Cache Team,

    Just updated WordPress to 5.3 and now get the following error when wanting to access our page:

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    Warning: Cannot modify header information – headers already sent by (output started at /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home1/admintai/public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home1/admintai/public_html/wp-includes/pluggable.php on line 1268

    Any idea? What to do know? Best to delete the plugin and wait for an update?

    Thanks in advance
    Andreas

    The page I need help with: [log in to see the link]

Viewing 14 replies - 76 through 89 (of 89 total)
  • Yui

    (@fierevere)

    ru.wordpress.org team, ru_RU support & translation

    Marko, yes, correct, that long text is from hosting FAQ about error 500.
    User has PHP 7.3

    @u0565660 , посмотрите логи ошибок сервера (ошибок PHP), на предмет ошибки в конце файла, с Fatal, если не сможете найти файл лога сами, то спросите техподдержку хостинга где он находится.
    Также убедитесь что вы устанавливаете свежую версию плагина.

    u0565660

    (@u0565660)

    Ответ службы поддержки хостинга: Переименовали файл .htaccess в .htaccess1, после чего сайт стал доступен. Рекомендуем проверить правила указанные в файле htaccess. Сайт заработал с этим плагином. Причина была в этом файле.

    • This reply was modified 3 months ago by u0565660.
    • This reply was modified 3 months ago by u0565660.
    silviya28

    (@silviya28)

    Hello,

    After renaming the plugin folder I got 2 other warnings:

    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /public_html/wp-content/advanced-cache.php.
    W3 Total Cache Error: some files appear to be missing or out of place. Please re-install plugin or remove /public_html/wp-content/db.php.

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/wp-content/advanced-cache.php:26) in /public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /public_html/wp-content/advanced-cache.php:26) in /public_html/wp-includes/pluggable.php on line 1268

    After renaming the other files there was another warning, so I renamed them back.

    Do you have a solution for that?
    Thank you!

    u0565660

    (@u0565660)

    Сайт стал загружать только главную страницу. Остальные выдали ошибку 400. Посмотрел файлы сайта. В файлах стало два файла htaccess. и htaccess1. Файл htaccess1 переместил в архив. А вот в файл htaccess. добавил стандартный код в начало:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    После этого все страницы начали загружаться. Будем думать дальше как с этим плагином работать. Идея то хорошая была )))

    • This reply was modified 3 months ago by u0565660.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @silviya28
    The mentioned files are W3 Total Cache drop-ins.
    After you update and re-enable W3 Total Cache those warnings will go away. If the warnings continue after updating, simply delete those files from the wp-content folder and W3 Total Cache will create them again.

    Hy, I am To gettting the same error as “Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home2/uduu1572/public_html/mysite.com/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8”

    After, my hosting provider automatically updated my wordpress 5.3 Version. The error is so bad it dropped my ranking and content updates are not reflecting and got stucked out badly.

    my site is: https://www.vediostatus.com anyone please help, me to solve this issue. On clicking of my site url some unwanted script loading automatically , but no homepage of my website …. anywhere.

    Thanks … Julia

    • This reply was modified 2 months, 3 weeks ago by julia765.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @julia765

    I am sorry about the issue you are having. Please update W3 Total cache to the latest 0.11.0 as the issue is fixed in that release.

    Updating to WP 5.3 I get errors from 2 different version of this plugin:
    – the current version gives me errors on the front end:

    Warning: preg_match(): Compilation failed: nothing to repeat at offset 0 in […]/plugins/w3-total-cache/PgCache_ContentGrabber.php on line 897

    The usual fix for that error is to uncheck 3 instances of “” on the Browser Cache settings page. But I already has them unchecked. 🙁 So I dunno what to do.

    The page does load, but it appears underneath all the warning messages. Also, If I “Purge All Caches” from the admin bar, it’ll load correctly, but once I click a link, or “refresh” the page, and the warnings re-appear.
    Before latest WP and plugin update, everything was fine.

    – an earlier version, breaks the backend, so I cannot even easily check the plugin version. Will need to go into the database and manually disable the plugin.

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in […]/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    Just as I was getting less apprehensive about updating WP or WP plugins… UGH.
    I hate WP updates!

    • This reply was modified 2 months, 3 weeks ago by SherylHohman.
    • This reply was modified 2 months, 3 weeks ago by SherylHohman.

    All broken sites fixed. Prevented another from breaking by following the instructions provided by Plugin Support. Only difference is that I did NOT uninstall, and reinstall.

    Here’s what I did:

    purged all caches. disabled the plugin.
    (on 2nd site I then updated the plugin – WP was already updated, but w3cache I avoided because I ran into an issue on the 1st site).
    deleted the files indicated. re-activated plugin. purged caches again.

    Now it works. Can confirm that that fixed 2 sites.

    On a 3rd (I hadn’t yet updated w3cache or WP):
    I purged, disabled plugin, deactivated, deleted files.
    Then updated plugin, then updated WP.
    (deleted files again). re-activated plugin, purged all caches.
    And, avoided all problems!

    Me, too. Two warning notices, fist below:

    “Warning: include_once(/data/23/2/24/120/2187283/user/2401782/htdocs/WordPress/wp-content/plugins/wp-super-cache/wp-cache-phase1.php): failed to open stream: No such file or directory in /data/23/2/24/120/2187283/user/2401782/htdocs/WordPress/wp-content/advanced-cache.php on line 22”

    site seems functional, but the warning is stuck on, public & admin

    have disabled all plugins, reinstalled 5.3 — same warning
    reactivated plugins — same warning
    https://www.budcrawford.com

    @budcrawford did you try what @sherylhohman did? (comment ahead of you) Just wondering…

    Here’s what she said she did:

    Here’s what I did:

    purged all caches. disabled the plugin.
    (on 2nd site I then updated the plugin – WP was already updated, but w3cache I avoided because I ran into an issue on the 1st site).
    deleted the files indicated. re-activated plugin. purged caches again.

    Now it works. Can confirm that that fixed 2 sites.

    When she says she “deleted the files indicated”, I believe those were the cache files within the plugin directory.

    Hi,
    I just updated my version and I’m getting the same error. I’m publishing off this site but now my content formatting is completely jumbled I’m not able to work on it.

    I read some of the comments on fixing plugins but I’m not even able to scroll down the page to see or access the left menu. The error messages are taking up the top 1/3 of the page.
    I’m not familiar with some of the plugin fixes mentioned in this thread. And I don’t know how to do the suggested update W3 Total cache to the latest 0.11.0.

    Will WP be issuing another update that fixes this? If so, when?
    I’m stuck here. Can someone please Help!

    Thank you,

    Hello, this thread about error after updating stops simply. What were the solutions?

    I updated WP to 5.3 and W3 Cache to newest version and get this errors:

    Warning: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 0 in /www/htdocs/USER/SITE.com/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php on line 920
    
    Warning: preg_match(): Compilation failed: quantifier does not follow a repeatable item at offset 0 in /www/htdocs/USER/SITE.com/wp-content/plugins/w3-total-cache/PgCache_ContentGrabber.php on line 920

    What is the solution for this?

    • This reply was modified 1 month, 1 week ago by Manni79.

    Also the plugin seems to be deactivated and even when I activate it and WP says it is activating is, after refresh of plugins overview in shows like it is deactivated. Any ideas about that regarding to that “PgCache_ContentGrabber.php on line 920” error?

Viewing 14 replies - 76 through 89 (of 89 total)
  • You must be logged in to reply to this topic.