Support » Plugin: W3 Total Cache » Plugin not compatible with new wordpress update (5.3)?

  • Resolved andreasra

    (@andreasra)


    Dear W3 Total Cache Team,

    Just updated WordPress to 5.3 and now get the following error when wanting to access our page:

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    Warning: Cannot modify header information – headers already sent by (output started at /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home1/admintai/public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home1/admintai/public_html/wp-includes/pluggable.php on line 1268

    Any idea? What to do know? Best to delete the plugin and wait for an update?

    Thanks in advance
    Andreas

    The page I need help with: [log in to see the link]

Viewing 15 replies - 31 through 45 (of 89 total)
  • brunoruas16

    (@brunoruas16)

    After WordPress upgrade to version 5.3 I can no longer access wp-admin. https://soairc.com.

    Erro Message:

    Warning: Declaration of QuietSkin::feedback($string) should be compatible with WP_Upgrader_Skin::feedback($string, …$args) in /home4/picanha/public_html/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php on line 12

    Warning: Cannot modify header information – headers already sent by (output started at /home4/picanha/public_html/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home4/picanha/public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home4/picanha/public_html/wp-content/plugins/ocean-extra/includes/wizard/classes/QuietSkin.php:12) in /home4/picanha/public_html/wp-includes/pluggable.php on line 1268

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @brunoruas16

    As you can see in your error message this issue is related to https://wordpress.org/support/plugin/ocean-extra/ plugin. I believe that they have released an update approx 5 hours ago so you may as well update that plugin.
    Be that as it may, your issue is not related to W3 Total Cache.

    eslamrifaee

    (@eslamrifaee)

    Iā€™m also having the same problem. can’t access my admin and website .. please help as soon as possible … i tried the solution above didn’t work to at least log into my dashboard..!!!
    ————-

    Warning: Cannot modify header information – headers already sent by (output started at /home4/arrendoegypt/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home4/arrendoegypt/public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home4/arrendoegypt/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home4/arrendoegypt/public_html/wp-includes/pluggable.php on line 1268

    —-

    Warning: include_once(/home4/arrendoegypt/public_html/wp-admin/includes/plugin.php): failed to open stream: No such file or directory in /home4/arrendoegypt/public_html/wp-content/plugins/woo-checkout-field-editor-pro/classes/class-thwcfd.php on line 28

    Warning: include_once(): Failed opening ‘/home4/arrendoegypt/public_html/wp-admin/includes/plugin.php’ for inclusion (include_path=’.:/opt/php71/lib/php’) in /home4/arrendoegypt/public_html/wp-content/plugins/woo-checkout-field-editor-pro/classes/class-thwcfd.php on line 28

    Warning: require_once(/home4/arrendoegypt/public_html/wp-admin/includes/plugin.php): failed to open stream: No such file or directory in /home4/arrendoegypt/public_html/wp-content/plugins/woo-poly-integration/__init__.php on line 35

    Fatal error: require_once(): Failed opening required ‘/home4/arrendoegypt/public_html/wp-admin/includes/plugin.php’ (include_path=’.:/opt/php71/lib/php’) in /home4/arrendoegypt/public_html/wp-content/plugins/woo-poly-integration/__init__.php on line 35

    Plugin Support Marko Vasiljevic

    (@vmarko)

    @eslamrifaee

    As you can see you are having error messages from other plugins. W3 Total Cache as been fixed with the update. Please contact the support of the mentioned plugins or use this suggestion https://wordpress.org/support/topic/plugin-not-compatible-with-new-wordpress-update-5-3/page/2/#post-12125313
    and rename plugins that are causing the errors except for W3 Total Cache.

    eslamrifaee

    (@eslamrifaee)

    Warning: Cannot modify header information – headers already sent by (output started at /home4/arrendoegypt/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home4/arrendoegypt/public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home4/arrendoegypt/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home4/arrendoegypt/public_html/wp-includes/pluggable.php on line 1268

    eslamrifaee

    (@eslamrifaee)

    it says W3 Total Cache including with the other plugins …
    take a look please
    https://www.arrendoegypt.com/

    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @eslamrifaee

    Have you updated W3 Total Cache to 0.10.2 ?

    girdy74

    (@girdy74)

    Thank you so much! Just updated to 0.10.2, enabled the database caching again and everything is working great. No errors.

    sud0siggyz

    (@sud0siggyz)

    I am having something similar as trouble. I can’t access my admin page, I have: changed all plugins names one-by-one (gives the caching error), then I disabled and renamed db and advanced cache and also w3tc-config. Any of them didn’t work so I reset everything and updated to latest W3TC plugin manually throught FTP.

    All I get is this:

    Warning: Declaration of W3TC\DbCache_WpdbLegacy::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home2/host/public_html/wp-content/plugins/w3-total-cache/DbCache_WpdbLegacy.php on line 0

    Fatal error: Cannot declare class WP_User_Request, because the name is already in use in /home2/host/public_html/wp-includes/user.php on line 3657

    I don’t know what to do. Any help?

    • This reply was modified 2 months ago by sud0siggyz.
    • This reply was modified 2 months ago by sud0siggyz.
    eslamrifaee

    (@eslamrifaee)

    Not yet … I can’t update it as i can’t access my dashboard to update

    eslamrifaee

    (@eslamrifaee)

    how can i update through file manager !!

    sud0siggyz

    (@sud0siggyz)

    eslamrifaee; rename your old plugin or delete it
    then unzip your new plugin in the wp-content/plugins/ folder.

    girdy74

    (@girdy74)

    If any of you cannot access your admin dashboard you can update the plugin manually by FTP/SFTP or File Manager via cPanel.

    I did a quick search and found how to do it via cPanel as I have FTP/SFTP access:
    https://hostadvice.com/how-to/how-to-update-a-wordpress-plugin-manually-using-cpanel/

    Here’s instructions for FTP/SFTP:
    https://docs.brainstormforce.com/how-to-update-plugin-manually-through-ftp/

    sud0siggyz

    (@sud0siggyz)

    Girdy74 did the plugin update make your site work? I didn’t find any solution to fix it.

    anviltech

    (@anviltech)

    @vmarko Thank you for the immediate response.. you deserve a star.. šŸ™‚

Viewing 15 replies - 31 through 45 (of 89 total)
  • You must be logged in to reply to this topic.