Support » Plugin: W3 Total Cache » Plugin not compatible with new wordpress update (5.3)?

  • Resolved andreasra

    (@andreasra)


    Dear W3 Total Cache Team,

    Just updated WordPress to 5.3 and now get the following error when wanting to access our page:

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    Warning: Cannot modify header information – headers already sent by (output started at /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home1/admintai/public_html/wp-includes/pluggable.php on line 1265

    Warning: Cannot modify header information – headers already sent by (output started at /home1/admintai/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php:8) in /home1/admintai/public_html/wp-includes/pluggable.php on line 1268

    Any idea? What to do know? Best to delete the plugin and wait for an update?

    Thanks in advance
    Andreas

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 89 total)
  • I’m seeing an error as well after updating to WordPress 5.3 (“…” have been replaced from account name):

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home/…/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    • This reply was modified 2 months, 1 week ago by girdy74.

    Same error on multiple WordPress sites running W3

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, ...$args) in

    Moderator Marius L. J.

    (@clorith)

    Hiya, could you please let us know what version of W3TC you are using, are you using the latest version (released 3 hours ago at this time)?

    On the site I’m seeing this on; WordPress 5.3 and W3TC 0.10.1

    Hi, same here: Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home/site/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    Using: Versión 0.10.1 on WP 5.3

    Plugin homepage states:
    Version: 0.10.1
    Last updated: 3 hours ago

    So yes, I’m using the latest update.

    Thanks for your help

    • This reply was modified 2 months, 1 week ago by egocefalo.
    Plugin Support Marko Vasiljevic

    (@vmarko)

    Hello @andreasra @senator94 @clorith @girdy74 @egocefalo

    Thank you for reporting this issue after upgrading to 5.3
    Just to let you know that we are investigating this and will reply as soon as we test this.
    Thank you for bringing this to our attention.

    Add my sites to the list of those running the latest W3 Total Cache who crashed with these error messages after the WP 5.3 update.

    Unfortunately it prevents login to the WP dashboard, so I can’t even deactivate the plugin through normal means. I am considering using my hosting file manager to delete it, though I would appreciate feedback on if this will work or not.

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home3/anvilpub/public_html/blog/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    Have the exact same error too.. just a guess it might be the Database cache..

    our blog site (http://blog.anvilpublishing.com/) broke after update..

    I have the same error as well. Running WP5.3 + Version: 0.10.1 of W3TC

    • This reply was modified 2 months, 1 week ago by gearu.

    Add me to this list as well. Site is broken with same error.

    As others have stated. Can’t access the dash. Basically our hands are completely tied with sites being inaccessible.

    Site that is broken: https://helivebyfaith.org

    Please add me as well. Same warning message with same WordPress and W3 versions. Thanks.

    same error :/ after upgrading to 5.3.1 wordpress version

    same error, after upgrading to 5.3.1 wordpress version.
    I must disable Option Database Cached ! 😀

    Hi, i have the same error:

    Warning: Declaration of W3TC\DbCache_Wpdb::prepare($query, $args) should be compatible with wpdb::prepare($query, …$args) in /home/xxxxxx/public_html/wp-content/plugins/w3-total-cache/DbCache_Wpdb.php on line 8

    My WordPress version is: v5.3

    My W3TC – W3 Total Cache version is: v10.0.1

    Please help me and thanks in advance for the support.

Viewing 15 replies - 1 through 15 (of 89 total)
  • You must be logged in to reply to this topic.