Support » Plugin: WP Security Audit Log » Plugin not available on network sites’ dashboard after 3.1.6 update

  • After I updated to version 3.1.6 I can’t see the plugin in the sites’ dashboard. Trying to access it directly via URL https://example.com/site-name/wp-admin/admin.php?page=wsal-auditlog issues a can’t load wsal-auditlog message.

    I still can access/change plugin settings in the network dashboard though. The plugin is activated on the entire network, and this is happening on two multisite installations I run.

    Edit: it’s probably worth noting that I was running version 3.0.1 before the update.

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    Hello @hvianna

    Thank you for using our plugin and sorry to hear you are having such issues.

    As such updating from 3.0.1 should not create any issues. Can you please try the following:

    1) Deactivate the plugin.
    2) Delete the table wp_wsal_options from the WordPress database.
    3) Activate the plugin.

    Does that help?

    Hello @wpwhitesecurity and thank you for the prompt response!

    Unfortunately that didn’t help. I still have no access to the audit log from any site dashboard. I also tried deactivating all other plugins, but to no avail.

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    You’re welcome @hvianna.

    So you are able to access the FULL plugin menu (including the audit log ) in the Network dashboard correct?

    Just checking, what roles do the users you are using on the sites have on that site in question? By default these are the privileges:

    Super admin can access the plugin menu from anywhere
    Site admins can see the audit log of their site only when they are logged in to the site.

    Looking forward to hearing from you.

    That’s correct, on the network dashboard I can access all configuration options and the log viewer.

    My user is super-admin. I also tried explicitly adding my user to a couple of sites, but still can’t see the audit log on their dashboards. Also tried with a different super-admin user, just to be sure.

    Thanks for your time.

    Plugin Author WPWhiteSecurity

    (@wpwhitesecurity)

    It seems that you have restricted the plugin install just to the super admin. Can you navigate to the plugin settings and confirm if the option Restrict Plugin Access is enabled?

    If it is, please disable it and access should be restored. Can you please check and advise?

    I’ve been using the restrict access option since I first installed the plugin, with the allowed usernames in the “Can Manage Plugin” field.

    I disabled the restrict option, logged out and logged back in, but still no change.

    Plugin Contributor robert681

    (@robert681)

    Hello @hvianna,

    Would it be possible to send us an export of the table wp_wsal_options so we can take a look please? You can send it to info@wpsecurityauditlog.com.

    E-mail sent! Thanks.

    Solved in version 3.2.0!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Plugin not available on network sites’ dashboard after 3.1.6 update’ is closed to new replies.