Support » Plugin: WordPress Button Plugin MaxButtons » Plugin not able to activate

  • Resolved jimleeder123

    (@jimleeder123)


    The plugin is unable to activate on our client’s website. The site is hosted on AWS on PHP 8.1.1 and MySQL 8.0.27.

    We have the plugin working on another website so I wonder if it’s an issue with these versions?

    The error is a fatal Mysql error upon activation of the plugin pasted below with the client name removed.

    Fatal error: Uncaught mysqli_sql_exception: Table ‘client-name.wp_maxbuttonsv3’ doesn’t exist in /var/www/client-name.co.uk/public/wp-includes/wp-db.php:2056

    Any help would be appreciated, thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Bas Schuiling

    (@basszje)

    Hi,

    Are you in the position to try it on PHP 8.0 or lower? I think the changes in PHP 8.1 might cause this in combination with this WordPress issue -> https://core.trac.wordpress.org/ticket/52825 . In general many things in WP don’t seem quite ready to fully support PHP 8.

    (Looks like in WP 5.9 this might not be an issue).

    The database table should be create upon activation. I suppose your database user in WordPress is allowed to create tables.

    I’ll also take a look at it to see what we can do to prepare MaxButtons for this.

    My current test machine runs on PHP 8.0.11, same MySQL version and it has no issues.

    Plugin Author Bas Schuiling

    (@basszje)

    I just installed PHP 8.1 and my assumptions were correct. Upon activation MaxButtons tries to create the table via WordPress. It’s the WordPress DB that’s causing the issues, which should be fixed next version.

    For now I recommend to move back to PHP 8. I get tons of other warnings on 8.1.

    Thread Starter jimleeder123

    (@jimleeder123)

    Hi,

    This has now been fixed with the latest WordPress update (5.9) so you were correct – thank you for your replies!

    Plugin Author Bas Schuiling

    (@basszje)

    I’ll resolve this topic then. Thanks for the feedback.

    Be careful with using PHP 8.1, I still get a lot of other warnings from plugins, themes etc. For next version I’ll check if MaxButtons is fully supporting the latest version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Plugin not able to activate’ is closed to new replies.