Support » Plugin: Nexi XPay » Plugin non funziona con WooCommerce 3.5.2?

  • Buongiorno,
    non se capita solo a me ma su WooCommerce 3.5.2 e WP 4.9.8 non si riesce ad abilitare il gateway Nexi nelle impostazioni WooCommerce > Pagamento, nonostante i dati vengano salvati correttamente. Ad ogni riapertura del pannello di gestione dei pagamenti, il gateway si disabilita da solo.
    Su WooCommerce 3.1 il plugin funzionava perfettamente, aggiornandolo a questa versione non si riesce ad utilizzare.
    Consigli?

    grazie
    Tobia

Viewing 6 replies - 1 through 6 (of 6 total)
  • Abilitando il debug, a parte qualche notice, nel pannello di gestione in ogni pagina compare il seguente errore:

    Cannot modify header information – headers already sent by (output started at […]/wp-content/plugins/cartasi-x-pay/includes/class-wc-gateway-nexi-xpay.php:137) in
    […]/wp-admin/includes/misc.php

    ho nascosto qui la path del server sostituendola con […]

    Plugin Author Nexi Payments

    (@cartasi)

    Buongiorno,
    abbiamo visto che si è messo in contatto tramite mail con il nostro supporto tecnico tech.ecommerce@nexi.it . Le forniremo assistenza li.

    Al momento non ci risulta questo tipo di comportamento. Lasciamo aperto il post, verifichiamo se altri utenti segnalano il problema

    • This reply was modified 11 months, 3 weeks ago by Nexi Payments.

    ATTENZIONE bisogna attivare la modalità TEST nel plugin e iscriversi alla piattaforma NEXI TEST. I link ti vengono mostrati passo passo.
    Una volta attivo sulla piattaforma TEST (registrato e connesso), ti vengono rappresentati i parametri per le verifiche.

    Se non sei registrato e connesso ottieni quel errore

    Questa è la mia esperienza, seppur limitata. Anch’io ho preso paura di quella schermata bianca. Funziona tutto senza problemi, in pochi minuti e agevolmente

    Si lo sappiamo, il plugin lo usiamo da un anno e la procedura di nexi test è già stata fatta a suo tempo.
    Con WooCommerce 3.1 funzionava regolarmente.
    Con la 3.5 non c’è modo di farlo funzionare. Le sto provando tutte.

    Risolvendo l’errore “Cannot modify header information” e costruendo una funzione per non generare i vari notice relativi alle variabili vuote, il mancato funzionamento del plugin persiste anche se nel log non viene visualizzata nessuna anomalia.
    Ho provato anche a modificare la versione php del web server da 7.2 a 7.1.

    Se fosse possibile parlare o scrivere a uno sviluppatore di Nexi, forse una soluzione la troviamo altrimenti andiamo avanti con Paypal.

    grazie
    Tobia

    Plugin Author Nexi Payments

    (@cartasi)

    Buongiorno,
    le chiediamo nuovamente di scriverci alla mail tech.ecommerce@nexi.it in modo da verificare con i nostri sviluppatori in modo più approfondito.

    Non ci risultano problemi di incompatibilità con la versione 3.5.2 di Woocommerce

    Cordiali Saluti

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Plugin non funziona con WooCommerce 3.5.2?’ is closed to new replies.