Support » Plugin: Ajax Search for WooCommerce » Plugin non-functional since Woo 3.0

  • Resolved adam__ph

    (@adam_ph)


    Since the release of WooCommerce 3.0 this plugin has become completely unfunctional.

    We get the following warning:

    [10-May-2017 03:16:34 UTC] PHP Warning: Parameter 2 to DGWT_WCAS_Search::search_filters() expected to be a reference, value given in /public/wp-includes/class-wp-hook.php on line 298

    [10-May-2017 03:16:30 UTC] PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, no array or string given in /public/wp-includes/class-wp-hook.php on line 300

    [10-May-2017 03:16:36 UTC] id was called incorrectly. Product properties should not be accessed directly. Backtrace: require(‘wp-blog-header.php’), require_once(‘wp-includes/template-loader.php’), do_action(‘template_redirect’), WP_Hook->do_action, WP_Hook->apply_filters, WC_AJAX::do_wc_ajax, do_action(‘wc_ajax_dgwt_wcas_ajax_search’), WP_Hook->do_action, WP_Hook->apply_filters, DGWT_WCAS_Search->get_search_results, WC_Abstract_Legacy_Product->__get, wc_doing_it_wrong. This message was added in version 3.0.

Viewing 5 replies - 1 through 5 (of 5 total)
  • How can we advance the update process If it is possible?

    • This reply was modified 2 years, 4 months ago by  dock3r.
    Plugin Author Damian Gora

    (@damian-gora)

    Hello,

    Apologies for the delayed response.

    I have released version 1.1.1 which is compatible with WooCommerce v3.0+. Could you confirm if everything is ok?

    Best
    Damian

    Hi,

    Thank you Damian, everything is functional now.
    However I get this in the error.log when searching:

    [Wed Jun 07 09:51:17.132253 2017] post was called incorrectly. Product p
    roperties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), do_action('template_redirect'), WP_Hook->do_act
    ion, WP_Hook->apply_filters, WC_AJAX::do_wc_ajax, do_action('wc_ajax_dgwt_wcas_ajax_search'), WP_Hook->do_action, WP_Hook->apply_filters, DGWT_WCAS_Search->get_search_results, dgwt_
    wcas_get_product_desc, WC_Abstract_Legacy_Product->__get, wc_doing_it_wrong. This message was added in version 3.0.

    Works with Woocommerce 3.0.8 but there are still some problems:
    SCREEN

    Looks like version 1.1.2 fix all the problems. THX

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin non-functional since Woo 3.0’ is closed to new replies.