Support » Plugin: No Sub-Category Posts in Loops » [Plugin: No Sub-Category Posts in Loops] Good to see this has been updated for WP 3.1

  • I’m not sure this is completely related to this plugin but I have some strange behaviour on my site.

    The site is http://www.planetrail.co.uk/

    On the second menu (dark blue) you will see ‘Holidays by Rail’, ‘Destinations’, ‘Holiday Ideas’ and ‘Seasonal’. All work fine except Destinations – if I select a sub category item from any of those menu’s it’s OK. However if I click the menu heading (‘Holidays by Rail’, ‘Destinations’, ‘Holiday Ideas’ or ‘Seasonal’) I should just get the one post in than category (and no posts from sub categories – I use a plugin to hande that).

    If I click on Destinations I also get the three posts that are in the sub category of United Kingdom but not those from other posts in sub categories – weird.

    I’m puzzled – any ideas?
    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m having the same issues since WP 3.1. but got no reply from the devs until now.

    Example:
    http://www.photographik.be/category/verslagen/canada-alaska-2006/

    Only the first article from April 5 should be visible. This is the main category. However, many other articles from sub cats are visible too. Not all, weird indeed.

    ollybenson

    (@ollybenson)

    There is a small bug with this plugin for version 3.1+

    It is designed to handle different versions when it builds the query. However, it does not handle the different versions when collecting the IDs to build the query.

    If you are using the latest version of WordPress (v3.1 +) you should change line 78 where it says:

    $exs[] = $value->cat_id;
    to
    $exs[] = $value->term_taxonomy_id;

    Then it should work.

    Olly

    DirkD

    (@dirkd)

    Hi Olly, thank you for your reply. Yes, that’s it ! It works perfect now !
    Have a nice day.
    Dirk

    Plugin Author Glenn Ansley

    (@blepoxp)

    Just tagged a new version and gave props to Olly. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: No Sub-Category Posts in Loops] Good to see this has been updated for WP 3.1’ is closed to new replies.