Support » Plugin: Plugin Organizer » Plugin No Longer Works for me

  • This awesome plugin worked for the longest time but lately I’ve noticed that plugins are running when I’ve set them as disabled. I have no idea where to begin to figure out what’s wrong. I go to my Global Plugins settings – red and blue dots are correct but some plugins are disobeying these settings. What can I do? Thanks

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jeff Sterup

    (@foomagoo)

    Use the tool on the settings page under the Plugin Search tab. Search for one of the plugins that is not following the global settings. Edit the posts that are returned to make sure it hasn’t been enabled somewhere.

    The plugins that I’m concerned about both show up with “Global Plugins” being returned with the search tool….but it doesn’t indicate if for Standard or Mobile. So when I click on “Global Plugins” it takes me to the settings which are set correctly (blue and red dots where they are supposed to be). I’m still seeing things that indicate these settings aren’t working as configured. Is there anything else I can do? Thanks

    Anyway thanks for the more than 2 years of great functionality as a result of Plugin Organizer. Gonna just deactivate it for now because I can’t get it to work any longer.

    jchoelt

    (@jchoelt)

    Same issue here. Running wordpress 4.8.2, plugins aren’t disabled anymore.

    I made a small experiment in my function.php file:

    add_filter( 'option_active_plugins', 'disable_all_plugins' );
    function disable_all_plugins($plugins){
      array_splice($plugins,0);
      return $plugins;
    }

    All plugins are still being loaded…

    Plugin Author Jeff Sterup

    (@foomagoo)

    It sounds like you might have a caching plugin installed. Caching plugins cache the plugin list and won’t ever call the filter.

    I’ve had a caching plugin installed for years, with no recent updates (no change) and I can tell you that your plugin Plugin Organizer worked with it without any issues for the longest time.. years really.

    No caching plugin, the filter is definitely called (I logged the calls), about a dozen times when the page loads…

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.