Support » Plugin: Table Rate for WooCommerce by Flexible Shipping » Plugin no longer works after update from 2.1.10 to 3.0.7 (no shipping added)

  • Resolved pitusp

    (@pitusp)


    I have updated this plugin recently from 2.1.10 to 3.0.7 and, as a result, it stopped showing any Shipping amounts so customers thought they’re no longer paying for shipping – what a pain.

    I’ve tried to find a solution, but so far to no avail.

    I’d like to know, what’s changed exactly that’s breaking the primary functionality? How do I fix it? The message that pops up about some tax option in WooCommerce is nonsense as there’s no such option in Woo 3.4.6 so I don’t know how to fix it?

    I have two zones – US and CA, each has a set of Price ranges (don’t know how to send you the table or understand why you’d need it to help me fix the problem? There’s nothing in the System Report that would list these zone pricing ranges so I’m not including it here…)

    For now I have just down-graded the plugin to version 2.1.10 (first needed to Deactivate the latest, then Delete it and then hit Add New and upload the flexible-shipping.2.1.10.zip downloaded from The Plugin Archive – took me a while to find that archive).

    After Activating it, it still didn’t work, so I had to clear the cache – I did it by changing some other shipping option and re-saving it via admin panel.

    For now, I don’t advise anyone upgrading to 3.0.7 until it’s fixed.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor grola

    (@grola)

    Can you provide screenshots with complete shipping method settings?

    Sure, how/where do I send them? I don’t see any way to attach them to this message.
    Try this .zip file with 3 screen-shots

    Btw, the message that you show up is quite misleading – I don’t know what it’s referring to?

    “Flexible Shipping has changed the calculation method for shipping rules. Currently, the cart value for rules based on price is determined by WooCommerce tax option “Display prices during cart and checkout”. You should check the settings.”

    • This reply was modified 1 year, 3 months ago by pitusp.
    Plugin Contributor grola

    (@grola)

    There is 0 in Free Shipping. Remove it and leave this field blank.

    Thanks for the hint … I’m not sure how that 0 got there as I don’t recall entering it and it works with that 0 when using version 2.1.10 so, perhaps the update to 3.0.7 has put that 0 in there? Or 2.1.10 was ignoring it?

    It may be a good idea to detect that in the latest version and warn the user that a 0 in there overrides all the rules and offer to clear it for the user automatically – in fact, why not just do that as 0 is useless in there.

    Plugin Support ospiotr

    (@ospiotr)

    Please update the plugin to the latest version.

    Please let me know if your issues has been solved.

    Here’s the changelog:

    * Added Cache settings in FS Connect Advanced settings
    * Added info and link about planned integrations
    * Added support for not allowed demo domain
    * Fixed missing tracker message
    * Fixed typo in Connect notices
    * Fixed COD Enable for shipping methods functionality
    * Fixed UK counties
    * Fixed for free shipping zero value in settings

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Plugin no longer works after update from 2.1.10 to 3.0.7 (no shipping added)’ is closed to new replies.