Support » Plugin: Smush Image Compression and Optimization » Plugin no longer working? "Temporarily disabled…"?

  • Resolved J. Brown


    I have been running WP Smushit on more than one site (different servers) for several years and had them set to auto smush on upload. I just noticed that, for some time now, none of the images that have been uploaded were processed. On one server ( I can still manually smush via the media library. But on the other server (Web Hosting Hub), when I try to hit “Smushit now” in the media library, I get a spinning wheel and then it returns to “not processed” (same with attempts at Bulk Smush.) On both servers, in Settings-Media, under WPSmush it says “Temporarily disabled until May 31, 2012 at 9:48 (different dates on different servers.)” And when I try to set it back to “Automatically process on upload”, I get the following error message:

    Warning: trim() expects parameter 1 to be string, array given in /home/yogijb5/public_html/wp-admin/options.php on line 147

    Warning: trim() expects parameter 1 to be string, array given in /home/yogijb5/public_html/wp-admin/options.php on line 147

    Warning: Cannot modify header information – headers already sent by (output started at /home/yogijb5/public_html/wp-admin/options.php:147) in /home/yogijb5/public_html/wp-includes/pluggable.php on line 876

    Everything was working fine previously and nothing has changed with my theme or plugins (I use very few.) Perhaps someone could help me sort it out. The convenience of not having to smush manually before uploading is considerable.


    Much obliged.

Viewing 14 replies - 1 through 14 (of 14 total)
  • On the JSON/JSON.php file try deleting the last line (in other words delete the closing PHP tags).

    Let me know if that fixes the errors you’re getting…

    I tried deleting the closing php tags in JSON/JSON.php and I still get the same errors when trying to set back to “Automatically process on upload”. No change.

    However, I just discovered that I am now able to smush images manually in the media library.(?) A number of them (but not all) come back with “no savings” which makes me think that some were processed on upload despite it saying “not processed” (I always handle the images the same.) At least, I can smush them now from within wordpress. That’s something. But if we can find a way to get it back to automatic, I’d sure like that.

    I do appreciate you trouble shooting this for me.
    Any other ideas?



    WPMU DEV Support Staff

    Hi @jbrown-1

    Sorry for the slow reply here!

    I just wanted to check if you are still having a problem. Just to confirm was the problem that your images are not smushing automatically on upload and producing an error, but it looks like they are actually being smushed?

    Hey Mike-

    No worries. It still says: “Temporarily disabled until …” in Settings>Media>WPsmushit and when I try to set it back to “Automatically process on upload” I still get the same error message I quoted above.

    However, I am able to manually smush them from the library. So they are still not smushing on upload as desired but I am able to do it from within my admin which is still valuable.

    If there is anything else I can tell you, let me know.



    WPMU DEV Support Staff

    Hey Mike-

    I tried the fixes recommended. There was a missing end tag but even after putting it in, and clearing caches, I still get the same error. I also did some further checking and it looks like it might have something to do with a redirect function on the setting page:

    “In case you’ve used the function: wp_redirect() or tried to use a header redirect after the header (or any content at all was sent) that error message will pop. Instead use javascript redirection if needed.”


    I got the same error for several months, hope there will have a fix for this.

    I have the same error too. Been using it for years with no problem and now it no longer works. I’ve been thinking of trying this one if there is no fix.



    WPMU DEV Support Staff

    Hi @jbrown-1 @longnha & @mizmichele

    Ok that’s three people with the same issue, I’ve notified the developer. Unfortunately this is a side effect of taking over other peoples code :-/

    In the mean time could you please open up the plugins .php files and do the steps mentioned in the above link?

    The following are the files that you need to check:

    Check both files for whitespace at the bottom and make sure the last two characters are “?>” or “}” if there are any spaces or tabs after then please delete them and try again.

    Hey all.

    This should be resolved in our last release just a couple of days back.

    If you’re still having issues, please let us know.

    Take care.

    Yes, the problem is solved at my side.

    Thank you.

    All fixed since the last update.
    Kudos and thanks.



    WPMU DEV Support Staff

    That’s great, thanks for letting us know 🙂


Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Plugin no longer working? "Temporarily disabled…"?’ is closed to new replies.