Support » Plugin: Enjoy Social Feed plugin for WordPress website » Plugin no longer displays anything

  • Resolved geea

    (@geea)


    Hi!

    The plugin worked properly until recently, when the shortcode we used on the homepage stopped displaying anything. We’ve tried unlinking and re-linking the user, clearing user data, deactivating and reactivating the plugin. Also, we’ve tried with the shortcode and widget, still nothing.

    Thank you for your assistance.

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author designemotions

    (@designemotions)

    Hi @geea ,
    it is strange if the plugin worked before that the stream disappeared without doing other operations.
    Have you installed something new? What kind of editor do you use?
    Could you send me the text you find in the “Diagnostic” tab of our plugin?

    Thank you

    Thread Starter geea

    (@geea)

    Thanks for your prompt reply.
    The client doesn’t remember installing something new. The site used Beaver Builder as page editor, but we’ve cloned it to staging and disabled all plugins and reverted to the default theme and it still doesn’t work.

    Here is the diagnostic data:

    ## ENV INFO ##
    Site URL:           https://dancemetrodc.org
    Home URL:           https://dancemetrodc.org
    Wordpress Version:  5.6
    PHP Version:        7.3.25-1+0~20201130.73+debian9~1.gbp042074
    SAPI:               fpm-fcgi
    WEB Server:         Apache/2.4.25 (Debian)
    
    ## Cache ##
    Path:               /home/320310.cloudwaysapps.com/mkrrkacnnp/public_html/wp-content/uploads/ei-cache
    Images in cache:    0
    
    ## USERS: ##
    array (
      'id' => '17841401163001797',
      'token' => 'IGQVJWQnRYcHRVLXpvb0NlVm1CSkxYQ3F0Y1JlTjJLRU1jenRiblNSaWRmYVZAjQzU0b0JSMEVrMy1Eb3hqU2xhUDRCWF9NOWNPU0pUakpuaEQ1RU9pcWFjTERIa1hWVFJyUjNrUzhn',
      'username' => 'dancemetrodc',
      'business' => false,
    )
    ## API RESPONSE ##
    dancemetrodc: Success!
    
    ## DATABASE ##
    Version:        1.0.5
    
    *Media*
    Count:          0
    	CREATE TABLE <code>wp_enjoy_instagram_media</code> (
      <code>id</code> bigint(20) NOT NULL AUTO_INCREMENT,
      <code>image_id</code> varchar(255) COLLATE utf8mb4_unicode_520_ci NOT NULL DEFAULT '',
      <code>image_link</code> varchar(255) COLLATE utf8mb4_unicode_520_ci NOT NULL DEFAULT '',
      <code>image_url</code> text COLLATE utf8mb4_unicode_520_ci NOT NULL,
      <code>thumbnail_url</code> text COLLATE utf8mb4_unicode_520_ci NOT NULL,
      <code>user</code> varchar(225) COLLATE utf8mb4_unicode_520_ci NOT NULL DEFAULT '',
      <code>caption</code> longtext COLLATE utf8mb4_unicode_520_ci NOT NULL,
      <code>likes</code> mediumint(9) NOT NULL DEFAULT '0',
      <code>moderate</code> varchar(20) COLLATE utf8mb4_unicode_520_ci NOT NULL DEFAULT '',
      <code>date</code> bigint(20) NOT NULL DEFAULT '0',
      UNIQUE KEY <code>id</code> (<code>id</code>)
    ) ENGINE=InnoDB AUTO_INCREMENT=21 DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci
    
    *Hashtag*
    Count:     	0
    	CREATE TABLE <code>wp_enjoy_instagram_hashtags</code> (
      <code>id</code> bigint(20) NOT NULL AUTO_INCREMENT,
      <code>image_id</code> bigint(20) NOT NULL DEFAULT '0',
      <code>hashtag</code> varchar(255) COLLATE utf8mb4_unicode_520_ci NOT NULL DEFAULT '',
      <code>moderate</code> varchar(20) COLLATE utf8mb4_unicode_520_ci NOT NULL DEFAULT '',
      UNIQUE KEY <code>id</code> (<code>id</code>)
    ) ENGINE=InnoDB AUTO_INCREMENT=84 DEFAULT CHARSET=utf8mb4 COLLATE=utf8mb4_unicode_520_ci
    
    ## ACTIVE PLUGINS: ##
    Akismet Anti-Spam: 4.1.8
    Beaver Builder Plugin (Lite Version): 2.4.2
    Breeze: 1.1.9
    Bulk Delete: 6.0.2
    Classic Editor: 1.6
    Display Posts: 3.0.2
    Enjoy Instagram: 5.3.1
    GDPR Cookie Consent: 1.9.5
    If Menu - Visibility control for menu items: 0.16.2
    Login Logout Register Menu: 1.0
    Ninja Forms: 3.4.34
    Ninja Forms - File Uploads: 3.3.10
    Ninja Forms - PayPal Express: 3.0.15
    Plainview Protect Passwords: 1.4
    PublishPress Capabilities: 1.10.1
    Resize Image After Upload: 1.8.6
    reSmush.it Image Optimizer: 0.3.11
    Safe SVG: 1.9.9
    The Events Calendar: 5.3.2.1
    The Events Calendar: Filter Bar: 5.0.4
    The Events Calendar PRO: 5.2.2
    Theme My Login: 7.1.2
    UberMenu 3 - The Ultimate WordPress Mega Menu: 3.6.0.1
    WordPress Importer: 0.7
    WP Sheet Editor - Post Types: 2.23.0
    
    Plugin Author designemotions

    (@designemotions)

    Hi @geea ,
    thank you very much for the text that can help us.
    First I see that there are no images in the cache, perhaps the plugin has been updated from an old version and the db lines that were previously created need to be cleaned up.
    Go to the “diagnostic” tab and click on “Re-install database” this button will delete only the traces that some old version had left and will download the cached images (which is a new feature).
    After doing this let me know if anything has changed

    Thread Starter geea

    (@geea)

    Thanks for your help, I’ve clicked on the Re-install database, I got a confirmation message with “Data initialized”, but the Diagnostic tab shows the same info with 0 images in cache and nothing shows up on the page. The wp_enjoy_instagram_media table is also empty, which is probably why the error log is filled with these messages:

    [Wed Feb 03 12:47:58.740561 2021] [proxy_fcgi:error] [pid 11106:tid 140139422721792] [client 95.76.2.60:34768] AH01071: Got error 'PHP message: WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 for query SELECT * FROM wp_enjoy_instagram_media WHERE user = 'dancemetrodc' ORDER BY date DESC LIMIT made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/genesis/page.php'), genesis, do_action('genesis_loop'), WP_Hook->do_action, WP_Hook->apply_filters, genesis_do_loop, genesis_standard_loop, do_action('genesis_entry_content'), WP_Hook->do_action, WP_Hook->apply_filters, genesis_do_post_content, the_content, apply_filters('the_content'), WP_Hook->apply_filters, do_shortcode, preg_replace_callback, do_shortcode_tag, EnjoyInstagram_Shortcodes->grid_shortcode, EnjoyInstagram_Shortcodes->render, EnjoyInstagram_Shortcodes->get_images, EnjoyInstagram_DB->get_shortcode_media_user'

    Plugin Author designemotions

    (@designemotions)

    Hi @geea,
    it is a new error that we need to analyze better.
    If that’s not a problem for you, could you create a temporary account as an administrator and let us log into the WP backend to check some options?

    To avoid posting logins on the forum, you could write to us from this page:

    https://www.mediabetaprojects.com/enjoy-instagram-premium/help-and-support-enjoy/

    Thanks

    Thread Starter geea

    (@geea)

    Hi!

    I’ve sent you an email with the logins.

    Thanks.

    Plugin Author designemotions

    (@designemotions)

    Hi @geea ,
    we solved the problem in private discussion,
    I close this thread.

    Thank you

    Hi,

    I am having same issue, it was all good but I just updated plugin today & after updating plugin is not working anymore. I am using elementor page builder on website.

    Please provide me solution as well, if you want login credential I can provide you as well in private.

    Let me know ASAP.

    Thanks,

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.