WordPress.org

Support

Support » Plugins and Hacks » [Resolved] [Plugin: Ninja Forms Lite] Submit button doesn't work

[Resolved] [Plugin: Ninja Forms Lite] Submit button doesn't work

Viewing 8 replies - 1 through 8 (of 8 total)
  • Also, I wanted to let you know, I’ve also tried turning off all my other plugins (except for options framework which is needed for my theme) to no avail.

    Plugin Author Kevin Stover

    @kstover

    Hey,

    There are a couple of things I see when I look at the sample form page you sent.

    • You’re page includes jQuery twice. Once from the WordPress includes folder and once from google API.
    • You’re jQuery.form.js file is being included from Contact-Form-7 and not from WordPress itself.
    • You’re page basically loads jQuery UI twice. Once from the WordPress includes folder and once from google API

    The actual error that is causing Ninja Forms not to work is this one: “Uncaught TypeError: Object [object Object] has no method ‘progressbar'”
    This is a fairly common error and, in our experience, is usually caused by bad jQuery includes.

    The 404 error has something to do with your theme, so I’m not sure where or how to go about fixing it. It’s looking for:
    “http://delpieroforsupervisor.com/wp-content/themes/campaign1.3/campaign/includes/shortcodes/includes/css/friendly_buttons.css?ver=3.3.1”

    These jQuery duplications and the jQuery.forms.js include would need to be cleared up before I can tell where the jQuery error is coming from. It isn’t clear from the source where the google API include is coming from, unfortunately.

    Kevin –

    Thanks for the quick reply. I’ll check with the theme creator and get back to you.

    Hey Kevin, just as a follow up, I contacted the theme creator and, after he pushed an update that fixed the jquery issues, the plugin works great. Thanks so much for your help!

    Sorry to bump this issue again, but I’ve just installed this plugin on WP v3.3.1, custom theme, and have had no end of issues even after getting the form to appear correctly. So close yet so far…

    The first problem was that the help tips wouldn’t appear properly. Turned out it was because the css file it was looking for was all-black.css but no such file existed, so I actually had to rename black.css to get it to work!

    Now my submit button doesn’t work and having discovered that Ninja Forms wants now to include all the jquery craziness on every single page of my site, despite having only one form on one page, I’ve taken the advice above and removed my own jquery include from my custom header.

    However, I’ve now got the “no method progressbar” issue which seems to stem from the fact that the relevant js file isn’t being correctly included. In fact, having messed with scripts_functions.php for a while I’ve established that wp_enqueue_script is simply refusing the include any progressbar.js files I throw at it (even the built in WP version).

    What could cause this?

    Thanks for your help, including the above which got me this far.

    I think I’ve got it working, but only by cheating.

    In scripts_functions.php, wp_enqueue_script refused to include:

    NINJA_FORMS_URL .'/js/min/jquery.ui.progressbar.min.js'

    …apparently because of the preceeding line:

    wp_enqueue_script('jquery-ui-progressbar',

    …so to get it to load I changed it to:

    wp_enqueue_script('jquery-ui-progressbar-ninja',

    …and now it loads and apparently works. I’m sure it will probably turn out that my custom theme is to blame, though I’m fairly sure I’m not loading anything out of order.

    Plugin Author James Laws

    @jameslaws

    It’s definitely a jQuery UI issue. Usually a theme or plugin loading an old version but I can’t say for sure without a link to the page so I can see exactly whats being loaded.

    Hi Guys,

    I am really really baffled with the submit button not working on the WP Ninja Lite form that I have created. All works beautifully except when one goes to submit the form the button just doesn’t work.

    I am not very coding friendly only know absolute small time basics and have no idea how I can fix this – please please is there someone out there who would be willing to help???

    I am running this template: Theme Name: Bisuness Coach Central Coast Bill Annesley
    Theme URI:
    Description: Artisteer-generated theme
    Version: 1.0
    Author:
    Author URI:

    If someone could check the coding to make sure there are no conflict and/or configuration problems I would be forever grateful- the website is http://businesscoachcentralcoast.com.au and the form page link is http://businesscoachcentralcoast.com.au/about/business-coaching-services/small-business-health-check/#.T_QFJvV5dEE

    Much thanks in advance Angeleika1

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] [Plugin: Ninja Forms Lite] Submit button doesn't work’ is closed to new replies.