Support » Plugin: Ninja Forms - The Easy and Powerful Forms Builder » [Plugin: Ninja Forms Lite] Cannot create a form

  • Resolved Amtiskaw


    I have installed Ninja Forms Lite, but I am unable to create a form. I click ‘Add New’ and am taken through to the ‘Basic Form Settings’ page. I fill in all the fields and hit ‘Save Form Settings’ and redirected to the forms list, but it is still empty; the form as not saved. Nothing I do seems to actually make it create a form.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Plugin Author Kevin Stover



    Could you give me some more info about your WordPress installation?

    • What version of WordPress are you using?
    • What version of Ninja Forms Lite?
    • Have you tried deactivating all your plugins besides Ninja Forms Lite? Sometimes weird behaviours can be caused by plugin conflicts.
    • Are you using a premium theme? If so, which one?

    If you can answer those questions for me, I’ll try and help you get everything sorted out.

    – Kevin

    Hi, thanks for your quick response!

    • 3.3.1
    • Yes – No effect
    • No
    Plugin Author Kevin Stover


    Alrighty, I think that the best thing for me to do would be to have a look at your WP-Admin myself. If you don’t mind creating a temporary admin account for me, I’ll hop in and see what I can find out. My email address is: kevin [ a t ] wpninjas [ d o t ] net.

    I look forward to hearing from you soon!

    – Kevin

    Easier said that done, as I’m developing on a localhost installation at the moment. I’ll see what I can do about getting it deployed and get back to you.

    Plugin Author Kevin Stover


    Ah, I see. No problem. I just haven’t been able to reproduce your bug, so without seeing your particular installation, I’m not sure that I can squash it. Off the top of my head it sounds like an issue with MySql not creating the table used in the backend properly. Ninja Forms thinks that the table has been created, which is why you get the redirect back to the list of forms.

    You mentioned that the list of forms is blank; this also suggests a problem with inserting into the database because Ninja Forms is supposed to create a new test form upon activation.

    If you are able to get it live and have the same problem, please let me know, I’m very interesting in making sure that Ninja Forms works properly for everyone.

    Sorry for the inconvenience this might have caused,

    – Kevin


    The tables are definitely there, as I can see them in the DB view. One thing is that I’m creating the site using Microsoft WebMatrix, , which manages all the PHP, MySQL and WordPress configuration itself, so maybe it’s using some slightly unusual settings? WP is also running on port 46228.

    I’ll let you know if I make any progress figuring out what the problem is.

    OK, I found some blog on debugging plugins, and added the code for displaying errors that occur during activation. This is what I’m seeing:

    WordPress database error: [Field ‘show_title’ doesn’t have a default value]
    INSERT INTO wp_ninja_forms (title,mailto,subject,new,success_msg,save_subs,send_email,ajax,landing_page,append_page, email_from,email_msg,email_fields,multi,multi_options, post,post_options,save_status,save_status_options) VALUES (‘First Test Form’,’’,”,’0′,”,’checked’,’checked’,’checked’,”, ”,”,”,”,’unchecked’,”,’unchecked’,”,’unchecked’,”)

    and a bit later, but I guess caused by the first error…

    WordPress database error: [Incorrect integer value: ” for column ‘form_id’ at row 1]
    INSERT INTO wp_ninja_forms_fields (label,type,form_id,value,field_order,req,extra,class,help) VALUES (‘New Label’,”,”,’none’,’9999′,’0′,’a:1:{s:5:\”extra\”;a:2:{s:9:\”show_help\”;s:9:\”unchecked\”;s:4:\”mask\”;s:4:\”none\”;}}’,’Comma,Separated,List’,’Sample Help Text’)

    Plugin Author Kevin Stover


    Thanks for digging! I’m in the UK and it’s getting late here, but I’ll take a look at that in the AM and see if I can track down what’s going on specifically.

    – Kevin

    Hey, no problem. I’m in the UK myself and should probably be going to bed as well!

    I seem to have got it working though. The changes I had to make were all in ninja_initial_setup in nina_forms.php. I’m guessing maybe you’ve changed the table structure recently and forgot to update the initial value population?

    I had to modify the wp_ninja_forms INSERT statement to add values to the columns ‘show_title’, ‘desc’, and ‘show_desc’, and the wp_ninja_forms_fields INSERT to add an integer 1 into the ‘form_id’ column, as it was trying to put an empty string in.

    Plugin Author Kevin Stover


    Hey, thanks for the heads up. It was a bit of lazy coding on my part as all of the MySQL db’s I’ve worked with automatically insert an empty string as the default values for those fields. I’ll fix it up and upload a patch in the next few days.

    If you don’t have any objections, I’m going to mark this as resolved.

    Thanks again for your help,

    – Kevin

    Plugin Author Kevin Stover


    Just wanted to let you know that I’ve updated Ninja Forms to version which will take care of this problem. If you are experiencing this issue, please download this new version.


    – Kevin


    I am using WordPress 3.3.2 and Ninja Forms Lite 1.3.4.

    I got a similar error not being able to create any forms. I turned on the mysql-error output and saw the following errors:

    WordPress database error: [Feld ‘save_status’ hat keinen Vorgabewert]
    (Translated: field ‘save_status’ has no default value)

    So I altered the table-field by providing an empty string as default value. That’s probably not correct however it got me a step further and I got the following error:

    WordPress database error: [Feld ‘save_status_options’ hat keinen Vorgabewert]
    (Translated: field ‘save_status_options’ has no default value).

    I could play this game a little further, however I am not quite willing right now.

    Since I don’t know what the default values should be, I would ask you to take a look at this and provide a fix.

    Thank you

    Plugin Author Kevin Stover


    Hey Alex,

    If you can get into your MySQL backend, try deactivating the plugin, deleting the files, delete the 3 tables that Ninja Forms created (backup any values by exporting the values in mySQL if you have forms already on your site), then upload a new copy of Ninja Forms and re-activate. Sometimes you can get this bug if Ninja Forms fails to update properly.

    – Kevin

    Hi Kevin,

    First of all thanks for your quick reply.

    I tried what you did. However – I didn’t tell you yet – I used a complete new installation of ninja forms lite. I didn’t update it from any earlier version.

    However I did what you suggested. Reinstallation with deleting the db-tables explicitly. I tried the manual installation by downloading the plugin from and putting it into the plugins-folder of my wp-installation. Also I tried to install the plugin from the backend of my wp. In both cases no success.

    I checked the ninja_forms.php-file again and inspected the query that is used to create the 3 db-tables. Lines 311-337 is the query that creates the main table. In lines 334+334 it is explicitly stated:

    save_status varchar(10) NOT NULL,
    save_status_options longtext NOT NULL,

    So this fields mustn’t be NULL, but also no default-value is set.

    – Alex

    Also I dumped the $update_array in the file includes/save.php. So when saving a form for the first time, these keys are dumped:

    [save_subs] => checked
    [send_email] => checked
    [ajax] => checked
    [landing_page] =>
    [append_page] => s:0:””;
    [multi] =>
    [multi_options] =>
    [post] =>
    [post_options] =>
    [title] => Contact form
    [show_title] => checked
    [desc] =>
    [show_desc] =>
    [subject] => Contact via website
    [email_type] => text
    [email_from] =>
    [mailto] =>
    [success_msg] => Thank you for your request, we\’ll take care of it.
    [email_msg] =>
    [email_fields] => s:0:””;

    This shows that the necessary fields save_status and save_status_options are not provided. Maybe this helps you.

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘[Plugin: Ninja Forms Lite] Cannot create a form’ is closed to new replies.