WordPress.org

Support

Support » Plugins and Hacks » [Plugin: NextScripts: Social Networks Auto-Poster] Parse error

[Plugin: NextScripts: Social Networks Auto-Poster] Parse error

  • Hi
    After update to latest version, it showing me just this error:

    Parse error: syntax error, unexpected T_IF, expecting T_FUNCTION in ………../wp-content/plugins/social-networks-auto-poster-facebook-twitter-g/NextScripts_SNAP.php on line 442, referer: ………/wp-admin/plugins.php?error=true&plugin=social-networks-auto-poster-facebook-twitter-g%2FNextScripts_SNAP.php&_error_nonce=366b13e251

    I had to deactivate using phpmyadmin as whole blog was down.

    I removed full path for security.

    Plugin is great but useless after update.

    Can you provide old version to download?

    Regards
    PJ

    http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author NextScripts
    Participant

    @nextscripts

    Hi Turtlettpj

    Thank you for your interest to our products.

    This a very unusual error. It means class wasn’t closed before the IF statement. Will it be possible for me to take a look at your environment?

    Please contact me at support@nextscripts.com or http://www.nextscripts.com/support

    Please let me know if you have any questions.
    Ludwig Van Normainen
    NextScripts.com

    Getting the same error, but in my case, the site did not go down. The plugin just failed to get activated..

    Thanks to the support team (Ludwig), they were prompt and suggested that I turn ‘on’ the short_open_tag in php.ini file.

    But, since I don’t directly have access to php.ini, I tried searching for the php shorthand tag within the NextScripts_SNAP.php file and found that there were two places the shorthand was used – <? ... ?> instead of <?php ... ?> – replacing <? with <?php worked for me (line#322, in my case).

    <?php if(function_exists('doPostToGooglePlus')) { ?><s><? } ?><img src="<?php echo $nxs_plurl; ?>img/snap-icon12.png"/> Get the <a href="http://www.nextscripts.com/social-networks-auto-poster-for-wp-multiple-accounts/#getit">"Pro" Edition</a>. You will be able to add several accounts for each network as well as post to Google+, Pinterest and LinkedIn company pages.<?php if(function_exists('doPostToGooglePlus')) { ?></s> <i>Done! Thank you!</i><? } ?><br/>

    to

    <?php if(function_exists('doPostToGooglePlus')) { ?><s><?php } ?><img src="<?php echo $nxs_plurl; ?>img/snap-icon12.png"/> Get the <a href="http://www.nextscripts.com/social-networks-auto-poster-for-wp-multiple-accounts/#getit">"Pro" Edition</a>. You will be able to add several accounts for each network as well as post to Google+, Pinterest and LinkedIn company pages.<?php if(function_exists('doPostToGooglePlus')) { ?></s> <i>Done! Thank you!</i><?php } ?><br/>

    Plugin Author NextScripts
    Participant

    @nextscripts

    Thanks joelouis

    This is fixed in the version 2.2.4

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: NextScripts: Social Networks Auto-Poster] Parse error’ is closed to new replies.