WordPress.org

Forums

NextScripts: Social Networks Auto-Poster
[resolved] Facebook Post not in Newsfeed (9 posts)

  1. kigo17
    Member
    Posted 2 years ago #

    I followed the instructions and everything is working as stated. The only issue I have is that although the post appears on my Facebook timeline, it does not appear on the newsfeeds of my friends accounts.

    Any ideas?

    Thanks

    http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

  2. NextScripts
    Member
    Plugin Author

    Posted 2 years ago #

    Wait a little bit. Sometimes it takes Facebook couple hours to update all its servers, so you your post become visible to everyone.

  3. tayloredweddings
    Member
    Posted 2 years ago #

    I'm having the same issue as the above poster and have posted about eight hours ago and the post appears on my FB timeline but not on any of my friends newsfeeds.

    Any ideas? Thanks!

  4. kigo17
    Member
    Posted 2 years ago #

    At first I had it set as Attach Your Blogpost and it didn't post on their news feeds. I have changed it to Share a link and it seems to be working, I'll keep an eye on it over the next few days.

  5. tayloredweddings
    Member
    Posted 2 years ago #

    I've done that and still seem to have the same issue.

  6. jonahvsweb
    Member
    Posted 2 years ago #

    This still is an issue. I'm definitely not seeing it update to my newsfeed, only my personal wall. I've had Attach your blogpost set as kigo17 mentioned, so that's probably not the fix.

  7. NextScripts
    Member
    Plugin Author

    Posted 2 years ago #

    It could be several other reasons for it. It could be your default privacy settings, your App could be "Sandboxed", Low priority of your posts, etc..

    First of all check if your app is not "sandboxed":

    Facebook->Developers->Apps->Your App Basic Settings->Sandbox Mode - should be "Disabled"

    Then check "Permissions". Default Activity Privacy may be set to "Only Me"

    Then check "Advanced". Something here also could filter out your posts.

  8. jonahvsweb
    Member
    Posted 2 years ago #

    Thanks for responding so quickly. I checked your suggestions and the only one that I can see that might have been a problem was that 'Default Activity Privacy' was set to None, but I changed it to "Public". I'll update this thread with results after my next post to see what happens.

  9. Anders_bp
    Member
    Posted 2 years ago #

    I had the same problem, but found out that was sandbox mode which was not disabled.

    All have the same problem check it!

    Facebook->Developers->Apps->Your App Basic Settings->Sandbox Mode - should be "Disabled"

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextScripts: Social Networks Auto-Poster
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.