Support » Plugin: NextGEN Image Cropper » [Plugin: NextGEN Image Cropper] Just doesn't work for me

  • Resolved sigf


    Installed the plugin fine. It gives the ‘crop’ link next to the images. It loads the crop popup. However, when I click save it pauses for a second and then behind the popup I can see that it has reloaded the gallery page (above the previous gallery page) but highlighted in a red box. I assume this is because it cannot generate a error message so just reloads the page in the error box.
    Basically, the image isn’t cropped.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author mitchmccoy


    Check your browser error console for any javascript errors. It sounds like the cropping form is not submitting properly because of an error. Post any errors here.

    Thanks for the response. Sadly there are no errors in the console. Are there any known conflicts between this and common plugins? I seem to get no response from many ‘add-ins’ such as the tinymce nextgen description plugin.

    Plugin Author mitchmccoy


    It’s definitely a Javascript issue. The fact that you see the ‘Crop’ link and the image dialog popup means that some of the javascript is working. The form submission code is not however. Line 97 of /js/gallery.js is the form submission code. what browser/version are you using? Are you using jquery 1.6 or above?

    I running the Google library jquery, which I believe is 1.7.1.
    I am using Chrome, and I don’t get their version numbers but it’s up to date (and says 16.0.912.75)
    I’ve also tried it on Safari, with the same result.

    I can confirm this exact behavior.

    WordPress 3.2.1, Genesis 1.8 Framework.

    When you click save it opens up the entire Manage Gallery page in the Shadowbox for a bit, then goes right back to the Crop image window. When you close the Crop Image window there is an error message window open with the entire Manage Gallery Page embedded in it.

    Firebug did not bring up any warnings or errors.

    Had high hopes for this plugin, I think its badly needed as a core feature.

    Sorry I’m actually on 3.3.1, plugin says its only tested to 3.2.1, so maybe it needs to be updated for 3.3.1?

    I’m having the same basic problem. WordPress 3.3.1. Firefox 10/Mac.

    After firing the POST, it GETs wp-admin/load-scripts.php, and seemingly tries to get all of the scripts associated with this plugin again. I can send a screenshot from Firebug if that’s helpful.

    In Firebug, here’s the content of the POST:


    ngg_crop[cropheight] 1076
    ngg_crop[cropprocess] 1
    ngg_crop[cropwidth] 2000
    ngg_crop[optimizeforhome] 1
    ngg_crop[x1] 0
    ngg_crop[x2] 2000
    ngg_crop[y1] 0
    ngg_crop[y2] 1076
    pictureID 1

    I am having the same problem. Any news on this?

    When I “view source” on my site – it shows:
    <script type=’text/javascript’ src=’′></script>

    So – I assume that should be enough for the jquery requirements, right?

    Is there anything else to try?

    Anyone have any luck fixing this? I really need to get this plugin working.

    Thank you!

    Figured it out! On line 30 of imagecrop.php:

    <form class="ngg_crop_form" action="<?=$_SERVER['REDIRECT_URL']?>" method="post">

    I changed it to:

    <form class="ngg_crop_form" action="<?=$_SERVER['REQUEST_URI']?>" method="post">

    And the plugin works. Eventually some servers don’t support $_SERVER[‘REDIRECT_URL’]. I’m on Hostgator and I guess they don’t.

    Thank you, this did work for me. It is a shame about the Cache issues, but hey!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: NextGEN Image Cropper] Just doesn't work for me’ is closed to new replies.