WordPress.org

Support

Support » Plugins and Hacks » [Plugin: NextGEN Gallery] Won’t Create Thumbnails / Galleries

[Plugin: NextGEN Gallery] Won’t Create Thumbnails / Galleries

  • I am running WP2.5 and NGG 0.93. I have been unable to create a gallery through the interface and also unable to upload images and generate thumbs. If I manually create the wp-content/gallery/xxx and wp-content/gallery/xxx/thumbs folders, it will accept the gallery. However through the interface I always get ‘Unable to create directory’ and ‘Check safe mode’ errors.

    Here is what I have done:
    All folders in wp-content set to 777 permissions
    Modified nggallery.php as follows:

    //define('SAFE_MODE', ini_get('safe_mode'));
      // modded by ME
      define('SAFE_MODE', FALSE);

    Created a php.ini file with safe_mode=FALSE

    Here are my server settings – the memory values should be sufficient:

    # Operating System : Linux
    # Server : Apache/1.3.41 (Unix) FrontPage/5.0.2.2635 mod_psoft_traffic/0.2 mod_ssl/2.8.31 OpenSSL/0.9.8b mod_throttle/3.1.2
    # Memory usage : 17.07 MByte
    # MYSQL Version : 5.0.51
    # SQL Mode : Not set
    # PHP Version : 5.2.5
    # PHP Safe Mode : On
    # PHP Allow URL fopen : On
    # PHP Memory Limit : 48M
    # PHP Max Upload Size : 100M
    # PHP Max Post Size : 100M

    Any help would be greatly appreciated. I have been unable to get this popular plugin to work for over a week now, using both the 0.92 and 0.93 versions. Thanks.

    http://wordpress.org/extend/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 18 total)
  • This is a server settings, not a nextgen problem. As long as you have the safe mode active you must creat the folders manually…

    So am I unable to use this plugin at all? I’ve manually created the folders and set the permissions to 777 and the thumbnails are not created:

    Follow thumbnails could not created.
    
          Feb 4-4.jpg (Error : Create Image failed. Check safe mode settings)
          Feb 4-3.jpg (Error : Create Image failed. Check safe mode settings)
          Feb 4-2.jpg (Error : Create Image failed. Check safe mode settings)
          Feb 4-1.jpg (Error : Create Image failed. Check safe mode settings)
    
    Thumbnails successfully created. Please refresh your browser cache.

    I have generated my own thumbnails and placed them in the respective thumbs folders, and the thumbnails do not appear. Is there any way for me to use this plugin?

    I have no capability to turn safe mode off, as I’m using shared hosting and this is controlled by the hosting service:

    Safe_mode
    Safe_mode is enabled for all domains, and will not be disabled due to security reasons. Even if the requirements for your application need safe_mode disabled, our implementation of PHP will allow scripts to work with safe_mode enabled.

    Safe Mode is a stupid idea to make a web space save… It’s very hard to circle around it. So if you manually create all folder correct, NextGEN should handle it (I have tested it 2,3 times under safe mode enviroment). But if the server didn’t allow the creating or adding of new files , you cannot use the plugin…

    Thanks for the responses Alex. I’ll keep trying periodically in the future – I’ve seen that PHP6 has safe mode removed. Perhaps my hosting service will upgrade soon and that will solve my problems. Thanks.

    I am having this problem as well. I checked my PHP file and safe mode is OFF. I also set the permissions on the folders to 777… and I have tried just uploading 1 file which is well under the 2MB limit. Any ideas? Thanks

    asp_tags 		Off
    file_uploads		On
    include_path		.:/usr/lib/php:/usr/local/lib/php
    max_execution_time 	30
    max_input_time 		60
    memory_limit		64M
    register_globals 	Off
    safe_mode		Off
    session.save_path	N;/path
    upload_max_filesize	2M
    zend_optimizer.version	3.3.3

    What exact error message do you get ? Could you post the sever settings from the NextGEN overview menu ?

    Alex – I am having the same problem with the thumbnails. I am getting this error message:

    SAFE MODE Restriction in effect! You need to create the folder /home/wgmaas/public_html/blog/wp-content/gallery/2007-07-11-beach/thumbs manually
    When safe_mode is on, PHP checks to see if the owner (32130) of the current script matches the owner () of the file to be operated on by a file function or its directory

    I’ve gone in and deleted my thumbs folder, recreated it and I atill get the same error message.

    I’ll add in mine also, here are my server settings:
    * Operating System : FreeBSD
    * Server : Apache
    * Memory usage : N/A
    * MYSQL Version : 5.0.24
    * SQL Mode : Not set
    * PHP Version : 4.4.7
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : Off
    * PHP Memory Limit : N/A
    * PHP Max Upload Size : 2M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes
    Also when I add a new gallery it no longer adds it under gallery and is instead out under the blog root ( I had a database problem last night and I’m not sure if that is the problem)
    Either way I have copied pictures into the gallery and then did the scan gallery for new pics and it says it found X amount of pics but when I go to the gallery it shows no files no matter what I do.
    Up till 2.5 it was working wonderful.. Now I can’t see any picture in any gallery and all my wrap around NGG funtions are dead. if I go into a post and add a picture all my pictures show up like it knows they are there and it will add the picture selected.. (can we get a preview here Alex??) I tell it to float left or right or center and it ignores the command and there is no wrap around.
    Thanks Alex… love your work.. will a reload of the 2.5.1 software help? I’m going to try this and see if it helps.
    Jeff

    Not sure if this is of any help but I ran into exactly the same problem you describe.

    After playing around with evething for a while I gave it a last try and deactivated all (!) plugins and then just activated NEXTGen.

    It suddenly worked properly (upload, creating thumbnails etc.). Step by step I re-activated my other plugins and – alas – it still works.

    No idea what has caused that but it may be due to some update/overwrite (not de- and reactivating plugins) at some earlier stage which caused the proper handling of albums.

    Just my two cents …

    2raiderdav:
    I have Safe Mod: ON and I’m able create a thumbs.

    1. Create directory for Gallery
    2. Create inside this directory new directory “thumbs”.
    3. Set both directories to 777
    4. Create a Gallery
    5. Scan directory for new pictures.

    Please try it and say if it works to you too.

    Like maierma (but with later versions of wordpress – 2.6.3, and nextgen – 0.99.1) I tried many things but only all plugins except nextgen worked. I disabled Akismet, Simple Tags, IImage browser, IImage Gallery, Configurable Cloud Tag, ImageGallery, wpSearch, and WordPress Automatic Upgrade. I had foolishly let a lot of these be activated even though I wasn’t using them. NextGen Gallery did not work until it was the only plugin left. But it has continued working after I re-activated each of the plugins I really need: Akismet and wpSearch. I also will re-activate the marvelous WP auto update plugin as soon as the next WP upgrade happens. I haven’t tested NextGen Gallery with WPauto upgrade activated.

    I spent perhaps 10 hours across many days trying to figure out why NextGen Gallery wouldn’t work for me. So many thanks to maierma for trying and reporting on the one thing that was needed in my case.

    Thanx to the diactivate plugings. That defently worked. TRY THAT GUYS.

    Yes, it’s that simple and always (!) worth a try if you run into problems. Basic rule, easy to remember (and even easier to forget … ;-).

    Many plugins are not coded all too well, I assume, and can therefore cause all sorts of trouble when interacting. This doe NOT include NGG, which is great and seems to have a very slid code base!

    Hi, I’m running WP 2.6.3 and NGG 0.99.1. NGG has no problem making the folders and I can see the images being uploaded and showing up on the server. However NGG gets hung up when making the thumbnails. Maybe I’m not patient enough but how long would it normally take for one image?

    I tried deactivating all the plugins and still get stuck on the thumbnail screen.

    I was having similar problems with the application stopping on the “creating thumbnails” screen.

    I did 2 things:

    1. Noticed that I had a Thumbs.db file (created by Windows) that I had uploaded with the JPEGs I wanted added – creating a new gallery and ensuring this file was not there helped!

    2. I edited functions.php to include the fullpath to the libraries whereever ‘NGGALLERY_ABSPATH’ was referenced. I think my install was not quite working out the complete path to several libraries.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘[Plugin: NextGEN Gallery] Won’t Create Thumbnails / Galleries’ is closed to new replies.