Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » [Plugin: NextGEN Gallery] Thumbnails not generated and unable to view

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’ve the same problem…
    If i try to edit thumbnail for existing photos or upload a new photos, the error is this as follow:

    Warning: Division by zero in /web/htdocs/www.********.it/home/wp-content/plugins/nextgen-gallery/lib/ on line 293 Warning: Division by zero in /web/htdocs/www.********.it/home/wp-content/plugins/nextgen-gallery/lib/ on line 306 Warning: imagecreatetruecolor(): Invalid image dimensions in /web/htdocs/www.********.it/home/wp-content/plugins/nextgen-gallery/lib/ on line 436 Warning: imagecopyresampled() expects parameter 1 to be resource, boolean given in /web/htdocs/www.********.it/home/wp-content/plugins/nextgen-gallery/lib/ on line 940 Warning: Division by zero in /web/htdocs/www.********.it/home/wp-content/plugins/nextgen-gallery/admin/edit-thumbnail.php on line 42

    Not sure why Nextgen Gallery 1.9.3 having trouble creating a thumbnail. This was the error found:

    PHP Fatal error: Call to undefined function ImageCreateFromJpeg() in /home/domain/public_html/wp-content/plugins/nextgen-gallery/lib/ on line 179

    I solved an annoying problem with NextGen Gallery.

    On my FTP server I noticed all images and thumbs had been generated. But when managing a gallery I couldn’t see any thumbs. I Googled for a solution, with no definitive success, and I saw lots of folks have thumbnail trouble.

    I noticed gallery and thumb folders and images had different and inconsistent values. On a hunch on my ftp client I edited permissions to 755 for gallery and thumb folders. Voilá! Everything worked. I called Panix (my server) and asked if it’s okay to change permissions. They said 755 is great.

    I’ve now changed all my gallery/thumb folders and images to 755 and I’m happy. I hope this helps, and NextGen makes this info easy to find.

    @jimkend Thank you sooooo much for uncovering this. I had the same problem, and this was an instant fix.

    To others: just be sure the change propagates down to the *content* (images) in each folder, not just the folder itself!

    Glad I could help! It’s not often I stumble upon solutions others haven’t found. So when I find something useful I feel obliged to “share the love,” if ya know what I mean.

    I’m having the same problem on some of my galleries.
    Thumbnails display well on the web site but not in the ‘Manage gallery’ screens.

    I tried changing the file permission to 755 to the whole directory of a gallery (images and thumbs) as suggested in this thread but it had no effect at all.



    I actually found my problem.
    The folder names of the problematic galleries had spaces.
    I replaced the spaces with “-“, changed the gallery path in the “manage gallery” screen to reflect the change, save. And Bam, all my thumbnails appear!

    @jordl, it used to work with spaces before. I don’t know what is causing the spaces to be stripped out now, but like you, I’m having to go back & put dashes in to both my folder names and image file names.

    Hello! I have thumbnails generation problem using with WordPress 3.5 and NextGen Gallery 1.9.9

    I have a WPMU installation (I manage many websites with a single wordpress installation) and I have thumbnail generation problem only in some websites. I did try to deactivate all the plugins, but the problem persists. The only thing that changes from one website to the other is the theme, and I did try to switch the theme with the standard theme, but no difference.

    The only problem that affect all the websites is the visualization of an image using
    as this return a broken image. This affects, for example the possibility to edit a thumbnail (as the image on the left, in the dialog, does not appears). I did extensive search, but I found no solution.

    Regarding the generation of the thumbnails I get the error “A failure occurred” and pressing on “more” I read “Error: Create image failed. Check Safe Mode settings”. It cannot be the safe mode, as php.ini affects all the websites, and not just some. I searched about this, but found nothing.

    Looking at the error logs of my web server I found this:
    ”Warning: imagecreatetruecolor(): Invalid image dimensions in xxx\wp-content\plugins\nextgen-gallery\lib\ on line 555” and ”Warning: imagecopyresampled(): supplied argument is not a valid Image resource in xxx\wp-content\plugins\nextgen-gallery\lib\ on line 940”

    Anyone has some idea on how to solve this problem?

    I found that “NextGEN Facebook OG” made problem, if i deactivate this plugin gallery working fine, there are NO :
    ”Warning: imagecreatetruecolor(): Invalid image dimensions in xxx\wp-content\plugins\nextgen-gallery\lib\ on line 555” and ”Warning: imagecopyresampled(): supplied argument is not a valid Image resource in xxx\wp-content\plugins\nextgen-gallery\lib\ on line 940”

    and if I activate again “NextGEN Facebook OG” i got this massage again !

    I too am having issues with generating thumbnails, although it seems i am the only one having this issue.

    Uploading images (regardless of its size) works beautifully, but as soon as the “Generating thumbnails” dialog pops up the images keep failing. It just completely refuses to resize the images!

    The browser window also hangs so there’s not much i can do. I’m not even able to see the entire error message (i don’t even think it’s an error message, but rather some header info from the file or something…), see screenshot:

    View post on

    Here goes the server info:

    Operativsystem : Linux (64 Bit)
    Server : Apache/2.2.15 (Unix) mod_ssl/2.2.15 OpenSSL/0.9.8e-fips-rhel5 mod_bwlimited/1.4
    Minnesanvändning : 63.06 Mbyte
    MySQL Version : 5.0.90-community
    SQL Mode : Ej satt
    PHP Version : 5.2.13
    PHP Safe Mode : Av
    PHP Allow URL fopen : På
    PHP Memory Limit : 64
    PHP Max Upload Size : 50M
    PHP Max Post Size : 50M
    Gräns för PCRE Backtracking : 500000
    PHP Max Script Execute Time : 30s
    PHP Exif stöd : Ja ( V1.4 )
    PHP IPTC stöd : Ja
    PHP XML stöd : Ja
    Grafiska bibliotek

    GD Version : bundled (2.0.34 compatible)
    FreeType Support : Ja
    FreeType Linkage : with freetype
    T1Lib Support : Nej
    GIF Read Support : Ja
    GIF Create Support : Ja
    JPG Support : Ja
    PNG Support : Ja
    WBMP Support : Ja
    XPM Support : Ja
    XBM Support : Ja
    JIS-mapped Japanese Font Support : Nej

    When copying the above info i noticed the “Plugin control” module above (translated, not sure what it says in English). I ran the test and the middle one, “Test image functinoality” failed with the message “Could not create image, check your memory limit”.

    I have increased the memory_limit in on line 164. Still no success.

    I’ve also checked the folders/images for spaces or anything that might cause it to fail, but it looks fine to me. Only lower letters (english), a “-” and numbers.

    Some people reported that disabling the “fixed dimension” option would fix this, but it didn’t work for me.

    I’m out of ideas! Any suggestions?

    Edit: More information!

    It seems to be related to the filetype/size and possibly exif info of the image. I came to this conclusion because the images i’m trying to upload is a gallery of JPG images (max width/height is 800px). File sizes vary from ~200kb to ~450kb. It seems to be the case that only the images over 400kb fails. I tried converting one of the failing images to PNG, still get the same error. Okay, that solves it! Must be the filesize, right? Nope! I tried uploading another random image (not from the gallery). The one i uploaded was over 800kb in size, but i shit you not it uploaded and resized thumbnail perfectly! Soo… the last thing that could cause this is the exif info from the image, right? I don’t know…

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Plugin: NextGEN Gallery] Thumbnails not generated and unable to view’ is closed to new replies.