Support » Plugins » [Plugin: NextGEN Gallery] swobjects 2.0.4

  • Hello,

    Today I tried an update of “viper’s video quicktags” plugin, now the slideshow-widget of NG doesn’t work anymore.

    Looks like it’s because the other plugin uses already Version 2.04 of the swobject, NG uses version 1.5.
    Is it possible to update?

Viewing 15 replies - 1 through 15 (of 15 total)
  • currently not, I normally don’t plan to update swfobject, because it does the job a long time.

    But I will review it for V1.00

    Thx 🙂

    There’s a reason versions of SWFObject have been released (bugfixes, etc.). Sure, 1.x works, but 2.x works better. 😉

    Alex, I added a line into your nggwidget.php and into the nggfunctions.php (“included” the script again)…

    Not sure if it’s brilliant, but it works so far:

    $out  = "\n".'<script type="text/javascript"
    src="/wp-content/plugins/nextgen-gallery/admin/js/swfobject.js"></script><div
    class="slideshow" id="ngg_slideshow'.$galleryID.'">';
    $out .= '<p>The <a
    href="http://www.macromedia.com/go/getflashplayer">Flash Player</a> and
    <a href="http://www.mozilla.com/firefox/">a browser with Javascript
    support</a> are needed..</p></div>';

    It require a rework of my script code, so I will look for it in V1.00.

    Until that it may work that you added the V1.5 + V2.1, but I don’t know where it causes problems or not….

    Hi,

    I too am having problems with the SWFObject not defined error. I have tried adding the line into the nggfunctions.php but cant really work out where to put them…

    Would it be possible for someone to post a new widget and functions source files or paste the full code here. I love these two plugins and would love for them to work alongside each other 🙂

    No worries all, I finally worked it out 🙂 All you need to insert is this line:
    $out = "\n".'<script type="text/javascript" src="'.NGGALLERY_URLPATH.'/admin/js/swfobject.js"></script><div class="slideshow" id="ngg_slideshow'.$galleryID.'">';

    before the support line:

    $out .= '<p>The <a href="http://www.macromedia.com/go/getflashplayer">Flash Player</a> and <a href="http://www.mozilla.com/firefox/">a browser with Javascript support</a> are needed..</p></div>';

    For anyone having problems with this it is line 165 of the nggfunctions.php

    Barny

    it doesn’t work with me. 🙁

    I still get this in miy sidebar widget:

    Get the Flash Player to see the slideshow.

    Any other update on this?

    Downgrade Viper Video Quicktags to Version 5 or disable NextGEN/wordTube until I release an update.

    The documentation about swfobject says clear :

    SWFObject 2 is NOT backwards compatible with SWFObject 1.5

    i’ll wait for the update.

    Thx. 😉

    until I release an update.

    Let me know if you need any help. I know the docs are pretty clear, but I’m happy to help fellow plugin devs anyways. 🙂

    Thanks,

    I think I’m able to get this running, but it’s a bad timing. I’m in the middle of a new release for wordTube / NextGEN

    I don’t want to mess around with the code, but an update to SWFObject 2.1 support would be appreciated! I have embedded the 2.1 version to display flash content anyway, using NGG there are currently two versions loaded, which should not be necessary. Would be even better if one could choose in admin panel whether to load SWFObject or not by default.

    Too bad 🙁 I’ll wait for a new version of NextGen as well, meanwhile I have to disable Vipers Quicktags, as I do have more galleries than videos but on the other hand all my videos are offline or using the old YouTube object.

    Thank you guys. 😉

    I updated NextGEN Gallery & wordTube… please update now it should be fix the version conflict

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: NextGEN Gallery] swobjects 2.0.4’ is closed to new replies.