Support » Plugins » [Plugin: NextGEN Gallery] Space over Gallery

  • Hey.

    Someone has an Idea why i have this large Space between my Gallery an the Headline “Eine kleine Auswahl aus dem Bereich: Print” ?
    Seems that the Gallery starts after the widgets on the right side. But why?

    Thanks for help.
    Tim

Viewing 15 replies - 31 through 45 (of 70 total)
  • Thanks again WhisperT.

    This is very strange… I’m still seeing the space above all the posts (inlcluding the gallery) in Internet Explorer (version 6.0.2900.2180) and Maxthon. I’ll try installing the latest version of IE and see what that will solve 🙂 If others would take a look and please give some feedback… that would be great. I’m curious if it’s just me seeing the space and if it’s a browser problem. Please try only with IE guys, with the other browsers it works.

    Well, as awkward as it seems, after installing the latest IE, the space is gone.

    I don’t know what is wrong with IE 6, but 7 solves the problem. So guys, if you are still having the space problem, try upgrading your browsers to the latest version.

    I’m ready to go now 🙂 thanks for all the help

    I’ve asked around and the space is still there for the ones that are using 6.0.2900.2180…

    Yes it has to be a IE6 specific problem, and the space will continue to be there till you create a workaround. I will sit down and try to have a look at it today see if I can help you find what is causing it. It really is good practice to make your site pleasant for anyone coming to view your site.

    Also … are you using an OS other than Windows? I gathered that you aren’t, and that may explain why I can’t see the space.

    Have you tried to disable your plugins one at a time to see if you can narrow down which one of them may be causing the space. If the space persists even after going through the plugins then it is probably something in the theme stylesheet that is causing the trouble.

    Let me know if you find anything out it may help me in creating a work around.

    @maierma – NP, if you want to get familiar with CSS Firebug is an addon for Firefox that really can help you along your way. When used along side the information you can find on the web about good solid CSS, it can really help the learning curve.

    It lets you edit your stylesheet in a live manner that not only helps things develop faster, it also helps you see right in front of you how the things you use in your CSS file affect your design. I STRONGLY recommend using this tool and taking the time to get familiar with it.

    It really is good practice to make your site pleasant for anyone coming to view your site.

    I’m trying really hard, but as I’ve said earlier, I’m new to html and wordpress 🙂 The good thing is I read alot and I learn fast, and that there are people like you who help us beginners.

    I’m using WinXp with SP2, but I don’t think this has anything to do with it, or at least it shouldn’t.

    And yes, I have created a kind of “netowrk” between my 7 blogs, and on each of them I have installed different plugins to try them out. This seems to be a specific problem related to NextGen, or something in NextGen. The picture section is the only one with the big space in IE6.

    I had exactly the same problem on another section where not a single plugin was installed, but instead I had some scripts for live time and weather forecast. I’ve added them in the left column, and they’ve created the same issue as NGG, and only in IE6. After I took them out and put them in separate pages, the problem was gone.

    * It might have something to do with the fact that my html code is not that great, I have like 134 errors in my theme, which I compiled using tutorials and advices. 🙂 I’m trying to get them out using Firebug and Web Developer for Firefox, but it’s kinda’ hard for me… Maybe if you take a look at the code you’ll be able to find something there, ’cause this is impossible for me in my current stage.

    @@ WhisperT

    Thanks for the tips! CSS is on top of the agenda asap!

    I used Firebug (Firebug isn’t working in FF3 I’m using, will get back to FF2 for that). I had a look at the stylesheets in Firebug (and applied changes that worked) but couldn’t quite get where the “problem-styles” actually came from – in my case not from a stylesheet but from a php-file (smoothgallery).

    So, I’ve learned a bit already but will go for some css-tutorials this weekend to get a better overview.

    @ WhisperT: THANKS soooooo much!

    * Another thing that might be usefull:

    Someone said to me that it might be a problem between my theme’s CSS and the plugin’s CSS.

    I’ve fixed the html errors in the main section and now I’m fixing them throughout the rest of them.

    * The pictures section is the only one with CSS errors:

    169 .ngg-navigation Parse Error !important;
    170 Unknown pseudo-element or pseudo-class :block
    170 display Parse Error !important;
    171 padding-top Parse Error padding-top:15px;
    172 Unknown pseudo-element or pseudo-class :center
    172 text-align Parse Error center;
    174 text-align Parse error – Unrecognized }

    URI : http://www.townportal.ro/poze/wp-content/plugins/nextgen-gallery/thickbox/thickbox.css40 .TB_overlayBG Parse Error opacity=75)
    41 .TB_overlayBG Property -moz-opacity doesn’t exist : 0.75
    42 .TB_overlayBG Property opacity doesn’t exist in CSS level 2.1 but exists in [css3] : 0.75
    47 * html #TB_overlay Value Error : height Lexical error at line 47, column 81. Encountered: “?” (63), after : “” ? document.body.scrollHeight : document.body.offsetHeight + ‘px’);
    48 * html #TB_overlay Value Error : height Parse error – Unrecognized }
    64 * html #TB_window Value Error : margin-top Lexical error at line 64, column 105. Encountered: “&” (38), after : “” && document.documentElement.scrollTop | document.body.scrollTop) + ‘px’);
    65 * html #TB_window Value Error : margin-top Parse error – Unrecognized }
    135 * html #TB_load Value Error : margin-top Lexical error at line 135, column 105. Encountered: “&” (38), after : “” && document.documentElement.scrollTop | document.body.scrollTop) + ‘px’);
    136 * html #TB_load Value Error : margin-top Parse error – Unrecognized }
    145 #TB_HideSelect Parse Error opacity=0)
    146 #TB_HideSelect Property -moz-opacity doesn’t exist : 0
    147 #TB_HideSelect Property opacity doesn’t exist in CSS level 2.1 but exists in [css3] : 0
    154 * html #TB_HideSelect Value Error : height Lexical error at line 154, column 81. Encountered: “?” (63), after : “” ? document.body.scrollHeight : document.body.offsetHeight + ‘px’);
    155 * html #TB_HideSelect Value Error : height Parse error – Unrecognized }
    162 #TB_iframeContent Property _margin-bottom doesn’t exist : 1px

    OK, fixed my site BUT just noticed that the option album=ID,compact messes up the stylesheet again …

    Is this an example why the clear:both; actually is there (I took it out to get rid of the huge space above all galleries and albums)?

    Ideas?
    see here

    Guys? Any improvements?

    Can anyone give me a hand for these malfunctions?

    Alas – I managed to get the “album-overview` (compact) right!

    I followed hero-WhispertT’s advice and had a close look at the stylesheet and noticed that the nggallery.csshad a flaw which lead to the album-overview not showing correctly in compact-mode.

    In case anyone is interested, I added the following line at the very beginning of the stylesheet to the .nggallery-overview:
    overflow: hidden;

    It now reads:

    .ngg-albumoverview {
    	overflow: hidden;
    	margin-top: 10px;
    	width: 100%;
    
    }

    The result is here

    @@ DuckDuke
    I wish I could help but I’m only beginning to understand the css and how it works. You posted a couple of links, just to be sure, could you post the “trouble page” again here?

    @@ wsperuzzi

    It’s definitely the clear: both; in the nggallery.css (around line 118). Get rid off all clear: both; lines and you should be OK.

    btw: This Thread is a good read – sjould be bookmarked for future-reference onn ngg and css-issues.

    Sure. this is it:
    http://www.townportal.ro/poze

    I’ve posted another gallery in the meantime, and the same big space in lower versions of IE… And more CSS errors were created… Not to mention the horrible quality for the pics. I have to see them in full size and then zoom in to see them properly… I really don’t know what I can do about it.

    @@ DuckDuke

    Can’t access your website … maybe you are updating it just now? Or is anything broken? Server down? 🙁

Viewing 15 replies - 31 through 45 (of 70 total)
  • The topic ‘[Plugin: NextGEN Gallery] Space over Gallery’ is closed to new replies.