WordPress.org

Forums

[Plugin: NextGEN Gallery] Space over Gallery (71 posts)

  1. maierma
    Member
    Posted 7 years ago #

    @@ WhisperT

    THANKS! That was it (line 166, btw).

    I was going through many, many ... css-files and some phps but didn't manage to trace down which one produced the clear: both;. I should spend some time getting to know css a bit better.

    "Hero" struck again. ;-)

  2. DuckDuke
    Member
    Posted 7 years ago #

    Thanks again WhisperT.

    This is very strange... I'm still seeing the space above all the posts (inlcluding the gallery) in Internet Explorer (version 6.0.2900.2180) and Maxthon. I'll try installing the latest version of IE and see what that will solve :) If others would take a look and please give some feedback... that would be great. I'm curious if it's just me seeing the space and if it's a browser problem. Please try only with IE guys, with the other browsers it works.

  3. DuckDuke
    Member
    Posted 7 years ago #

    Well, as awkward as it seems, after installing the latest IE, the space is gone.

    I don't know what is wrong with IE 6, but 7 solves the problem. So guys, if you are still having the space problem, try upgrading your browsers to the latest version.

    I'm ready to go now :) thanks for all the help

  4. DuckDuke
    Member
    Posted 7 years ago #

    I've asked around and the space is still there for the ones that are using 6.0.2900.2180...

  5. WhisperT
    Member
    Posted 7 years ago #

    Yes it has to be a IE6 specific problem, and the space will continue to be there till you create a workaround. I will sit down and try to have a look at it today see if I can help you find what is causing it. It really is good practice to make your site pleasant for anyone coming to view your site.

    Also ... are you using an OS other than Windows? I gathered that you aren't, and that may explain why I can't see the space.

    Have you tried to disable your plugins one at a time to see if you can narrow down which one of them may be causing the space. If the space persists even after going through the plugins then it is probably something in the theme stylesheet that is causing the trouble.

    Let me know if you find anything out it may help me in creating a work around.

    @maierma - NP, if you want to get familiar with CSS Firebug is an addon for Firefox that really can help you along your way. When used along side the information you can find on the web about good solid CSS, it can really help the learning curve.

    It lets you edit your stylesheet in a live manner that not only helps things develop faster, it also helps you see right in front of you how the things you use in your CSS file affect your design. I STRONGLY recommend using this tool and taking the time to get familiar with it.

  6. DuckDuke
    Member
    Posted 7 years ago #

    It really is good practice to make your site pleasant for anyone coming to view your site.

    I'm trying really hard, but as I've said earlier, I'm new to html and wordpress :) The good thing is I read alot and I learn fast, and that there are people like you who help us beginners.

    I'm using WinXp with SP2, but I don't think this has anything to do with it, or at least it shouldn't.

    And yes, I have created a kind of "netowrk" between my 7 blogs, and on each of them I have installed different plugins to try them out. This seems to be a specific problem related to NextGen, or something in NextGen. The picture section is the only one with the big space in IE6.

    I had exactly the same problem on another section where not a single plugin was installed, but instead I had some scripts for live time and weather forecast. I've added them in the left column, and they've created the same issue as NGG, and only in IE6. After I took them out and put them in separate pages, the problem was gone.

    * It might have something to do with the fact that my html code is not that great, I have like 134 errors in my theme, which I compiled using tutorials and advices. :) I'm trying to get them out using Firebug and Web Developer for Firefox, but it's kinda' hard for me... Maybe if you take a look at the code you'll be able to find something there, 'cause this is impossible for me in my current stage.

  7. maierma
    Member
    Posted 7 years ago #

    @@ WhisperT

    Thanks for the tips! CSS is on top of the agenda asap!

    I used Firebug (Firebug isn't working in FF3 I'm using, will get back to FF2 for that). I had a look at the stylesheets in Firebug (and applied changes that worked) but couldn't quite get where the "problem-styles" actually came from - in my case not from a stylesheet but from a php-file (smoothgallery).

    So, I've learned a bit already but will go for some css-tutorials this weekend to get a better overview.

  8. Kijac
    Member
    Posted 7 years ago #

    @ WhisperT: THANKS soooooo much!

  9. DuckDuke
    Member
    Posted 7 years ago #

    * Another thing that might be usefull:

    Someone said to me that it might be a problem between my theme's CSS and the plugin's CSS.

  10. DuckDuke
    Member
    Posted 7 years ago #

    I've fixed the html errors in the main section and now I'm fixing them throughout the rest of them.

    * The pictures section is the only one with CSS errors:

    169 .ngg-navigation Parse Error !important;
    170 Unknown pseudo-element or pseudo-class :block
    170 display Parse Error !important;
    171 padding-top Parse Error padding-top:15px;
    172 Unknown pseudo-element or pseudo-class :center
    172 text-align Parse Error center;
    174 text-align Parse error - Unrecognized }

    URI : http://www.townportal.ro/poze/wp-content/plugins/nextgen-gallery/thickbox/thickbox.css40 .TB_overlayBG Parse Error opacity=75)
    41 .TB_overlayBG Property -moz-opacity doesn't exist : 0.75
    42 .TB_overlayBG Property opacity doesn't exist in CSS level 2.1 but exists in [css3] : 0.75
    47 * html #TB_overlay Value Error : height Lexical error at line 47, column 81. Encountered: "?" (63), after : "" ? document.body.scrollHeight : document.body.offsetHeight + 'px');
    48 * html #TB_overlay Value Error : height Parse error - Unrecognized }
    64 * html #TB_window Value Error : margin-top Lexical error at line 64, column 105. Encountered: "&" (38), after : "" && document.documentElement.scrollTop | document.body.scrollTop) + 'px');
    65 * html #TB_window Value Error : margin-top Parse error - Unrecognized }
    135 * html #TB_load Value Error : margin-top Lexical error at line 135, column 105. Encountered: "&" (38), after : "" && document.documentElement.scrollTop | document.body.scrollTop) + 'px');
    136 * html #TB_load Value Error : margin-top Parse error - Unrecognized }
    145 #TB_HideSelect Parse Error opacity=0)
    146 #TB_HideSelect Property -moz-opacity doesn't exist : 0
    147 #TB_HideSelect Property opacity doesn't exist in CSS level 2.1 but exists in [css3] : 0
    154 * html #TB_HideSelect Value Error : height Lexical error at line 154, column 81. Encountered: "?" (63), after : "" ? document.body.scrollHeight : document.body.offsetHeight + 'px');
    155 * html #TB_HideSelect Value Error : height Parse error - Unrecognized }
    162 #TB_iframeContent Property _margin-bottom doesn't exist : 1px

  11. maierma
    Member
    Posted 7 years ago #

    OK, fixed my site BUT just noticed that the option album=ID,compact messes up the stylesheet again ...

    Is this an example why the clear:both; actually is there (I took it out to get rid of the huge space above all galleries and albums)?

    Ideas?
    see here

  12. DuckDuke
    Member
    Posted 7 years ago #

    Guys? Any improvements?

    Can anyone give me a hand for these malfunctions?

  13. maierma
    Member
    Posted 7 years ago #

    Alas - I managed to get the "album-overview` (compact) right!

    I followed hero-WhispertT's advice and had a close look at the stylesheet and noticed that the nggallery.csshad a flaw which lead to the album-overview not showing correctly in compact-mode.

    In case anyone is interested, I added the following line at the very beginning of the stylesheet to the .nggallery-overview:
    overflow: hidden;

    It now reads:

    .ngg-albumoverview {
    	overflow: hidden;
    	margin-top: 10px;
    	width: 100%;
    
    }

    The result is here

    @@ DuckDuke
    I wish I could help but I'm only beginning to understand the css and how it works. You posted a couple of links, just to be sure, could you post the "trouble page" again here?

  14. maierma
    Member
    Posted 7 years ago #

    @@ wsperuzzi

    It's definitely the clear: both; in the nggallery.css (around line 118). Get rid off all clear: both; lines and you should be OK.

    btw: This Thread is a good read - sjould be bookmarked for future-reference onn ngg and css-issues.

  15. DuckDuke
    Member
    Posted 7 years ago #

    Sure. this is it:
    http://www.townportal.ro/poze

    I've posted another gallery in the meantime, and the same big space in lower versions of IE... And more CSS errors were created... Not to mention the horrible quality for the pics. I have to see them in full size and then zoom in to see them properly... I really don't know what I can do about it.

  16. maierma
    Member
    Posted 7 years ago #

    @@ DuckDuke

    Can't access your website ... maybe you are updating it just now? Or is anything broken? Server down? :-(

  17. DuckDuke
    Member
    Posted 7 years ago #

    Yes, it was down all day, "thanks" to my hosting... It happens now and them, they say they're upgrading and sometimes they have problems "upstream". No ideea what that means. :)

    Anyway, now is working "fine".

    WshiperT and Alex, we (or at least I) need help with this.

  18. DuckDuke
    Member
    Posted 7 years ago #

    Anyone?

  19. maierma
    Member
    Posted 7 years ago #

    Just to make sure: Have you deactivated Lightbox (in ngg & plugins)? Lightbox has an issue with IE6.

    Don't have IE6 here (and why should one use a stupid browser with no tabs?), can't really check what's going on there.

    No idea what your blog is about, the pictures in between the text are are certainly ... questionable content, don't you think?

  20. Alex Rabe
    Member
    Posted 7 years ago #

    I also can't help... i didn't use IE6 anymore. Sorry

  21. DuckDuke
    Member
    Posted 7 years ago #

    No idea what your blog is about, the pictures in between the text are are certainly ... questionable content, don't you think?

    I found those on the forum on one of the biggest financial newspapers in our country. I'm making posts about things like that sometime. To show people how some don't care about their website at all.

    Anyway, on the matter at hand: this is not an issue about IE6. It's the CSS in general. In Firefox, in Opera. All those errors are from the CSS, not because of IE6...

    There are 2 problems.
    1. The big space in lower versions of IE.
    2. Those CSS and html errors which appear in all browsers.

    The plugin is generating somehow 22 CSS errors, and dozens of html errors. Here are 2 examples of pieces of text/code that the validator shows as errors:

    CSS: 169 .ngg-navigation Parse Error !important;

    html: <font color="#ffffff">*</font>
    <div class="ngg-galleryoverview" id="ngg-gallery-8"><div id="ngg-image-35" class="ngg-gallery-thumbnail-box desc">

    ... On the other blogs where I don't have NGG installed I have 0 errors now, both in html and CSS. I don't know if it's a conflict with my theme or something native, it would be nice if someone who cares about validation and has NGG installed would share some knowledge on this.

  22. DuckDuke
    Member
    Posted 7 years ago #

    Oh, and I don't use Lightbox.

  23. Alex Rabe
    Member
    Posted 7 years ago #

    If you have validation problems with thickbox.css, you should switch the effect. I never looked for the CSS valdiation inside of thickbox...

    If i use the W3C validtaion for CSS I get a couple of errors, but they are all related to Thickbox (and some warnigs, which i ignore myself)

    The W3C HTML validation says it's "Valid XHTML 1.0 Transitional"

    So, no problem with the code, but maybe a problem in combination with a theme file. So use the default theme and try to reduce the number of plugins to find the problem source.

  24. DuckDuke
    Member
    Posted 7 years ago #

    Thickbox is off. I have no effect.

    Still the following CSS errors:
    169 .ngg-navigation Parse Error !important;
    170 Unknown pseudo-element or pseudo-class :block
    170 display Parse Error !important;
    171 padding-top Parse Error padding-top:15px;
    172 Unknown pseudo-element or pseudo-class :center
    172 text-align Parse Error center;
    174 text-align Parse error - Unrecognized }

    As for other plugins, I've tried deactivating all of them except ngg and the problem remained the same.

    And I have alot of html errors as well when I try validating, lik this one:

    Line 564, Column 87: document type does not allow element "div" here; missing one of "object", "applet", "map", "iframe", "button", "ins", "del" start-tag.

    …g-galleryoverview" id="ngg-gallery-8"><div id="ngg-image-35" class="ngg-galle...

  25. DuckDuke
    Member
    Posted 7 years ago #

    Anyone? Anything?

  26. dheerg
    Member
    Posted 7 years ago #

  27. DuckDuke
    Member
    Posted 7 years ago #

    I will try to see if that's the solution to the problem.

  28. iam123
    Member
    Posted 7 years ago #

    very intresting theme i think

  29. DuckDuke
    Member
    Posted 7 years ago #

    @Dheers (and anyone else):
    I've just replaced the thickbox code with what you had on your site, and I still gave these errors:

    CSS:
    169 .ngg-navigation Parse Error !important;
    170 Unknown pseudo-element or pseudo-class :block
    170 display Parse Error !important;
    171 padding-top Parse Error padding-top:15px;
    172 Unknown pseudo-element or pseudo-class :center
    172 text-align Parse Error center;
    174 text-align Parse error - Unrecognized }

    And a bunch of html errors that seem related to the NGG plugin. Here's the link for the validation page.

    Why do I say related to NGG? Because they appear on a single post, the one that I've used to post some pictures using NGG:
    http://www.townportal.ro/poze/proprii/poze-pentru-seo/

    It seems that something is really wrong here, netween my theme and this plugin... Does no one know how to fix this?

    @Iam123: Mine or Dheers's ? :)

  30. qaxooti
    Member
    Posted 7 years ago #

    i think i may have figured out how to get rid of the extra spaces that appear at the top.

    here is what i had written before:

    [album=13,extend]
    [album=14,extend]
    [album=15,extend]

    this would put album 13 right under my header, then 14 a space under that, and 15 two spaces under 13.

    This is how I got rid of the space that would appear at the top of the galleries:

    [album=13,extend][album=14,extend][album=15,extend]

    I lined up all the albums next to one another and when I clicked on any particular album, they all appeared the same number of spaces under the gallery header.

    It's odd, but it did the trick for me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.