Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » [Plugin: NextGEN Gallery] So You Can NOT Put Multiple Galleries on A Page OR In A Post, Is That Corr

  • (Note: I’m using WP 3.01 and latest version of the NEXTGEN gallery plugin.)

    The plugin is great, BUT …

    I have searched for an hour and can’t figure out how to display more than 1 “gallery” or more than 1 “album” — on a PAGE or IN A POST in WordPress.

    So, is there really NO way to do this with the NEXTGEN plugin? If so, that’s a shame, and can I ask if anyone knows of another gallery plugin that WILL let you do this? Sorry, but I’m very confused here.

    Thank you very much for any help. 🙂

    http://wordpress.org/extend/plugins/nextgen-gallery/

Viewing 15 replies - 1 through 15 (of 23 total)
  • I have the same question.

    I want to create a page named PHOTOGRAPHY, and put multiple galleries or albums on this page. But I can’t even get 1 gallery showing on the photography page, even though I already made PHOTOGRAPHY as the parent page.

    So I’m equally confused. Looking forward to your help, and many thanks in advance!

    I can get ONE gallery or ONE album to show, but apparently there is no gallery plugin anywhere that will allow you to display MORE than one gallery/album withing ONE WP PAGE OR ONE WP POST.

    I find this hard to believe? With all the “gallery” plugins there are?

    But, maybe that’s just the way it is. I will keep waiting and checking back to see if some smart person can help or point to a new plugin or some clever way to make this happen.

    🙂

    I’m trying to do the same thing.

    I did find this, which I’m trying out now: http://www.clickonf5.org/smooth-slider.

    I’m no expert, but I believe you just put multiple codes. Ie
    [nggallery id=1]
    [nggallery id=2]
    And they’ll both show up.

    Leahs, nope, that was the first thing I tried. It will display ONE gallery (the first one) but not the second, or third, etc.

    Thanks, though!

    Websta — I’ll be interested to know if that works for what we want, but I see where it says “Post/Pages can be selectively put in the slider of your choice.” That sounds like singular — i.e., “ONE SLIDER.” Hope I’m wrong.

    Me too.

    From http://wordpress.org/extend/plugins/smooth-slider/

    “Highlighted Feature (from version 2.2) : Ability to create ‘Multiple’ sliders and an option to decide which post/page should show which slider”

    Sounds like you can create all the sliders you want — nice — but then you must decide “which post/page should show each (one?).”

    Bummer.

    Right, you create different sliders (say, from posts in a category) and then you assign those specific sliders to a particular Page/post (or category-##.php? I hope?).

    I can’t figure out how to call specific sliders though…

    If you get it working, I’d sure love to know how. It’ll be interesting to see if it lets you assign more than 1 slider to a page or post.

    Thanks. I will check back.

    I typed in “multiple galleries” for the plugin search, and found a few that seem to have some potentials to meet our needs. I’m still exploring myself, not sure if they work. Below are the plugins I found:

    1. Multiple Galleries
    – This plugin adds checkboxes next to images you have uploaded to a gallery in a post. Selecting checkboxes will include those images in that particular gallery.
    To create another gallery within the same post, simply choose ‘Insert Gallery’ and select the images.

    2. Light Box Gallery
    – on the faq page I saw this:
    * How can I handle multiple galleries in one page as separate ones?
    If you would like to handle galleries separately, add different class names into [gallery]. ex) [gallery class="gallery2"]

    3. File Gallery (multiple galleries per post with custom attachment order)

    4. Galleria WP (Multiple galleries on a page)

    Funny, I have more than one on a page, works just fine http://cameoflooring.com/specials/carpet/ except with explorer that is, with that I am getting slivers instead of images

    My entire site is practically made up of pages which each contain several galleries. I’m not sure why you’re having trouble. Here’s a good example, this page has over 30 galleries on it!

    http://www.thedrewseum.com/updates/8x10film/

    All we did was put in the coding like described above ([nggallery id=1], [nggallery id=2], etc)

    Thank you everyone!
    I should specify what happens when I enter the code for the second or third of fourth gallery: it will only display the FIRST gallery, and the others are displayed as the CODE [nggallery id=X] right under the last pic in the FIRST gallery.

    OR, I try again on another page, and as soon as I click SAVE, the first gallery no longer SHOWS THE PICS (it just has “picture 1” “picture 2” markers where the pics were SHOWING before!) and the newer gallery id DOES SHOW.

    It’s so weird!

    Something must happen to the existing gallery (first one) when I cut-and-paste the gallery id code into the page and hit save. But I have no idea what happens to it.

    thedrewseum: Wow, your site is beautiful! And that is what I need: just like you have it set up. You are using the NEXTGEN Gallery plugin, right? Just to check. And you stick in the code (above) and it works for you?

    This is so odd. Maybe you are using an old version of the plugin that allowed the multiple galleries to show on a page or post?

    Thanks so much for posting your info!

    carpetguy: Thank you, also! I will keep working on getting to the bottom of this.

    I think I am narrowing the problem down. It is something with the “Effects” that is not working correctly.

    Which “effects” (lightbox, shadowbox, etc.) are you guys using? I have it set right now on “lightbox” and the first gallery is not showing, like I said, although the second is. Also, if you click on where the pics SHOULD be showing and aren’t — in the first gallery I mean — the lightbox effect opens but just spins and spins and spins and doesn’t load. So apparently something is NOT FINDING nggallery 1 after I add nggallery 2 to the same page.

    OK, I reinstalled the NEXTGEN plugin from scratch and activated the THICKBOX effect and it is all working now. I have no idea what caused the problems I was having adding more than one “gallery” to a post or page.

    Just wanted to add this in case someone comes along wondering what happened in the end: my answer is, “I don’t have any idea.”

    Good luck everyone and thanks again.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Plugin: NextGEN Gallery] So You Can NOT Put Multiple Galleries on A Page OR In A Post, Is That Corr’ is closed to new replies.