NextGEN Gallery
Slideshow is not working (13 posts)

  1. csigncsign
    Posted 4 years ago #


    I use WordPress 3.0.1 as a multiblog system, the newest NextGen Plugin and the newest JW-Image-Rotator.

    In the Nextgen settings at "slideshow", there is (!) the right path to the Rotator; Nextgen found it by itself, when I click at "search".

    I have a gallery with 6 images in it, ID=6. The gallery view works perfect at a page, I can see all images!

    Then I would like to show in an article this gallery as a slideshow (same sub-blog of this multiblog system, by the way!) using

    [slideshow id=6]

    But I only see the rotator, no images!

    I have read the FAQs here:
    and I do have
    <?php wp_head(); ?>
    in my template!

    The page, where the slideshow does not work, is here:


    (I could suppose, that this is a multiblog problem?
    Because at another website, where I use multiblog, too, another gallery plugin has also problems because of using the right path, because multiblogs have a "blogs.dir" directory and in the gallery script this is not considered.)

    What could be the problem and what can I do, do get the slideshow working? Deactivating all other plugins has not solved it.



  2. csigncsign
    Posted 4 years ago #

    By the way:

    NextGen Plugin is activate multisite wide and I use version 1.6.2

  3. csigncsign
    Posted 4 years ago #

    And another info:

    I use domain mapping:

    http://my-name.de/blog1/ is mapped to http://blog1.my-name.de!

    Maybe this is important, because Firebug gets an error message, when I try to analyze the page:


  4. csigncsign
    Posted 4 years ago #

    No one an idea how to get a slideshow working at multiblog?

  5. irishrunner16
    Posted 4 years ago #

    I just activated multisite and am now having this same issue - the slideshow doesn't load in a widget or when clicking "view as slideshow" on a page.

    It appears the issue is somehow related to multisite, because when I was not running multisite, it worked with my theme.

    The JW Image Rotator does work with multisite, but due to the JW logo appearing on it, I would really like to have your default slideshow work.

    This is the error that comes up with firebug:
    jQuery("#ngg-slideshow-0-14-1").nggSlideshow is not a function
    jQuery("#ngg-slideshow-0-14-1").nggSlideshow( {id: 0,fx:"fade",width:200,height:160,,timeout:5000});
    210</script> </div>

  6. latha_wp
    Posted 4 years ago #

    Even i am having the same issue.

    Getting same error on multiblog.

    Did any tweak solved this problem? If yes can you please let me know..

    Thanks in advance

  7. tstruyf
    Posted 4 years ago #

    I'm having the same problems: Loading gif appears, and no images.
    Important detail: I'm NOT using multiblog
    Firebug reports ".nggSlideshow is not a function" 2 times !

  8. angelajude
    Posted 4 years ago #

    Hi --

    Having the same issue here. I am NOT using multi-site and the crazy thing is that 4 out of the 6 slideshows I have are working. Two of them just get stuck on the loading gif.

  9. Joerg
    Posted 4 years ago #

    I have the same problems, also running blog with NextGen Gallery in a Multiblog environment with WP 3.0.3.

    Beyond that I can not change the standard gallery path at the options!?

  10. artestates
    Posted 4 years ago #

    I am also having the same problem as the posters above. Has this issue been resolved. This is quite frustrating. IS THERE ANYONE OUT THERE!?

  11. maver
    Posted 4 years ago #

    I am unable to get the slideshow to work. The path to my imagerotator file is /wp-content/plugins/nextgen-gallery/ and it has been added to the options in the next gen plugin.

    I get the circling loader that wants to start the slideshow but thats all. I am able to view the picture gallery perfectly. No problems there.

    Any thoughts please



  12. it@lkwa.net
    Posted 4 years ago #

    I am having similar problem with the slide-show works fine in FireFox but all I get in IE7 or IE8 is the loader Image-Rotator.
    WordPress 3.0.1
    NextGen Plugin 1.74

    Anybody have a clue how to fix this????

  13. kyleiwaniec
    Posted 4 years ago #

    I had the same problem. It turned out I had multiple references to jquery because every plugin using jquery was inserting its own link to it in wp_head (in the <head> of your page), thus they were clashing.

    There are some things you can do to fix this. I found this little code snippet which removes all jquery and only inserts only the one you specify:

    put this in your functions.php file:

    /* stop loading multiple jquery scripts by plugins */
    if( !is_admin()){
    wp_register_script('jquery', ("https://ajax.googleapis.com/ajax/libs/jquery/1.5.0/jquery.min.js"), false, '1.3.2');

    However, that works if your plugins are properly written. My google calendar plugin was not, and was ignoring this. And for some reason my jquery drop-downs didn't like it. In the end, I didn't use this trick. I had to go into my calendar code and remove their reference to jquery. That fixed it. And everything is working now.

    I hope this helps someone.


    PS. Oddly enough, I still have an extra link to jquery (from a different plugin), but things are working fine, so I'm leaving it alone :).

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.