WordPress.org

Support

Support » How-To and Troubleshooting » [Plugin: NextGEN Gallery] Slideshow doesnt work with last uptdate

[Plugin: NextGEN Gallery] Slideshow doesnt work with last uptdate

  • Hello,
    I’ve been using Next Gen Gallery slideshow widget for two months.
    Everything goes ok ๐Ÿ™‚

    But, with last update of Next Gen Gallery, slideshow doesn’t work.
    It allways says:
    Get the Flash Player to see the slideshow.
    But I have it installed and I tried to view this slideshow in several computers with allways same message.

    My site is:
    http://www.magarciaguerra.com/

    Please, could you tell me what can I do?

    Thanks a lot
    Miguel

Viewing 15 replies - 1 through 15 (of 55 total)
  • I had the same problem.
    I noticed it was because swfobject.js (inside admin/js) wasn’t put inside the <head> of my pages.
    So in nggallery.php I just commented out line 283:
    //if ( $this->options['galShowSlide'] )
    This forced the plugin to enqueue the swfobject.js file.

    That seemed to do it for me. I don’t know why $this->options[‘galShowSlide’] was false, but it was, and cause it to not enqueue the js file.

    Hope that helps.

    Thanks but I don’t have any idea how to do this
    ๐Ÿ™

    Under plugins in your dashboard, click on editor and then click on “NextGEN Gallery” in the right hand side (You can probably get to it here: http://www.magarciaguerra.com/wp-admin/plugin-editor.php?file=nextgen-gallery/nggallery.php). Search for “if ( $this->options[‘galShowSlide’] )” and then add two forward slashes to the beginning of it like this //if ( $this->options[‘galShowSlide’] ).
    That tells php to ignore that line of code.
    Save the file (make sure the file is writable by your server) and see if it makes your slideshows work.

    Thanks a lot… but… it doesn’t work.
    I’ve tried it, same error.

    :’-(((

    @ryancp, man! thank you so much! my slideshow works like a charm now!

    @ryan
    THX I will change that for the next release

    @magarciaguerra
    http://www.magarciaguerra.com/wp-content/plugins/nextgen-gallery/admin/js/swfobject.js?ver=2.1 return a error 403. Check your file permissions

    Hello again…

    @alexrabe
    I also tried to set chmod of swfobject.js to 777 few minutes ago.
    Error persists

    I will remove next gen gallery slideshot widget of my blog until next update.
    ๐Ÿ™

    Now, this file has again default chmod.

    Thanks anyway

    There will be no fix, it’s your settings not a nextgen issue

    I’m having sort of the same problem, but I’m not receiving any error messages.
    2.7 and ng 1.0.1
    Just the slideshow mode not working, either when it’s invoked by clicking [Show as slideshow] from the picture view, or when it’s invoked with [slideshow id=1] in a page.

    Tried commenting out the 283 line, but no change.

    Any ideas on what to check next, Alex, or anyone?

    TIA,
    art

    Hello I have this same issue on my site

    I have tried what ryancp says with no success, unfortunately.

    Does anyone else have any clues as to how I can fix this as I would really like this issue resolved as I am sure others would too.

    Open to any suggestions. Thanks in advance,

    Keren

    Hi Alexrabe,

    You state There will be no fix, it’s your settings not a nextgen issue

    Then could you please advise us what we need to change exactly to fix this issue as we are site administrators and have root access to our server so can try changing anything you say is causing this issue.

    Thanks in advance,

    Kind regards,

    Keren

    There will be no fix, it’s your settings not a nextgen issue

    I really don’t know what I have to do.
    Before update it works very well, after update it doesn’t work. I didn’t change anything in my configuration files.

    Please, could you give us a list of things to do?

    Thanks a lot ๐Ÿ˜‰

    In Magarciaguerra case, the script file has no access from the web, so it failed.

    In all other cases I need a example link…

    Ok, I set chmod 755 to folder not only to file.
    So, folder
    /wp-content/plugins/nextgen-gallery/admin/js/
    has 755

    It seems work now… almost, cause no picture is showed in slideshow
    ๐Ÿ™

    Some screenshots of configuration
    http://www.magarciaguerra.com/01.jpg
    http://www.magarciaguerra.com/02.jpg
    http://www.magarciaguerra.com/03.jpg

    In Slideshow
    Try XHTML validation (with CDATA) is UNchecked

    Anyway, I’m using NextGen slideshow widget.

    Thanks again and Iยดm sorry for all this questions

    RESOLVED!!!

    all folder
    /wp-content/plugins/nextgen-gallery/
    and all files on it must have 755 chmod

    NextGen Gallery Slideshow widget works!!!!

    http://www.magarciaguerra.com

    Thanks to everybody helping me

Viewing 15 replies - 1 through 15 (of 55 total)
  • The topic ‘[Plugin: NextGEN Gallery] Slideshow doesnt work with last uptdate’ is closed to new replies.
Skip to toolbar