Support » Plugins and Hacks » [Plugin: NextGEN Gallery] Reflection on thumbnails

[Plugin: NextGEN Gallery] Reflection on thumbnails

  • Every time I use this tag for creating thumbnail
    <?php the_post_thumbnail(array($width,$height,true)); ?>, WP (or NGG, don’t know) creates thumbnails with reflections, but when I remove true argument from tag, it creates thumbnails but with variable width/height, and no reflection. How can I disable reflection on thumbnails? Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Have you resolved the problem?
    I have got the same problem and can´t explain where the reflection is coming from? Seems like a easter Egg or something….. very strange.

    anyone a suggestion?

    That’s exactly what i was looking for too! Someone?

    I´ve run some tests and it seems to have something to do with the NextGen Gallery plugin, like you said before. When I disabled it the thumbnails worked fine.. the problem is that i need this plugin in my theme.

    I think there is a problem with the cached images. The NGG thumbs look OK, but the cached images on the server have the reflection in it. I also need both functions and have no clue….

    I got it. Had to edit some nextgen files:

    Comment the following lines:

    • in the nextgen-gallery/lib/image.php file: 177

      where it says: $thumb->createReflection(40,40,50,false,'#a4a4a4');

      and the lines 165 to 173
      where it says:

      if ($ngg_options['wmType'] == 'image') {
      $thumb->watermarkImgPath = $ngg_options['wmPath'];
      $thumb->watermarkImage($ngg_options['wmPos'], $ngg_options['wmXpos'], $ngg_options['wmYpos']);
      if ($ngg_options['wmType'] == 'text') {
      $thumb->watermarkText = $ngg_options['wmText'];
      $thumb->watermarkCreateText($ngg_options['wmColor'], $ngg_options['wmFont'], $ngg_options['wmSize'], $ngg_options['wmOpaque']);
      $thumb->watermarkImage($ngg_options['wmPos'], $ngg_options['wmXpos'], $ngg_options['wmYpos']);
    • in the nextgen-gallery/nggshow.php file: 60

      where it says:

    Ah… Thank you so much. That solved the problem. I don´t like these “hacks” and workarounds (because I will forget the trick untill the next update), but most important is, that its running now.

    Thanks again, saved me a couple of hours…

    Kirk Wight


    Theme Wrangler

    Under Gallery > Options > Images, just uncheck “Cache Single Pictures” and then clear the cache folder.
    Not sure what that’s all about, but as long as this setting isn’t important to you, it will avoid having to change plugin files after an update.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: NextGEN Gallery] Reflection on thumbnails’ is closed to new replies.