Support » Plugin: NextGEN Gallery Optimizer » [Plugin: NextGEN Gallery Optimizer] Pro issues

  • Resolved jenncash

    (@jenncash)



    I’ve never used this Optimizer plugin, but went ahead and donated for the Pro version since I’m using various shortcodes. The most common issues explained in the FAQ are all true for me despite following the instructions provided.
    1. galleries are displaying in a vertical line regardless of the stylesheet I choose (I have not yet tried writing my own)
    2. image thumbnails click through to URL, not lightbox. I did check the appropriate box in Step 2 set up, added “class=…” string where directed, and made sure “Deactivate…” was checked in Gallery settings.
    Beta site is here:
    http://eastendforks.com/2012/05/23/bresola-egg-arugula-salad/
    access: east4748

    http://wordpress.org/extend/plugins/nextgen-gallery-optimizer/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi jenncash,

    Thanks for downloading NextGEN Gallery Optimizer Premium!

    I’ve taken a look through your site (thanks for the link) and have been testing the Pagelines framework on my development server…which is working for me without any problems.

    From your site’s source code, I can see that Optimizer is indeed activated and is removing NextGEN’s scripts and styles as it should. However, for some reason it isn’t detecting your gallery and singlepic shortcodes and loading the appropriate scripts and styles.

    Is it possible that you’ve deactivated the “PostLoop” option at either Pagelines –> Templates, or through the options on the post editing screen?

    Optimizer can only detect actual shortcodes inserted in the post editor such as [nggallery id=x], so if you’ve hard-coded direct calls to NextGEN functions in your template (eg. <?php echo do_shortcode(‘[nggallery id=x]’); ?>), Optimizer won’t be able to intercept these and fire off the appropriate scripts and styles…including the stylesheet to display your thumbnails horizontally, or those required for Fancybox to function.

    Potential fixes:
    1. If this is indeed the problem, you could reactivate “PostLoop” and use the post editor for your posts and shortcodes.
    2. If that’s not possible/desirable, I’ve just discovered that even when the “PostLoop” option is turned off, WordPress DOES still process the loop! So, if you insert the corresponding shortcode in the post editor of each post, that will trigger the scripts, and the galleries themselves will still display according to their current placement in your template.

    Hope this helps!

    Cheers,
    Mark.

    PS. Just a heads-up also, I’m running in debug mode and Pagelines is pulling errors in relation to deprecated theme functions phased out as of WordPress 3.4. Even if that’s not the problem here, it would be worth keeping an eye out for an update if you haven’t done so already.

    Hi Mark,
    Sadly this information doesn’t help. I haven’t deactivated
    “PostLoop” or changed any setting that would do so. I’ve double checked around settings also.
    I’m not doing anything fancy with the shortcode. On this page, (http://eastendforks.com/2012/05/23/bresola-egg-arugula-salad/) I’m using the following shortcodes:
    [slideshow id=1]
    [singlepic id=19 w=800]
    [nggallery id=2]
    I’m also using other plugins that use shortcode within the post editor. (Easy Columns and Special Recent Posts) Could that be a conflict?
    I’ve already upgraded to WP3.4, but haven’t upgraded to Pagelines 2.2.1 yet.

    Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hi jenncash,

    I’m sorry to hear that. And thank you for the further details.

    I’ve been testing the two plugins you mentioned with Pagelines, and there doesn’t appear to be any conflicts on my setup (although Easy Columns is showing some errors of its own).

    I’d be interested to know what other plugins you’re using, in particular the plugin that’s password-protecting your site. It might be making WordPress think it’s in the admin section once you log in, which could indeed prevent the loading of the required scripts.

    Are you using a caching plugin at all (eg. WP Super Cache, W3 Total Cache)? These may need to be cleared.

    Also, if I could get you to confirm you have <?php wp_head(); ?> present in your Pagelines header.php file, that would be great.

    Cheers,
    Mark.

    Thanks for your continued help Mark.
    I’m not using any caching plugins though Special Recent Posts does have a thumbnail cache. I emptied it just to check; no change.
    Also, I tried deactivating the password plugin; no change.
    However, I do NOT have <?php wp_head(); ?> present in the Pagelines header.php file. Is this something I should add? Where? Please be specific about syntax as well (include carrots and ?s or not).
    Thanks,
    Jenn

    Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hey Jenn,

    Sounds like we may have found the cause 🙂

    If you place <?php wp_head(); ?> immediately before the closing </head> tag in header.php, that should help things.

    Every WordPress theme should include this, as it’s a crucial hook intended to be used by plugins to add scripts and stylesheets to any given page.

    Cheers,
    Mark.

    Hi Mark,
    I did add to the php as directed, but that didn’t solve it. However, I upgraded to Pagelines 2.2 and am using their new grid system divs for columns rather than Easy Columns plugin. Without the Easy Columns shortcode, NextGen seems to be working now!

    Thanks,
    Jenn

    Plugin Author Mark Jeldi

    (@mark-jeldi)

    Hey Jenn,

    That’s fantastic news! Glad to hear it’s all working for you now.

    Thanks for replying with your fix also…it may well help other people experiencing similar issues.

    Cheers,
    Mark.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Plugin: NextGEN Gallery Optimizer] Pro issues’ is closed to new replies.