WordPress.org

Support

Support » Plugins and Hacks » [Plugin: NextGEN Gallery] Nextgen Gallery Slideshow Doesn't Load on Parked Domains

[Plugin: NextGEN Gallery] Nextgen Gallery Slideshow Doesn't Load on Parked Domains

Viewing 10 replies - 1 through 10 (of 10 total)
  • Can someone please help with this issue?

    Any ideas?

    The flash slideshow require in this case a crossdomain.xml . Google for it , could be the reason

    Thank you for your reply. I googled crossdomain.xml and put the following code in a crossdomain.xml file that I uploaded to the public_html directory of my website, and it’s still not working… am I doing something wrong?

    <?xml version="1.0"?>
    <!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
    <cross-domain-policy>
        <site-control permitted-cross-domain-policies="all" />
        <allow-access-from domain="www.servprocicero.com"/>
        <allow-access-from domain="servprocicero.com"/>
    	   <allow-access-from domain="www.servpro9781.com"/>
        <allow-access-from domain="servpro9781.com"/>
    	   <allow-access-from domain="www.servprochgo.com"/>
        <allow-access-from domain="servprochgo.com"/>
    </cross-domain-policy>

    Not sure where exact it should be placed, need to look for it

    OK I updated the code to allow for all domains just in case, and I tried putting it in 3 different locations:

    1. the server root
    2. the public_html folder and
    3. the wp-content folder and it’s still not working. Not sure what else to try. A friend suggested I use this code instead to allow all domains and nothing I am doing is working. Any other suggestions?

    <?xml version="1.0" ?>
    <cross-domain-policy>
      <site-control permitted-cross-domain-policies="master-only"/>
      <allow-access-from domain="*"/>
      <allow-http-request-headers-from domain="*" headers="*"/>
    </cross-domain-policy>

    Ahh I see , you didn’t use the flash sildeshow, you use the javascript based solution. Sorry for the misleading information. In this case it’s a Access-Control-Allow-Origin issue.

    In the script console you will see : XMLHttpRequest cannot load http://www.servprolagrangepark.com/index.php?callback=json&api_key=true&format=json&method=gallery&id=1. Origin http://servpro9781.com is not allowed by Access-Control-Allow-Origin.

    I need to look how to fix this in the future, but it will take some time

    If I change it to flash, will it work?

    not sure.. test it

    Thanks, I switched it to flash from javascript and it seems to be working now.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: NextGEN Gallery] Nextgen Gallery Slideshow Doesn't Load on Parked Domains’ is closed to new replies.