WordPress.org

Forums

NextGEN Gallery
Nextgen Gallery Slideshow Doesn't Load on Parked Domains (11 posts)

  1. dhobeika
    Member
    Posted 4 years ago #

    We are using the nextgen gallery slideshow on ServProLagrangePark.com and it works great. However, we have a series of other parked domain names that point to the same website, including http://servpro9781.com/, http://servprocicero.com/, and more.

    You will notice that the slideshow doesn't load up on the parked domains, but works fine on the main domain. Is there a way to get it to show up on all of the domains that point to the same address?

  2. dhobeika
    Member
    Posted 4 years ago #

    Can someone please help with this issue?

  3. dhobeika
    Member
    Posted 4 years ago #

    Any ideas?

  4. Alex Rabe
    Member
    Posted 4 years ago #

    The flash slideshow require in this case a crossdomain.xml . Google for it , could be the reason

  5. dhobeika
    Member
    Posted 4 years ago #

    Thank you for your reply. I googled crossdomain.xml and put the following code in a crossdomain.xml file that I uploaded to the public_html directory of my website, and it's still not working... am I doing something wrong?

    <?xml version="1.0"?>
    <!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
    <cross-domain-policy>
        <site-control permitted-cross-domain-policies="all" />
        <allow-access-from domain="www.servprocicero.com"/>
        <allow-access-from domain="servprocicero.com"/>
    	   <allow-access-from domain="www.servpro9781.com"/>
        <allow-access-from domain="servpro9781.com"/>
    	   <allow-access-from domain="www.servprochgo.com"/>
        <allow-access-from domain="servprochgo.com"/>
    </cross-domain-policy>
  6. Alex Rabe
    Member
    Posted 4 years ago #

    Not sure where exact it should be placed, need to look for it

  7. dhobeika
    Member
    Posted 4 years ago #

    OK I updated the code to allow for all domains just in case, and I tried putting it in 3 different locations:

    1. the server root
    2. the public_html folder and
    3. the wp-content folder and it's still not working. Not sure what else to try. A friend suggested I use this code instead to allow all domains and nothing I am doing is working. Any other suggestions?

    <?xml version="1.0" ?>
    <cross-domain-policy>
      <site-control permitted-cross-domain-policies="master-only"/>
      <allow-access-from domain="*"/>
      <allow-http-request-headers-from domain="*" headers="*"/>
    </cross-domain-policy>
  8. Alex Rabe
    Member
    Posted 4 years ago #

    Ahh I see , you didn't use the flash sildeshow, you use the javascript based solution. Sorry for the misleading information. In this case it's a Access-Control-Allow-Origin issue.

    In the script console you will see : XMLHttpRequest cannot load http://www.servprolagrangepark.com/index.php?callback=json&api_key=true&format=json&method=gallery&id=1. Origin http://servpro9781.com is not allowed by Access-Control-Allow-Origin.

    I need to look how to fix this in the future, but it will take some time

  9. dhobeika
    Member
    Posted 4 years ago #

    If I change it to flash, will it work?

  10. Alex Rabe
    Member
    Posted 4 years ago #

    not sure.. test it

  11. dhobeika
    Member
    Posted 4 years ago #

    Thanks, I switched it to flash from javascript and it seems to be working now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.