WordPress.org

Support

Support » Plugins and Hacks » [Plugin: NextGEN Gallery] "Missing The Call To In Your Theme" After Switching To New Theme

[Plugin: NextGEN Gallery] "Missing The Call To In Your Theme" After Switching To New Theme

  • I recently purchased a new theme for my site and while in the process of testing it out before putting it live, I noticed that images display when individual posts are loaded, but not on the main index page or anything else that shows excerpts. Likewise, images in the sidebars are not loading either.

    I upgraded to the newest version of Nextgen (I hadn’t updated in a while) and after updating everything, I noticed the Plugin Check on the Nextgen options page. I ran the check and everything came back fine except for Check Theme Compatibility, which replied with the error in the title: “Missing the call to in your theme.”

    I assume adding this “call to” will fix the issue, but I’m fairly illiterate as to the workings of php. I’ve learned some small tweaks by trial and error, but I have no idea how to fix this or where to put said fix.

    Any help would be greatly appreciated. If you need any further information from me to help resolve this, please let me know.

Viewing 15 replies - 1 through 15 (of 15 total)
  • I’ve got the same problem and while I am pretty educated when it comes to WP, I don’t understand the instructions. I’d love to get an answer as well.

    Having the same issue. Was debugging a slider loaded by theme not running and I was wondering if NextGen was clashing/conflicting with it so used this test widget in the NextGen admin and had the same warning:

    Missing the call to in your theme

    Not sure yet what it means and how to resolve this.

    1. Add <?php wp_head(); ?> to your “header.php” right before </head>

    2. Add <?php wp_footer(); ?> to your “footer.php” right before </body>

    Files (header.php & footer.php) are located in: /wp-content/themes/YOUR_THEME

    Done.

    This solution works fine for me.

    Great side effect: Now you’ve this awesome administration bar at the top of your front end.

    Cheers,
    Cris

    I did this and it still didn’t work. The plugin says it isn’t supported and I know the edits in the header and footer are working.

    Does anyone else have any suggestions?

    Thanks.

    -Adam

    I have the same problem. Added the call in the header, was already there in the footer… still says it’s missing.

    Yep….I’m having the same problem with the Spectrum Theme and NextGEN. I checked, and both the head and footer functions were already being called in the theme…just before </head> and </body>, respectively. Sounds like something changed somewhere in NextGEN, wp_head, or wp_footer to me. I’m betting NextGEN.

    <?php wp_head(); ?>
    </head>
    <?php wp_footer(); ?>
    </body>

    FYI, I do see the NextGEN scripts and css in my <head>, but nothing appears to be working….

    Can’t edit my previous posts now for some reason, but wanted to update that NextGEN is working for me after all, despite the erroneous “Missing The Call To In Your Theme” message in the Health Check.

    I am getting the same error. Did any of got a solution to this?

    I’ve seeing the same thing when running the check – though nextgen seems to be working fine.

    marvalpert1

    @marvalpert1

    I have the most recent version of WordPress and Nextgen Gallery
    when i do the compatibility test i get an error…..
    does the following work?
    1. Add <?php wp_head(); ?> to your “header.php” right before </head>

    2. Add <?php wp_footer(); ?> to your “footer.php” right before </body>

    2. I can see my pictures but when it goes to slide show it just spins and doesnt load.. any suggestions?
    thanks
    marv

    I am having this same problem. <?php wp_head(); ?> is in my Genesis theme, but the slideshows are not working and just reload the same pic over and over (and over)…

    I have this problem, and where it affects the operation for me is when a user with a role permission to upload images to their own gallery tries to upload, they get a “http 500” error. This wasn’t happening before I updated to the newest NextGen.

    As with the other folks here, I checked, and wp_head(); is included in the <?php section, right before the </head> tag.

    I just went back to NGG 1.8.4 and now it’s working fine.

    I hope they fix the bug soon, I’d like to upgrade again! (How do we report bugs to NextGen, anyway?)

    I use Magazine Basic 2.7.7 for wordpress 3.3 and Nextgen Version 1.9.2.

    The nextgen menu, popup etc was working fine. I uploaded pictures and created albums and add to a post via this little icon, but only got [Gallery not found] on the frontend.
    The <?php wp_footer(); ?> was missing in my footer.php as well.
    After I’ve added it, PluginCheck says:

    Your theme should work fine with NextGEN Gallery

    And it does. Everything is working.

    I’m still having the same problem, even after another NGGallery update. It happens on the flash-based upload, regular works ok. When a logged in user with permission tries to upload an image into their gallery, they get a “http 500” error.

    I’m really surprised such a bad bug hasn’t been fixed yet. I hope it is soon.

    Anyone have a work-around?

    Love the plugin, though!

    I’m having the problem… I seem to be able to do everything, but the ‘Add Gallery/Images’ option under ‘Gallery’ is completely blank; I also get the error: Missing the call to wp_head() in your theme, contact the theme author. The code in front of the </head> is correct and I have tried about six different themes so far…

    So, I have tried both NextGen gallery 1.9.1 and 1.9.2, and I have even downloaded the 1.9.1 from another WordPress website that is currently working for me, and uploaded the plugin, and I’m experiencing the same problem. WEIRDO!

    Any help would be most appreciated.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘[Plugin: NextGEN Gallery] "Missing The Call To In Your Theme" After Switching To New Theme’ is closed to new replies.