NextGEN Gallery
[resolved] Images are not loding (22 posts)

  1. lunapark
    Posted 3 years ago #


    I just installed WordPress and NextGen Gallery everything went successful.
    And I can upload pictures just great, but the problem is just that they wont't appear ?
    Not even the thumpnails...!!??

    What am I doing wrong ?
    I just installed the NextGen Gallery plugin, do I need to install other plugins allso ?

    Its really weird, coz everything seems to work, but the pictures just won't load.... And when I take look at the FTP-server, the pictures are uploaded allright.

    Heeelp :-)


  2. damainman
    Posted 3 years ago #

    Load in the admin, or load on the front-end of you website? I have the problem where everything loads properly in my admin but no images from the galleries will display on my front-end except for the gallery thumbnail from the album.

  3. lunapark
    Posted 3 years ago #

    They wont load any places...

    I really thought that this would be an easy question,
    since the gallery is useless if this isnt resolved.

    Maybe I just made a typically mistake..

  4. l8ay
    Posted 3 years ago #

    Have the same problem once I upgraded to
    NextGEN gallery 1.9.3
    Wordpress 3.3.2

    able to add new galleries but CANNOT UPLOAD any images into any gallery.
    the image gets loaded "100%" but then NextGen Gallery does not recognize it's been added to the folder/gallery and returns a "0 picture(s) successfully added"

    I can see the images in the folder on my server but not in NextGen, have tried
    -"scanning for new images" button.
    -uploading the images in a different way (ftp / zip upload etc)
    - turning off all other plugins
    - a different theme
    - changing folder permissions

    but none of these seems to work - anyone managed to solve this yet?

  5. lunapark
    Posted 3 years ago #

    I reinstalled the gallery serveral times after I tried differnt gallery, and suddenly it worked.

  6. SITEWEB44
    Posted 3 years ago #

    same as l8ay

  7. DeanoDV8
    Posted 3 years ago #

    Please can you explain what you did to resolve this? Did you reinstall NextGen Gallery several times, or did you reinstall the images??


  8. lunapark
    Posted 3 years ago #

    I installed a different gallery, and then again NexGen..And suddenly it worked.
    I created another Admin account to do it with, but I dont know if that was the reason?!

  9. damainman
    Posted 3 years ago #

    Not really clean, but the following solved the issue for me:

    1. I created a "Page" Template to use specifically for the page I was going to display the gallery on.

    2. Then I hard coded the shortcode into the area I wanted it to appear on the page with:

    <?php if ( have_posts() ) : while ( have_posts() ) : the_post(); ?>
                	<?php the_content(); ?>
                      <?php if(isset($_GET['album']) && isset($_GET['gallery'])) { ?>
                      <?php echo do_shortcode('[nggallery id='.$_GET['gallery'].' ]'); ?>
                    <?php } ?>
                <?php endwhile; else: ?>
                	<p><?php _e('Sorry, no posts matched your criteria.'); ?></p>
    <?php endif; ?>

    Thanks to the fact that the gallery actually puts in the variables into the URL, "$_GET['gallery']" allowed me to grab the gallery from the URL to display it.

    I'm not a pro, but since this worked for me... figured it might work for someone else. You will need to know how to make a page template though and assign it to the page via wpadmin.

  10. colinpask
    Posted 3 years ago #

    I have a similar problem. Nextgen worked perfectly with WordPress 3.1, Suffusion 4.0.0, and NextGEN Gallery 1.9.2.

    I then developed another website with WordPress 3.3.2, Suffusion 4.1.5.b4 and nextGEN Gallery 1.9.3. NextGEN will not work.

    Initially I was unable to find any images using NextGEN Gallery, however after deleting and installing NextGEN again, I found that when I run 'PlugIn Check' for NextGEN Gallery, it fails Check Plugin/Theme Conflict. I Deactivated all plugins (except Suffusion which is not a plugin) and check still failed.

    As I have 27 pages on the website, each requiring a different slideshow, I don't really want to have to enter code on every page (though suggestion appreciated damainman thanks)

    Anyone else with solution? It would be much appreciated - Thanks

  11. damainman
    Posted 3 years ago #

    np, if you find a solution please share as I don't want to put code on each page either lol.

  12. colinpask
    Posted 3 years ago #

    SOLVED - solved my own problem - finally.

    As I had the site working as a test site under a subdomain, I decided that I should compare the test site settings (which worked) with the new site (which failed Nextgen Plugin Test).

    I quickly found that in WORDPRESS > SETTINGS > GENERAL > SITE ADDRESS URL - the folder name where I have wordpress installed was missing. I inserted the folder name, clicked SAVE CHANGES and then did the a check of NEXTGEN in WORDPRESS > GALLERY > OVERVIEW > PLUGIN CHECK. Volia!!! Ticks all around so Problem fixed.

    I hope this might help others having the same problem.

  13. DeanoDV8
    Posted 3 years ago #

    After hours of tinkering with it and trying to figure out what was going on, I managed to do it (he says with fingers still crossed).

    I checked through the image sizes and made sure that the Gallery images and upload sizes were all within sensible size limitations to fit the page. I also checked the NEXT GEN Scroll Gallery image sizes measurements.

    By adjusting the image sizes, (as it seemed they might be a little overlapping slightly with sidebar widgets) I thought it might be a little overlap causing a clash with sidebar items/code, it seemed to resolve it a bit more, but not quite - I had managed to get Chrome and IE working with it, but Firefox kept crashing out time after time with a script error for NEXTGEN SCROLL GALLERY or by "not responding"

    I then got a friend to view the website and he said that AddThis looked to be causing a problem his end. I turned off scroll gallery and the page loaded fine with no errors, but obviously no gallery.

    I decided to uninstall NEXTGEN Scroll Gallery and reinstalled it and it now works. Rather odd, but it musthave been something in the upgrade or in the settings. Either way, it works now - touch wood!!

    Good luck! Hope this helps.

  14. bishop
    Posted 3 years ago #

    @lunapark: I had a similar problem with only several pictures that were uploaded but did not show up. It seems nextgen has issues with withespaces in image file names. I used a tool to multi-rename the filenames via ftp. I deleted the images in nextgen and scanned the folder for new images and voilĂ  :P

  15. DeanoDV8
    Posted 3 years ago #

    I am having issues with this still. It's driving me nuts.


  16. I had the same problem although I didn't have Facebook connect I did have add link to Facebook. I deactivated that and it gave me back my albums.

    This conflict definitely has something to do with different FB related plugins. Try deactivating anything related to FB.

  17. bjorn.kullberg
    Posted 3 years ago #

    Hi, same issue for me. Thumbnails showing but took me to blank page. I deactivated my Facebook plugIn and voilá it works again.

  18. FemmeFM
    Posted 3 years ago #

    Same issues, pic description & title are there, but won't load image.

    Somewhere an extra slash is added between 'wordpress' and 'wp-content' (where the gallery folder lives). I've checked settings I know of to make sure it's not me. Cannot find where that extra slash is coming from.

    This was after update of both WP and and suffusion theme (which completely broke the site).

    Site is working again, sans image galleries.

  19. Warmax
    Posted 2 years ago #

    Good afternoon all,

    i would like to state that i just updated my wp-sites running
    the latest wordpress
    on Operating System : Linux (32 Bit)
    Server : Apache/2.2.14 (Ubuntu)
    Memory usage : 36.03 MByte
    MYSQL Version : 5.1.66-0ubuntu0.10.04.1
    SQL Mode : Not set
    PHP Version : 5.3.2-1ubuntu4.18
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 64
    PHP Max Upload Size : 30M
    PHP Max Post Size : 8M
    PCRE Backtracking Limit : 500000
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes
    Graphic Library

    GD Version : 2.0
    FreeType Support : Yes
    FreeType Linkage : with freetype
    T1Lib Support : Yes
    GIF Read Support : Yes
    GIF Create Support : Yes
    JPEG Support : Yes
    PNG Support : Yes
    WBMP Support : Yes
    XPM Support : No
    XBM Support : No
    JIS-mapped Japanese Font Support : No

    and for some odd reason when i updated the plugin today from wp itself any new gallery images uploaded are not seen by the plugin but by ftp are available, may i ask what shall i do?

    i ran the compatability test and it passed, i re-scanned for new images and said 0, i uploaded via flash and it said 0 files where added, i also uploaded via ftp/import and still nothing in the plugin, but physicly thier there...

    my last back up is of yesterday, and i added new articles on several wordpress's on the same server and can't use the full back up..

    i would be greatfull if anyone could help.

  20. Warmax
    Posted 2 years ago #

    Okay guys after researching the issue, i came across and article to chown the directory (public_html)to root:root, but another friend of mine running wp and a linode suggest i do www-data:www-data instead, in iether way both worked for me.

    hope it helps anyone else

  21. MediaRoom
    Posted 2 years ago #

    I cannot down load or edit any photo galleries. When I click on "select or enter gallery" NextGEN doesn't recognize that we have any galleries and we have many. We recently upgraded WordPress from 3.0 to 3.5. Any suggestions? We have 25 hours to resolve this problem as our online campus newspaper is entering a contest, which closes in 25 hours. I hope someone can help.

  22. FemmeFM
    Posted 2 years ago #

    For some odd reason when I changed permissions on some of the pic folders via FTP, I was able to get pics to load and view.
    But as usual, that solution doesn't work every time. But it's worth trying.

    @Warmax, have u upgraded to the newest Ubuntu yet? Is it worth it? or should I wait until the next update? Busy busy life on this end with 2 kids and multiple 'jobs'.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic