Support » Plugins » [Plugin: NextGEN Gallery] Imagemagick setup for nextgen gallery

  • Hello,

    I realize that support for imagemagick is still experimental but I seem to be having an elementary problem that can probably be fixed easily. Plus, this is an excellent alternative to installing the missing gd library from OS X 10.5 server’s php package.

    After using macports to install imagemagick and confirming that it was working, I could not get nextgen to find imagemagick (keep getting the path error). I feel like I have tried every path imaginable. Macports installs imagemagick in opt/local/bin. But this path does not work so I am not sure what exactly nextgen is looking for when it says “…Path to library:” in Options. I tried opt/local/lib and variations on opt/local/include/ImageMagick/magick/ and several other paths.

    Hopefully I am making a simple mistake. Thanks ahead of time for suggestions!


    P.S. here is the website. I am sure I can get my bosses to make a nice donation if I can actually get the gallery to work 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • I’m no expert with imagemagick or nextgen gallery but I use both w/o problems…

    When you try to find imagemagick path… you’re saying “opt/…” that is missing something at the beginning… “opt/bin/etcetera” is not the same as “/opt/bin/etcetera” so you might just have to put its full path and not relative.

    if you’re not sure how to find the path for imagemagick, try this…

    on your terminal to the system with imagemagick installed, type:
    which convert
    this should tell you where “convert” is, this is part of imagemagick.
    the full path starts with a “/” try the same path you get from that command (minus the “convert” part of course) and see if that helps?

    My guess is that your path should look like this:

    and not

    make sense?

    Thanks rakxzo,

    That did indeed make a difference. The correct path appears to be /opt/local/bin/. Nextgen still tells me that there is no graphics support but when I try to create thumbs it gives no errors. The only problem is that the thumbs are just blank, simply white boxes. I confirmed that new jpg’s were created in the ‘gallery’ folder on the server and that they were blank.

    Any idea what is causing this issue? I am using the latest version of imagemagick and as I say above, I tested it and the logo.gif appears and looks fine. I do get the following errors:

    Xlib:  extension "Generic Event Extension" missing on display "/tmp/launch-xkhy8x/:0".
    Xlib:  extension "Generic Event Extension" missing on display "/tmp/launch-xkhy8x/:0".

    But only when I use the display command. Any further ideas? And why does Nextgen not recognize imagemagick as graphic support (is this normal)?

    Warm regards.

    The problem here was with my browser: Safari 4 beta. When I went back to Firefox everything worked quite well.

    Thanks again for the help.

    Sorry jonna that I didn’t get back to you earlier about your follow up question. I’m not sure how the notifications on these forums work and I totally missed it until now.

    I’m glad you got it working though. and thanks for posting what the problem was.


Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Plugin: NextGEN Gallery] Imagemagick setup for nextgen gallery’ is closed to new replies.