[Plugin: NextGEN Gallery] image uploads get stuck at "Create New Thumnails" (35 posts)

  1. Anonymous
    Posted 7 years ago #


    I uploaded images both via the ftp upload and the individual image upload and both ways, it finds the image(s) but gets stuck on the "Create New Thumbnails" screen. I get a bar at 0% and the message "Running... Please wait" it doesn't matter if I'm in IE or FF.

    Please advise, I feel like I'm missing some additional program that Next Gen gallery relies on? The /gallery/ folder has full write access and here are my settings:

    Server Settings

    * Operating System : Linux
    * Server : Apache/1.3.34 Ben-SSL/1.55
    * Memory usage : 9.57 MByte
    * MYSQL Version : 5.0.51a-log
    * SQL Mode : Not set
    * PHP Version : 4.4.8
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 40M
    * PHP Max Upload Size : 20M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 50000s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    GD support

    * GD Version : bundled (2.0.28 compatible)
    * FreeType Support : Yes
    * FreeType Linkage : with freetype
    * T1Lib Support : No
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XBM Support : Yes
    * JIS-mapped Japanese Font Support : No


  2. Alex Rabe
    Posted 7 years ago #

    Are you at 1&1 ?

  3. 50805101
    Posted 7 years ago #

    Try changing to deault theme, it worked for me..

  4. snowowl78
    Posted 7 years ago #

    I got a similar problem.

    I was uploading my pictures via ftp, after creating the album & the galleries. Then I wanted NGG to search the folders for new pictures. The process starts and the progress-bar fills up till a value between 35% & 39 %. While the progress-bar works the FF load-bar is shown, until the moment the process is breaking down (FF shows Finished in the status-bar).

    My Host is Strato and the system is the following:

    Server- Einstellungen

    * Betriebssystem (OS): SunOS
    * Server : Apache/1.3.37 (Unix)
    * Speicherverbrauch (Memory Usage): 12.94 MByte
    * MySQL Version : 5.0.51
    * SQL Modus : Nicht gesetzt (Not set)
    * PHP Version : 5.2.5
    * PHP Safe Mode : Aus (Off)
    * PHP Allow URL fopen : An (On)
    * PHP Memory Limit : 64M
    * PHP Max Upload Size : 10M
    * PHP Max Post Size : 10M
    * PHP Max Script Execute Time : N/As
    * PHP Exif Modul : Ja (Yes) ( V1.4 )
    * PHP IPTC Modul : Ja (Yes)
    * PHP XML Modul : Ja (Yes)

    GD Unterst├╝tzung (Support)

    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Ja (Yes)
    * FreeType Linkage : with freetype
    * T1Lib Support : Nein (No)
    * GIF Read Support : Ja (Yes)
    * GIF Create Support : Ja (Yes)
    * JPG Support : Ja (Yes)
    * PNG Support : Ja (Yes)
    * WBMP Support : Ja (Yes)
    * XPM Support : Nein (No)
    * XBM Support : Ja (Yes)
    * JIS-mapped Japanese Font Support : Nein (No)

    I also tried the suggestion from above, to change the theme, but this didn't worked, too.

    I don't know what to do know and need some help please.


  5. Alex Rabe
    Posted 7 years ago #

    Reduce the image resolution for a test

  6. snowowl78
    Posted 7 years ago #

    Hello again, ;-)

    I forgot to mention I'm using NGG 0.98.

    But I did reduce the resolution of the Images:

    1.) from 800x600 to 400x300 with resample 2 and quality 85% for the pictures and 80x60 with resample 2 and quality 75% for thumbs, it didn't work

    2.) from 400x300 to 320x240 with resample 2 and quality 85% for the pictures, with same values for thumbs from above, and this didn't work, too,

    One time it breaks down at 17 picures (35%), the other time at 18 pictures an (37%), it's always different...


  7. crjahn
    Posted 7 years ago #

    I have the very same problem and my provider is 1&1

    Alex, did you ask this for any particular reason (probably yes :-) )

  8. Alex Rabe
    Posted 7 years ago #

  9. Alex Rabe
    Posted 7 years ago #


    Did you have reduced the resolution, before (!) you uploaded them ? If you hit the memory limit, the it doesn't help to reduce the resolution with NextGen

  10. snowowl78
    Posted 7 years ago #

    No I didn't because They were uploaded via ftp, to get no conflict with the servers max. upload size.

    I have 2 folders containing pictures: one with pictures of 800x600 and one with pictures of 2816x2112.

    I once had a ngg with the bigger pictures in it working.

  11. maierma
    Posted 7 years ago #

    @@ snowowl78
    @@ crjahn

    I've had exactly the same problem (and, apparently, I'm using 1&1!).

    The follwoing worked for me:
    - deactivate *ALL* Plugins
    - activate NextGen again
    - create new thumbnails (should work OK with only NextGen activcated!)
    - step by step activate the plugins you really need

    Can't remember the plugin that caused the problem but some bugger was responsible ...

    Good luck!

  12. Soundofsirens
    Posted 7 years ago #

    OK. Got the same issue and the website is running on 1&1 as well.
    I started this thread (cause i did not found this one) http://wordpress.org/support/topic/197996?replies=1
    you'll find a detailled description over there.
    But let's stay here! :)

    So, are there any news? De-activating all Plugins didn't solved it. (btw. got only all in one seo installed)

  13. Alex Rabe
    Posted 7 years ago #

    Switching the hosting or the PHP version (from PHP 4 -> 5) should be help :-) otherwise I can't give any help until ImageMagick it ready to use (still in progress)

  14. Soundofsirens
    Posted 7 years ago #

    OK. Now it runs php 5.2.6 - which doesn't help :(
    Switching the hoster will be hardly to explain to that friend of mine i help with her website :(

    But thanks for your quick answer. :) When do you expect ImageMagick working?

  15. Alex Rabe
    Posted 7 years ago #

    No time schedule... when it's finished.

  16. maierma
    Posted 7 years ago #

    However, the safest (and most reliable) route for me has always been to upload the pictures via ftp to the desired folder and creating then the thumbnails. NextGen then seems to recognize the files as it is supposed to and even manages to creat thumbnails correctly. ;-)

    For some obscure reasons, the zip-upload does not always work.

    Sometimes, odd plugins, even when deactivated, can cause problems. I'd delete them completely to make sure that no part is causing issues here.

    It is also always worth switching to the default theme and check if problems continue. I have recently had trouble with some behaviour of a theme that overrides certain styles etc. (IE only that was).

  17. Soundofsirens
    Posted 7 years ago #

    how do you create manually thumbnails?

    edit: ok, do you mean "scanning folder for new pictures" under gallery settings?

    (if so, only the loading bar appears, but nothing happens...)


  18. maierma
    Posted 7 years ago #

    Once the pictures are in the gallery-folder, I use the "create thumbnails" function from NextGen. It recognizes the uploaded files and produces thumbnails, as expected.

    Mind you, the steps I described (deactivating plugins etc.).

    I've once also created the "thumbs"-folder (via ftp), too. but that didn't seem to be necessary.

  19. Soundofsirens
    Posted 7 years ago #

    sorry, but can't find the funciotn "create thumbnails"

  20. maierma
    Posted 7 years ago #

    OK, I see what you mean.

    Here is the path:
    - First, of course, you must create a new "gallery" ("add gallery").
    - Upload the pictures into the directory via ftp
    - Go to "Manage galleries" from the menu
    - Choose your new gallery
    - You won't see any pictures yet because NGG doesn't know yet about the new pictures but we come to that
    - Choose "Scan folder for new images"
    - Hopefully, your pictures will be detected now
    - Choose from the drop-down menu on the left (above your pictures) "Create new thumbnails" (default here is "No action").

    Hope this helps!

  21. Soundofsirens
    Posted 7 years ago #

    nope, but thanks for your detailed information! :)
    think we'll change the hoster...

  22. maierma
    Posted 7 years ago #

    The oster data look OK though - any luck with the default wp-theme?

  23. Soundofsirens
    Posted 7 years ago #

    no, i built up my theme onto kubrick - or do you mean the "classic" theme?

  24. maierma
    Posted 7 years ago #

    Yes, I meant Kubrick. Still I believe the problem does not lie with the hoster. What else is there to ttry out?
    Resetting? Deinstall & reinstall? ...?

  25. Soundofsirens
    Posted 7 years ago #

    OK. Did lots of testing this morning...

    Here we go!

    - De-Activatind / Resetting / De-installing - nope.
    - Test-installation on another host (the one, that has allready an working wp with ngg installed) - nope
    - Downgrading both WP to 2.5.1 and NGG to 0.96 (like the working version) on both hosts - nope.
    - Resizing the Pictures to 800px - works.

    Think i got to live with it now, since i'm tired of testing (other ideas are still appreciated though)... damn, would have been great, to sport some large pictures!

    Let's hope that the ImageMagick support will come soon!

  26. Soundofsirens
    Posted 7 years ago #

    Damn. No good news!
    Thought smaller pictures and single upload will work now, but it still fails for some reason with some particular files.
    please note, that all files are about the same size (max. 800px) and created with the same "safe for web" photoshop routine.

    what the heck is wrong? :(

    Here you'll find the pictures: http://www.soundofsirens.net/_tmp/ngg_test.zip
    All of them work, except of "steg.jpg"

    Any suggestions?

  27. Soundofsirens
    Posted 7 years ago #

    OK. Tried a different Gallery Plugin (PhotoXhibit) and got the same thumbnail-creation issues. It returns a error500.
    However, it lies with the server... dunno... will check it locally with xampp and on a 3rd online-hoster...

  28. Soundofsirens
    Posted 7 years ago #

    FYI: It was actually the host, that caused the problems.
    Those two didn't work: hosteurope (webpack m) and 1&1 (homepage perfect)
    But this one did it: all inkl (privat plus)
    Even with ultra xxl 2500px images! Yeah!
    They offer free testing-accounts, so you can check it out before you order. nice! :)

  29. maierma
    Posted 7 years ago #

    Odd - my 1&1 site works nicely with NextGen.

    Good luck with all inkl - I'll be switching sooner or later anyway but the 1&1 offer I use just now is almost unbeatable (50% off for a 2-year period).

  30. crjahn
    Posted 7 years ago #

    My impression, so far, was that whether the creation of thumbnails works or not, depends completely on how much memory is available. When I run it on the original pictures that is around 10 MB which in my case is not available. Disabling other plugins frees up memory and I think it much more likely that this makes it work for some, as opposed to incompatibilities with other (then deactivated) plugins.

    However, the amount of required memory depends on the size of the pictures. So when I resize them to 1024x768 (using Irfanview) before upload (and FTP is the fastest approach here for me), it seems to work ok.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.