Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » [Plugin: NextGEN Gallery] HTTP error with flash-based image uploads

  • Resolved jmek


    NextGEN displays an “HTTP Error” message (no other details) when using the Flash-based uploader with NextGEN 1.9.1 and WP 3.3. The problem occurs whether using drag-and-drop or the “Select Files” button. Images can still be uploaded if I “Disable flash upload,” but there goes the cool new drag-and-drop.

    When the site was running NextGEN 1.8.4 and WP 3.2.1, the Flash uploader worked fine. It’s only broken since the upgrade.

    And an odd thing: the HTTP error occurs only after the image has been 65% uploaded. (I am testing with images less than 20k, so it’s not a size issue.)

    The error occurs even if all other plugins are disabled.

Viewing 15 replies - 1 through 15 (of 49 total)
  • you will have to wait until the developer develop a new version to be compatible with WP3.3

    NextGEN 1.9.1 is the version that was developed to be compatible with WP 3.3. Guess it isn’t fully compatible yet. I was hoping there was a workaround or that enough people would be having this problem to prompt a fix,

    Which browser do you use ?

    The problem occurs in Firefox, Chrome, and Safari on PCs running Windows 7 or Windows XP. Same problem in Internet Explorer but with an error message of “I/O Error” instead of “HTTP Error”.

    Do you have the same issues when you upload a image with the core media uploader ( they updated to the same new loader )

    Alex, I am having the same exact issues. Same exact set of tests. The upload shows that it has finished and in the dialog box just below the upload percent bar it shows HTTP 500 error.

    I too have tested it on several machines and several configurations. The core uploader works fine. I wondered if it could be something to do with another plugin conflict. I run nextgen on 5 other sites and they are all upgraded to 3.3 and 1.9.1 and they have no issues with the flash uploader.

    Hope this helps.

    Alex, the core media uploader (WordPress > Media > Multi-file upload) works just fine.

    ADWheeler, we do have some slight differences in our problems. My error just shows “HTTP Error,” it doesn’t have a number (500 in your case). And my upload does not show that it has finished; it says “0 files uploaded” and indicates a failure.

    Actually AFTER my upload finishes that is what it says at the top. My flash window that shows the progress, briefly shows that error just before going to thumbnail generation…

    I’m checking this here again… Have currently no clue

    @jmek Other questions :

    Do use a SSL (https) backend ?
    Wordpress in a root or subfolder ?


    I am not using an SSL backend
    WordPress is in a subfolder

    Thank you for taking so much time on this!

    when i’m clicking on ‘Select files’ (add images to a gallery), nothing happens.

    everything worked fine WP3.2.1 (multisite) and Nextgen 1.9

    after upgrading to WP 3.3, the flash uploader in next doesnt work anymore.

    Javascript etc. activated; Flash 11.1.

    * Operating System : Linux (64 Bit)
    * Server : Apache
    * Memory usage : 32.01 MByte
    * MYSQL Version : 5.1.43-nmm4-log
    * SQL Mode : Not set
    * PHP Version : 5.2.12-nmm2
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 64
    * PHP Max Upload Size : 200M
    * PHP Max Post Size : 200M
    * PCRE Backtracking Limit : 500000
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : Yes ( V1.4 )
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    Graphic Library

    * GD Version : bundled (2.0.34 compatible)
    * FreeType Support : Yes
    * FreeType Linkage : with freetype
    * T1Lib Support : Yes
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XPM Support : Yes
    * XBM Support : Yes
    * JIS-mapped Japanese Font Support : No

    @ ALEX

    thank you very much for your work !!!!



    @alex et al:

    Did anyone find a solution to this problem?




    Same issues..
    any solution yet?

    I had the same problem. I have solved it by change the permission of the file nextgen-gallery/admin/upload.php from 644 to 755. Now the flash uploader is working correctly for me.

Viewing 15 replies - 1 through 15 (of 49 total)
  • The topic ‘[Plugin: NextGEN Gallery] HTTP error with flash-based image uploads’ is closed to new replies.