WordPress.org

Forums

[resolved] [Plugin: NextGEN Gallery] Homepage loads slow with NextGen plugin (6 posts)

  1. sam_m
    Member
    Posted 6 years ago #

    Hi,

    Since upgrading to 2.7WP and 1.0.2 NextGen Gallery, I notice my homepages takes up to 5-8 seconds extra to load. On the homepage I use the slideshow widget.

    If I switch off the NextGen plugin it is very fast loading - as expected. I did not have this problem before with the NextGen Gallery plugin in previous releases.

    Something has definitely changed which is adding load time onto my pages in WP. Not a good visiting experience for my site users are waiting this long for the homepage to load.

    Can you tell me if previous versions of NextGen will work with 2.7 WP? If so, I might have to revert back to those until this speed problem is fixed. Please help me fix what the problem is

    Many thx.

    Here are server settings:
    * Operating System : FreeBSD
    * Server : Apache/1.3.34 (Unix) mod_ssl/2.8.25 OpenSSL/0.9.7e PHP/4.4.2 FrontPage/5.0.2.2510
    * Memory usage : 17.11 MByte
    * MYSQL Version : 4.1.14-standard
    * SQL Mode : Not set
    * PHP Version : 4.4.2
    * PHP Safe Mode : Off
    * PHP Allow URL fopen : On
    * PHP Memory Limit : 64M
    * PHP Max Upload Size : 2M
    * PHP Max Post Size : 8M
    * PHP Max Script Execute Time : 30s
    * PHP Exif support : No
    * PHP IPTC support : Yes
    * PHP XML support : Yes

    * GD Version : bundled (2.0.28 compatible)
    * FreeType Support : No
    * T1Lib Support : No
    * GIF Read Support : Yes
    * GIF Create Support : Yes
    * JPG Support : Yes
    * PNG Support : Yes
    * WBMP Support : Yes
    * XBM Support : Yes
    * JIS-mapped Japanese Font Support : No

  2. johnnysy
    Member
    Posted 6 years ago #

    I have had some of the same issues with other flash based or media items on my front page until I did a couple of things to correct that.

    I moved from PHP 4 to PHP 5, installed wp-super cache, wp-widget cache if I remember correctly the plugin was called that.

    I didn't get to the point of looking for some of those added plugins for page loads until I used wp-tuner pluggin that gave me a chance to look at exactly the load times and the exact items that was slowing down the load time.

    I happen to support software that is used in hospitals and I always know when new versions come out there is the adjustment phase and unless I keep my stack of tweaks close by there will be slow downs for a little while.

    I hope what I suggests helps.

  3. sam_m
    Member
    Posted 6 years ago #

    @ johnnysy

    Thx for your suggestions. Unfortunately, the upgrade to PHP5 lies with the host company. Who will not move over at this stage.

    I will look into the cache plugins you mention. However, I think the problem could also be related to the revision of the code of NEXTGen by Alex. Hence, why I'd like to know if there are changes that would cause this slow down, which I did not have in previous versions.

  4. Alex Rabe
    Member
    Posted 6 years ago #

    That's strange because I optimized the Database queries... Could you post a link to your page?

  5. sam_m
    Member
    Posted 6 years ago #

    Hi Alex,

    After some more investigation, I found the problem. It is the 'imageflow' plugin that is used with NextGEN.

    I have disabled that plugin and await to hear from the author regarding the problem.

    This issue can now be closed at it is not NextGEN causing the load problem.

  6. Alex Rabe
    Member
    Posted 6 years ago #

    Ok, let me know when I can help

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags