WordPress.org

Forums

NextGEN Gallery
[resolved] Gallery thumbnails are not aligning? (5 posts)

  1. hollywooood
    Member
    Posted 2 years ago #

    Hi all,

    This is really a great plugin. I especially like the thumbnail cropper so a big thanks to the programmer on that one.

    Really hoping for a quick solution for this one. For some reason my thumbnails are not displaying correctly. The first row has a nice 4 columns but the next row displays only 1 thumb and then displays 4 for the next row. I checked the css and don't see a problem but not sure here.

    Have a look here

    I uninstalled and installed again but this didn't solve my problem. I would greatly appreciate a solution here and thank anyone in advance for some insight.

    http://wordpress.org/extend/plugins/nextgen-gallery/

  2. arothman
    Member
    Posted 2 years ago #

    I had this same problem. I discovered that the empty spots always were after an image I'd fixed the thumbnail for. Turns out that the thumbnails I edited were one pixel shorter than the defaults, thereby screwing up the floats. The auto-thumbs were 100x75, but the edited ones were 100x74. Just make sure the thumbs are all the same size and your rows should line up again.

  3. hollywooood
    Member
    Posted 2 years ago #

    super helpful with this...big thanks for posting!

  4. WayneM1
    Member
    Posted 2 years ago #

    Just chiming in here to say that this thread has helped me to fix the same problem of thumbnail alignment.

    Turns out some of my thumbnails were 150x149 when they should have been 150x150. All of these wrong sized thumbs were ones that I had edited using the thumbnail edit feature in the gallery management area.

    It can be really tricky to get an edited thumbnail to be the absolute correct size sometimes. This may be a bug in the thumb editor (or not) but, it would be very helpful it there was some way to either verify the thumbsize in the editor, or a routine in the editor that force corrects the edited thumbnail size to the constraints of the dimensions selected in the gallery options.

    This weird alignment issue has been "bugging" me for months now. Other solutions offered included setting a number in the column field in the gallery options. This is a kludge work around that does help - but leads to issues with gallery thumbnail displays on small screen devices like iPhones and tablets, etc.

    It would be really great to be able to bring this to the attention of the new developers as a "bug", or something that needs refinement - but I can't find a way to report it right now...

    Again, thanks for this very helpful thread :-)

  5. sidea
    Member
    Posted 2 years ago #

    Grrrr! The thumbnail cropper is a great feature, but the gaps in my gallery were doing my nut.

    As per Wayne, I ended-up forcing the gallery into columns via this page "domain/wp-admin/admin.php?page=nggallery-options#gallery"

    It worked...

    Thanks Wayne

    But if anyone finds a cleaner solution that won't screw-up mobile device rendering, that would be awesome.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • NextGEN Gallery
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic