Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » [Plugin: NextGEN Gallery] Error message – Passed variable is not an array or object

  • Hi, the below error messages appeared after upgrading my wordpress. Please help.

    Warning: reset() [function.reset]: Passed variable is not an array or object in /home/jrockxco/public_html/wp-content/plugins/nextgen-gallery/nggfunctions.php on line 689

    Warning: current() [function.current]: Passed variable is not an array or object in /home/jrockxco/public_html/wp-content/plugins/nextgen-gallery/nggfunctions.php on line 690

    Warning: array_search() [function.array-search]: Wrong datatype for second argument in /home/jrockxco/public_html/wp-content/plugins/nextgen-gallery/nggfunctions.php on line 694

    Warning: reset() [function.reset]: Passed variable is not an array or object in /home/jrockxco/public_html/wp-content/plugins/nextgen-gallery/nggfunctions.php on line 696

    Warning: key() [function.key]: Passed variable is not an array or object in /home/jrockxco/public_html/wp-content/plugins/nextgen-gallery/nggfunctions.php on line 697

    Warning: end() [function.end]: Passed variable is not an array or object in /home/jrockxco/public_html/wp-content/plugins/nextgen-gallery/nggfunctions.php on line 699

    http://wordpress.org/extend/plugins/nextgen-gallery/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Should I delete the new version and try downloading the old version again?

    ok I have removed and delete the plugin and then re-installed version 1.7.4 which is working fine again…

    all newer versions will encounter the above error.

    Sad to say, I didn’t know removing the plugin actually delete all my galleries and files and images… now I have to start all over again…

    Strange, no idea where to look. You use the latest WordPress version ?

    What kind of short code do you use on this page ?

    Yes, I used the latest wordpress version. The problem appear after I updraded all my plugins together with wordpress. I didn’t know what is the problem initially so I try to delete your plugin and try the older version one by one.

    All your new versions haave the same error Msg except 1.7.4 where there is no more error however all my galleries and albums were deleted and gone.Now I am worried about doing any upgrade to your plugin.

    What do you mean by what kind of shortcode I used?

    Think the database tables could not be found on whatever reason, check the database tables and maybe use a backup

    Don’t worry about the lost galleire, I can just recreate them.

    The main problem now is that your newest version have all the error messages as shown abbove. Does it mean I should never upgrade your plugin again?

    No, as said something went wrong, if you see in the overview page 0 image , the tables are not there or the access to database doesn’t work

    Did anyone solved this problem? I have it too.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Plugin: NextGEN Gallery] Error message – Passed variable is not an array or object’ is closed to new replies.