[Plugin: Nextgen Gallery] Error: Cannot redeclare class nggimage in image.php (8 posts)

  1. chaoticx
    Posted 7 years ago #

    I'm trying to install the latest version of NextGen Gallery 1.0.2 and am getting this fatal error
    Fatal error: Cannot redeclare class nggimage in /home/content/v/a/l/vala1/html/portfolio/wp-content/plugins/nextgen-gallery/lib/image.php on line 9

    I'm just updated to WP 2.7, not sure if that's causing the issue or not.

    Is there something I need to add to the php file to redeclare class nggimage?


  2. Eventa
    Posted 7 years ago #

    I have the same problem:
    Fatal error: Cannot redeclare class nggimage in //boswinfs02\home\users\web\b2480\ez.eventahu\szofoso.hu\wp-content\plugins\nextgen-gallery\lib\image.php on line 9

    I run WP 2.7 on Windows platform with iNove theme.

  3. nbperkins
    Posted 7 years ago #

    Could someone please address this issue. I am having the same problem. I too am on a Windows platform, but all permissions are set at 777.

  4. zowieguy
    Posted 7 years ago #

    I Still have not found a solution to this issue.
    I can create a gallery, start to upload images, the i get:

    Fatal error: Cannot redeclare class nggimage in //frigga\home\users\web\b556\as.concretestreet\wp-content\plugins\nextgen-gallery\lib\image.php on line 9

    and the gallery is created, with only one image (w/ thumbnail). then if i try to scan folder for images.. I get same error.. then i go back to manage gallery and there is now 2 images. So apparently it is only bringing in 1 image at a time. Since i have hundreds of images to import this would be a very time consuming affair.

    If anyone knows how to fix this issue it would be greatly appriciated.

    Operating System : WINNT
    Server : Microsoft-IIS/6.0
    Memory usage : N/A
    MYSQL Version : 5.0.45-log
    SQL Mode : Not set
    PHP Version : 4.4.8
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : N/A
    PHP Max Upload Size : 10M
    PHP Max Post Size : 8M
    PHP Max Script Execute Time : 120s
    PHP Exif support : No
    PHP IPTC support : Yes
    PHP XML support : Yes


  5. zowieguy
    Posted 7 years ago #

    was up all night trying to fix issue.. still no luck.

    Is there ANYBODY out there who has a clue on this?


  6. zumo13
    Posted 7 years ago #

    I just installed this plugin and I am experiencing the same issue, but it doesn't even generate the thumbnail.

    I can select the images one at a time and use the "create new thumbnails" feature. But, this process is tedious.

    If anyone has found an answer please post it.


  7. zumo13
    Posted 7 years ago #

    OK. So, I've fixed the problem for myself. I'm not a PHP programmer at all. But, after some googling, I decided to encapsualte all of the calls to load "/lib/image.php" with an if statement...

    if (!class_exists("nggimage"))

    This fixed the first error, but revealed another, so I did the same for "/lib/meta.php"...

    if (!class_exists("nggmeta"))

    I'm sorry, but it would take me too long to explain which files, and which directories to put them in, etc. that it requires to make it work. So, I just posted the files and directories that need to be replaced. You can download them here if you want...


    I know it's cludgey. And, I don't guarantee any of the work (like I said, I don't actually know PHP) but it's working for me. I hope this helps someone.


  8. zumo13
    Posted 7 years ago #

    OK. I have to say... "Use at your own risk."

    I'm getting all kinds of errors on the "Manage Plugins" page. That being said, the plugin is still working for me.

    WordPress 2.7.1
    NextGen 1.2.0

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.