Support » Plugin: NextGEN Gallery - WordPress Gallery Plugin » [Plugin: NextGEN Gallery] Edit Thumb problem — conflict confirmed

  • I was having a problem with the “edit thumb” function of NextGEN and found many posts in these forums of people experiencing the same problem (the full size image on the left was not loading, and the cropping tool did not present itself). None of the potential solutions I saw in any of the threads had any positive effect on my situation.

    In my case, after disabling all my other plugins, the problem was resolved, so I went back to the technique employed by that classic MacOS app ‘Conflict Catcher’ and systematically re-activated groups of plug ins until I narrowed it down to one culprit: WP Minify. I then tried adjusting the setting of that plugin to see what particular setting was causing the problem and it turns out that the mere presence of the plugin, even with all of its options disabled, was killing the edit thumb capability of NextGen.

    I am going to try other plugins that provide the same the ‘on-the-fly’ compression of CSS as WP Minify to see if any will work alongside NextGEN. If I get any more information on this, I will follow up this post.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Thanks for the feedback, good to know

    Hello,
    I have the same problem.
    I tried to deactivate all plugins, checked my flunctions.php encoding, but problem is still here.
    The funny thing that my working copy on svn is working perfectly, while it’s identical to production.

    I’m using Nextgen Version 1.7.3
    Wordpress 3.0.5 (Multisite)
    Themes:
    Fastway 2
    Blue Zinfandel 3-Column

    Thanx for help
    Dogen

    Interesting. It never worked for me with my old theme, but when I upgraded to a new theme it suddenly worked perfectly.

    When I looked closely to the issue, using FireBug, it seems that nextgen can’t find thumb to load to the left side – nggshow.php returns empty (or nonexisting) image.
    Now I’m suspecting it can happen because in my Multisite installation,
    siteURL isn’t equal to site domain.

    Another interesting thing. when I try open image by direct link like:
    http://laitman.co.il/wp-content/plugins/nextgen-gallery/nggshow.php?pid=169&width=350&height=350
    I got empty page whth the same link dispayed on in as image (jpeg)
    Isn’t this the case when nggshow.php can’t find image by pid? Why could it happen?
    Please help…

    Thanx
    Dogen

    Take a look at this: http://sakinshrestha.com/wordpress/nextgen-gallery-plugin-and-thumbnail-generation-support/

    Do that and try to upload your photos again.

    Take a look at this: http://sakinshrestha.com/wordpress/nextgen-gallery-plugin-and-thumbnail-generation-support/

    Do that and try to upload your photos again.

    Thanx guys for all the recommendations.
    Anyway It never worked for me so I went on with the debugging, and found out interesting problemm:
    When thumb is actually created by nextgen-gallery/lib/gd.thumbnail.inc.php, it adds empty line before the image begining, and that’s what causes nggshow.php display empty image.
    Anybody know how can I fix it?

    Hi!

    I come back to the first entry by cvc1968.

    I can confirm, that WP-Minify breaks the edit thumbnail function.

    The solution for this is the following:

    Just enter this line in the field “URIs on which WP-Minify parsing will be disabled” in the WP-Minify-Options:

    wp-content/plugins/nextgen-gallery/nggshow.php

    Save the options. Now editing the thumbs in NextGEN will work again.

    Thanks a lot – it helped me with gallery 1.7.4 – now it works well.

    But when I upgrade to 1.8.2 it’s still broken (exactly just like Dogen says), so whenever I want to make thumbnails I need to downgrade to 1.7.4 and then reupgrade to 1.8.2 when they’re done…

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Plugin: NextGEN Gallery] Edit Thumb problem — conflict confirmed’ is closed to new replies.