WordPress.org

Support

Support » Plugins and Hacks » [Plugin: NextGEN Gallery] “Edit thumb” doesn’t show image to crop when functions.php exists

[Plugin: NextGEN Gallery] “Edit thumb” doesn’t show image to crop when functions.php exists

  • The “edit thumb” link for a gallery image does not display the image to be cropped (on the left side).

    I have checked a variety of possibilities but the only thing that seems to affect this issue is removing the functions.php file in my theme. I have tried using a functions.php that only contains <?php ?> and having the file be completely blank but as long as it exists the image does not show. Once functions.php is deleted the image shows fine.

    The url for the image is http://address.com/wp-content/plugins/nextgen-gallery/nggshow.php?pid=11&width=350&height=350. If I try to access that url directly the image does not load but I have checked the db and the gallery directory and everything looks as expected including permissions.

    Any help would be greatly appreciated. Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m having the same problem – it would seam it is related to the theme and funtion.php specifically… any body through any light on this issue..?

    I am having a similar situation, except in that the thumbnail will not edit when I try to go into the “Edit Thumbnail” mode.

    I have had it work with some thumbnails, and not with others…

    You need to save the functions.php in UTF-8 without BOM (Dos\Windows ANSI as UTF-8). Worked for me using Notepad++. Had the same problem with cropping thumbs.

    tried the UTF-8 but it wouldn´t do…
    the thumb is there but I can´t edit..

    is there any solution…?

    mike

    I have the same issue!
    The “edit image” button is missing, and i don´t know what to do anymore.
    2 weeks ago the wordpress was working fine, and suddenly is missing!
    I disabled all plugins, change theme, delete theme, and nothing happens!

    My functions.php is fine, without any change since i installed the theme.
    I increased the memory in my php.ini… and nothing!

    Any suggestions?

    I see the ‘edit thumb’ link, but when I click on it, no image appears on the left hand side so there is no way to edit the thumb. I tried re-saving my functions.php in UTF-8 without BOM, but that didn’t seem to fix it. Anyone else having this problem? Any ideas?

    I was able to fix the issue by going through the active plugins and removing all extra carriage returns.

    Same problem here, so I’ve been having to redo a lot of thumbs by hand. Such a pain. I’ve been searching for a solution for weeks, but nothing seems to work :/

    Are you trying this in Firefox?

    Atleast on my machine, that doesn’t happen while using FireFox. And I was under the impression that the Edit Thumbs link was removed for IE users since it had so many problems.

    Paul

    I´ve tried in Firefox, ie 8.0 and chrome..
    I have a few plugins, and i deleted all of them, and nothing happens…

    If i erase my wp-admin and wp-includes folders, and copy all of them again, i will lost all my posts? I will left my wp-content folder to mantain the theme, uploads and the plugins.

    My functions.php in theme folder seems ok, because when i installed the theme, i was able to generate the thumbnails, but i don´t know how, my edit button desappeared.

    I look at my upload folder and all my thumbs were generated until the edit button failed.
    And now, my uploads are only for the image and none thumbnails.

    Sorry for my bad english =(

    I appreciated any help!
    Tks a lot

    You can generate thumbnails by using the drop-down menu at the top above the list of pictures (says No Action then a button for apply, sort gallery and save changes). You will need to check all of the pics that you want this done for.

    As for the functions.php, it’s not about a corrupt file but rather the fact that their is one all together. For the OP the image to do the cropping on would not show unless he removed the file functions.php. Of course, this would mess up other parts of his site when he did that.

    For me all I have to do is navigate away from the page then back and I am able to see the image again.

    Paul

    I have the same issue… if I rename function.php then the thumb generation works, but once i put its name back its broken again.. This is fine workround for me, put this will not work for a client.. ;-(

    Anybody got any thoughts on what the solution to this might be..?

    ok.. so I read this thread again and realized what rogerchang meant, so i went through my functions.php and deleted all extra carriage returns and this has fixed it…

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Plugin: NextGEN Gallery] “Edit thumb” doesn’t show image to crop when functions.php exists’ is closed to new replies.
Skip to toolbar