[Plugin: NextGEN Gallery] Drag and Drop problem (28 posts)

  1. apek
    Posted 6 years ago #

    has anyone found solution for the drag and drop problem when create album?

    i try nextgen gallery version 1.21, 1.30 and 1.33 on wordpress 2.7 and 2.8. i still cannot solve the problem.

    Is this problem is because of the plugin or the wp itself?
    If anyone has nextgen gallery that working, especially can drag and drop while creating album please tell here what you wordpress version and what your nextgen gallery version.

    I really need to solve this ASAP because i am making a site for my client.

  2. apek
    Posted 6 years ago #


  3. apek
    Posted 6 years ago #

    hello? anyone know?

  4. ascension2020
    Posted 6 years ago #

    I'm having this same problem after upgrading to WP 2.8. I posted a thread on it yesterday. Hopefully the dev or someone good with code can figure it out.

  5. Alex Rabe
    Posted 6 years ago #

    Please disable all other plugins, they may cause a problem. Also check for any javascript failure, due to the fact that's a jQuery implementation

  6. rosebean
    Posted 6 years ago #

    I tried disabling all of my plugins but it's still not working. Still can't save changes to sorting order.

  7. baszer
    Posted 6 years ago #


  8. apek
    Posted 6 years ago #

    disabling all plugins?
    this problem still happening even nextgen is the ONLY plugin that i use in my WP.

    i really stuck now because there is no better gallery for WP except nextgen.But now this problem happen and i just dont know what else to do.

  9. fi
    Posted 6 years ago #

    I have this problem as well - seems to be browser independent as it occurs on both Firefox & Safari for the Mac.

    I have tried deactivating all other plugins and the problem remains. Can't get hold of any galleries or albums in order to drop them onto another album.

    I have v 1.3.3 on WP 2.8. Other settings are:

    Operating System : Linux
    Server : Apache/2
    Memory usage : 14.23 MByte
    MYSQL Version : 5.0.82-community
    SQL Mode : Not set
    PHP Version : 4.4.8
    PHP Safe Mode : Off
    PHP Allow URL fopen : On
    PHP Memory Limit : 32M
    PHP Max Upload Size : 2M
    PHP Max Post Size : 8M
    PHP Max Script Execute Time : 30s
    PHP Exif support : Yes ( V1.4 )
    PHP IPTC support : Yes
    PHP XML support : Yes

  10. apek
    Posted 6 years ago #

    i guess just have to wait till this big problem to be solved.

  11. Alex Rabe
    Posted 6 years ago #

    I don't have any problem here. so i need to debug it on your server /blog, if interested in a solution contact me by mail with a user/password account for your blog, I will do my best to solve the issue...

  12. apek
    Posted 6 years ago #

    what is your email? how can i email you..i really need your help

  13. apek
    Posted 6 years ago #

    i think i just email you. please check your inbox, i email to the address i found in your website.

  14. Alex Rabe
    Posted 6 years ago #

    as feedback : the problem is realted to a old jQuery script loaded by the theme. Switch to default theme if you have similar issues

  15. rosebean
    Posted 6 years ago #

    Switching to the default theme didn't solve the problem :(

  16. rosebean
    Posted 6 years ago #

    Anyone else have a solution to this?? Bummer not to be able to use the recent version of WordPress with this plugin.

  17. Alex Rabe
    Posted 6 years ago #

  18. girly-girl
    Posted 6 years ago #

    I think this may be what is happening to me as well - I can't "grap" my galleries to put them into an album. It was working fine till yesterday.

    There is a post here http://wordpress.org/support/topic/297077 where someone else and myself are mentioning this problem.

    I have 2 albums, 10 galleries and some 6000+ photos. I'm webmastering this site is for someone else and need to solve this problem.

    I checked that link up there Alex, (r=570) but don't know what to do with it? I went in and unselected a preview image for the galleries but it didn't help me any with the Album Management page - I also deactivated and reactivated all plugins plus NextGen but still bugged.

    Any help is greatly appreciated.

  19. girly-girl
    Posted 6 years ago #

    Thanks for the fix Alex, that's what's solved my Album Management page problems for me.

    For those (like me) that need things spelled out here are the steps.

    Go in to your dbase .../wp-content/plugins/nextgen-gallery/admin/album.php and modify this album.php as such - locate the line in the code that is:

    $picturelist = $wpdb->get_results("SELECT * FROM $wpdb->nggpictures ORDER BY pid DESC");

    with this line:

    $picturelist = $wpdb->get_results("SELECT t.*, tt.* FROM $wpdb->nggallery AS t INNER JOIN $wpdb->nggpictures AS tt ON t.gid = tt.galleryid WHERE tt.exclude != 1 GROUP BY tt.galleryid ORDER by tt.galleryid");

    Save and upload this edited album.php

    Thanks Alex Rabe for the fix!

    Have a look at 6000+ racing photos all wonderfully presented with custom modified albums and galleries via NextGen Gallery, http://www.cableguyphotos.com

    Thanks for a great plugin, the best gallery plugin out there...especially for me when you have to deal with so many pics!

  20. zzzreyes
    Posted 6 years ago #

    I did a complete uninstall and installed the latest, latest:
    this worked!

  21. smi1ey
    Posted 6 years ago #

    I have tried all the above steps, including the latest version of NextGen Gallery, and the issue is not resolved. I can drag Albums fine, but I cannot drag anything from the middle "Select gallery" field. In fact, if I drag a gallery from the Album area to the "Select gallery" area, I can't drag it out. Issue happens in multiple browsers on multiple machines (all Macs, if that means something).

    I'm not sure how the theme would effect it, considering the theme isn't used in the admin panel, where the issue is occurring. But I changed to default anyways with no change. Anyone else still having this trouble? I can't offer login info because this is for an internal site for a major corporation.

  22. kstadden
    Posted 6 years ago #

    NextGEN is a wonderful plugin and it's frustrating that this is broken for me too. Specifically, dragging a gallery from the left and dropping it onto my album has no effect. I have three plugins installed and am reluctant to disable them: cforms, WordPress.com stats, and Twitter Widget Pro. Judging from the experiences of others, the problem may lie elsewhere. Alex, may I suggest that it might be a good idea to provide a workaround method for those of us who can't drag and drop, for whatever reason. I don't care if it's a clunky workaround as long as it works.

  23. blackwaterus
    Posted 6 years ago #

    I have this problem or a variation of it. I also could not drag galleries into albums. But I found a clunky workaround that works for me. For some reason, when I select "show all" galleries, rather than the default view that only shows galleries that are not assigned to an album, I am able to drag the galleries into albums. Maybe this will work for others. At least I am able to still put galleries into albums.

  24. jamie.wilsons
    Posted 6 years ago #

    What fixed it for me was removing the '@' symbol from the admin/wp25/album.php (Line 115).

    So from this:
    to this:

    It appears in a few other files, so if you have something like Notepad++, do the 'Find in Files' and just get rid of that '@' symbol - the new JQuery doesn't like it.

  25. Piotr
    Posted 5 years ago #


    got still the same/ similar problem.

    this is how it's looks:

    and shall like that:

    no way to drag and drop.
    WP ver: 2.8.6
    NG ver: 1.4.3

    mentioned above fixes are already in album.php, ver 1.4.3 :///

    Any support welcomed!

  26. Piotr
    Posted 5 years ago #

    It is caused by theme, it's use:
    jQuery library
    superFish dropdown
    jQuery Corner
    jQuery Form
    DD Belated PNG fix for IE6
    jQuery prettyPhoto
    jQuery Validate

    Any idea how to sort this out as I must use this theme and want nextgen as well.

  27. newportcreativegroup
    Posted 5 years ago #

    Just started having the same problem. Turns out the conflict was with TinyMCE Advanced. Which is very strange b/c that plugina and Nextgen Gallery have been happily co-existing for months now and I didn't upgrade either recently. I'm going to do some debugging and figure out what's going on and I'll post back here what I find.

  28. jonathanhoff
    Posted 5 years ago #

    Dear all,

    I know this thread has been dead for 10 months but I am having simliar troubles with Next Gen - I can't drag galleries into albums.

    I am using WP 3.0 and Next Gen 1.5.5 and I am with Bluehost. I checked the PHP line fix in album.php and it is different to both those listed above but I presume Alex has fixed the bug since then...

    Any ideas?!

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.